Page 51 of 63 FirstFirst ... 41 49 50 51 52 53 61 ... LastLast
Results 501 to 510 of 626
  1. #501
    ROG Enthusiast Array ELZZZORRO's Avatar
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    53

    Seriously, No sense of urgency?

    Seriously, no sense of urgency? Over 34,000 views, issue reported way over a month ago on this thread and no formal response from the manufacturer? This is my 1st Asus Gaming Laptop and I am not impressed for what I am reading on this magnificent forum.

    Do I care about a laptop sound performance? Not really, however, my kid sits next to me sometimes with her $200 Chrome book, and let me tell ya, when she asks me: Daddy, why does your $2500 Laptop sound like crap compared to mine? it bugs the sh*t out of me.

    Please, ASUS; FIX IT!!!

    Click image for larger version. 

Name:	No sense of urgency.jpg 
Views:	7 
Size:	66.0 KB 
ID:	45693

  2. #502
    ROG Guru: Orange Belt Array
    Join Date
    Jul 2012
    Reputation
    10
    Posts
    308

    Asus please , when is the fix. please prioritize this...

  3. #503
    ROG Guru: Yellow Belt Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    234

    You know things are bad when the speakers on my ASUS Transformer Flip LP300 are better than what I had on the G751. (A $599 2-in-1 13.3" Laptop beats a $1499 17" gaming powerhouse.)

  4. #504
    ROG Guru: White Belt Array
    Join Date
    Aug 2012
    Reputation
    10
    Posts
    102

    This is absurdity. Always when I want buy laptop - I always advise ASUS . I bought a few Asus laptop but G series(flagship) has still problem with audio. Asus G75 has/had problem with audio / G750 has/had problems with audio /G751 has problems with audio. WTF? My opinion on the asus is really really bad. I don't want back my Asus - but I don't see other way.

  5. #505
    ROG Enthusiast Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    43

    Quote Originally Posted by thamann2000 View Post
    It's quiet!! Everyone return their systems or just waiting extra patiently?
    My extra patiently is gone...... Now I'm just waiting

    Quote Originally Posted by BRSxIgnition View Post
    Sorry, I cant actively help test anything since I've sent my G751 back. (And bought an Nvidia Greenbox GTX + Asus Transformer Flip in its place for just a little bit more.)

    I hope those of you that are keeping your machines end up getting working fixes, though!
    I think I speak for most, if not all of us when I say thanks for all your time and effort helping to figure this out BRSxignition....hopefully it wasn't for nothing
    Last edited by fabrimacator21; 01-20-2015 at 11:32 AM.

  6. #506
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    8

    I have returned mine a long time ago. Very, very disappointed by this entire ordeal and lack of action.

  7. #507
    ROG Enthusiast Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    38

    finally I have bought it
    sound is greater than expected, but with loud sounds >> I notice sounds like vibrations from the subwoofer
    I used subwoofer disabling tool, but this prevents the vibrations but makes sound less loud >> is that normal?
    I have read at the start of this thread "Fix Being Worked On! (New Driver + UI)" >> which dirver you mean? the subwoofer disabling tool? or you got a new driver that fix the problem
    Last edited by Adly2010; 01-20-2015 at 12:41 PM.

  8. #508
    ROG Guru: White Belt Array
    Join Date
    Jan 2014
    Reputation
    10
    Posts
    118

    There's the possibility that it's a hardware problem and will never be fixed. (no, the G750 didn't have that kind of sound troubles : at most, there was a tiny bug in the Realtek drivers installer that disabled MaxxAudio, for some models in some countries : mine - French model - was OK from the beginning)
    I really can't understand why the G751 could be SO different from the G750, for example.

    on a desktop, when you buy a 2.1 sound system, it's just "stereo" for Windows. you plug the cable in the "stereo" output of the motherboard or sound card (like a Creative Labs Sound Blaster) it's the hardware that redirects low frequencies to the "boomer" (or "subwoofer" ); the driver does nothing.

    remember, many people returned their G750 because of screen problems (vertical lines in grey shades).... this was never fixed. (only "tweaked" by newer drivers)
    and then the G751 came out.
    Last edited by KoolASUS; 01-20-2015 at 04:36 PM.

  9. #509
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    66

    BRS. you did everything you could with this forum and I did everything i could with the corporate office. I chatted no less than 30 times. Made over a dozen calls. Filed 12 escalation. Contacted the BBB twice. And send no less than 40 emails. Although i admit I wanted to push asus the hardest and try to get all of us to sue or make a statement I always hoped the end result would be it would just work.

    Tragic that asus cared so little in the end.

  10. #510
    New ROGer Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    2

    im sooo afraid if its hardware problem. what should i gonna do if it is?
    i couldn't send back im staying in malaysia! and i use it for work! X_X
    ASUSSSSSSSSSSS......................WHY...........

Page 51 of 63 FirstFirst ... 41 49 50 51 52 53 61 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •