Results 1 to 10 of 13

Threaded View

  1. #1
    New ROGer Array
    Join Date
    Nov 2014

    Lightbulb Installing Arch Linux on my G751-JY

    I've been an Arch Linux far for a few years. Here is how I installed in a dual boot configuration with Windows 8.1 on my new G751 laptop. This sounds much more complicated than it is. Much of it comes from the excellent Arch wiki.

    • I first downloaded few live CD disks from various distributions to see if this was even possible. I tried, Mint, Ubuntu, Fedora, and Suse. The only one that gave me trouble was Ubuntu.
    • I found that for any distribution that you install, you have to add "nomodeset" to kernal options. This is because modern versions of Linux try to load the nouveau display driver, and that driver doesn't yet support the GTX980m.
    • nomodeset stops the open source graphics driver from installing and instead you will get sofeware rendering graphics. You will get a blank screen if you don't. This is fine for install. The laptop is even fast enough for it to be usable in this mode. After linux is running you can install the Nvidia drivers. (recommended) For now, nouveau isn't an option for this laptop.
    • Conclusion - Linux should work.

    Reinstall Windows
    • This step really isn't necessary.
    • I first reinstalled Windows 8.1 using instructions found elsewhere on the site to do it on the G750. This went fairly well. In fact it was less complicated than doing it as described on the G750. I did this to get rid of the little bit of bloatware and to remove the Windows hidden partitions (if any).
    • Make sure you download the Asus utility to backup the 2 recovery partitions to a USB. There is a driver install process that makes rebuilding Windows very easy if you do this.
    • I first unplugged the 1T drive. This keeps Windows from putting a hidden partition on it when you reinstall.
    • I used the Windows install process to remove the 2 NTFS partitions on the M.2 SSD . I created a new partition for Windows and left the rest of the drive unformatted. As noted above, I didn't touch the EFI, and the two recovery partitions. (they take up little space)
    • The Windows activation code is built into the laptop's firmware. Windows never asked for it and it automatically reactivated.
    • I finished up the windows install and rebooted. On the recovery USB that I created , there is an install process to put all the Asus drivers back on the machine. At this point it is pretty much back to factory conditions except with a clean version of Windows installed. The ROG G751 destop background image is also found on this recovery partiton.
    • Finally I disabled fast boot in Windows and in the UEFI.
    • I preceded to the linux install.

    Partitioning & prep. for Linux
    • I reinstalled the 1T drive.
    • Turn off secure boot.
    • I booted up a Linux rescue disk/usb (there are several out there) so that I could use gparted to partition the remaining disks. This also requires nomodeset in order to get non-accel. graphics to come up.
    • I added two partitions to the M.2 SSD. 100M for /boot and the remainder for /. /boot is formated as ext2, / = ext4.
    • The 1T drive is split between Windows & Linux. I formatted the Windows partition as NTFS. I created a small, 40G partition for /var and formatted it ext4. The remainder of the drive went to /home also ext4.
    • At this point I rebooted. Windows picked up the new partition without issue, but I had to go to disk administrator and reassign it to "D". The optical disk was moved to "E".

    Arch Installation
    • Installed ARCH following the instructions (beginners) in the wiki. It uses 4 partitions from above, /, /boot, /home, /var. The latter two are on the 1T drive.
    • I didn't use grub. I find it overly complicated for a UEFI machine. Instead I used rEFInd. When you boot, rEFInd automatically finds every bootable image, even on removable media, and presents a nice graphical interface for it. It even allows you to go directly to the UEFI/BIOS settings for the laptop. Configuration is with a simple text file.
    • rEFIN\nd gets installed to the EFI partition. The arch install for it worked well. Nothing from linux gets installed onto this partition and you normally will not need to access it again. I did remove the drivers for NTFS & EXT4 so rEFIN\nd won't scan these drives for install images.
    • Changed the laptop boot settings to boot rEFInd first, and the Windows loader 2nd. (you could even delete the Windows loader if you liked)
    • Rebooted laptop. rEFInd boot graphic comes up almost instantly. It showed Windows 8.1 & Arch linux as options to boot. Both worked.

    Graphics & Desktop Environment.
    • To get graphics to work, I had to install nvidia-beta as noted in the wiki. On Arch, this always pulls the latest beta driver from Nvidia. Currenly this is nvidia-beta 346.16-1.
    • As noted in the Nvidia release notes. 346.16-1 is the first release to support the GTX970m/980m mobile GPUs.
    • I installed the gnome3 desktop. I am a XFCE user, but I thought that I'd try this on this new laptop. I had briefly tried the Cinammon desktop from Mint, but I didn't care much for it. Arch doesn't dictate a DE. They officially support numerous options.
    • Rebooted and was happy that graphics came up fine. No issues with either wired or wireless networking.
    • I updated ARCH to current software and rebooted again. From this point he laptop works fine but I have a couple of remaining issues.

    Currently the backlight keys don't work. I've done some research on this but haven't hit the right solution yet. The backlight can be controlled using the xbacklight command. Adding "acpi_osi=" to the kernel options causes linux to recognize the brightness keys, but it doesn't change the brightness and it breaks xbacklight. I suspect it might be the beta Nvidia drivers are not handling this properly.

    The touchpad isn't working correctly. I haven't really tried to diagnose this as I've got a gaming mouse installed. I might get back to it. Some of the ASUS gaming keys are not recognized. This isn't surprising, and I haven't really researched it either. Beyond that, the laptop does everything that I need it to do under Linux.

    Hopefully this helps anyone wanting to try it. Please feel free to ask questions.
    Last edited by blackcat77; 12-07-2014 at 05:15 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts