Results 1 to 2 of 2
  1. #1
    ROG Enthusiast Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    55

    Question Max IV Extreme-Z Error B2, not booting at all!

    Hi everyone!

    My system:
    Asus Maximus IV Extreme-Z
    Intel Core i7 2600K
    4x4GB Ripjaws X
    OCZ Vertex 3 Max Iops for system
    Seagate 3TB for storage

    Until yesterday I had 2x EVGA GTX580 Hydrocopper 2, then I installed 2x Inno3D GTX 970.
    I also changed some cables for a cleaner look.

    Now my problem: the PC won't even boot into bios. It gets stuck on Error Code B2 "Legacy option ROM initialization", no ASUS logo, no BIOS, nothing. The monitor only shows something about "Nvidia Geforce GTX 970 BIOS", nothing I can do.

    The boot device LED is RED, no idea why, I once got into the mainboard BIOS after switching to BIOS 2, all HDDs were recognized.
    I then tried booting from the DVD to install Windows, and it got stuck again on B2.

    I tried clearing CMOS, but it didn't work so far. I havent pulled out the battery yet though.
    I also tried plugging in a USB stick with the 3603 BIOS (which was installed before), but it didn't do anything.

    Any advice? Is my GPU Bios not compatible with the mainboard bios? Is my mainboard bios messed up?

    Help please!
    Miniatura de Adjuntos Miniatura de Adjuntos 2014-12-07 18.35.24.jpg  


  2. #2
    ROG Enthusiast Array chevy350 PC Specs
    chevy350 PC Specs
    MotherboardAsus ROG Strix X470-F
    Processor2700X
    Memory (part number)G.Skill Trident Z 3600
    Graphics Card #1XFX RX580
    Graphics Card #2Zotac GTX 550Ti
    MonitorAcer KG240 & AOC S24D300
    Storage #1OCZ RD400
    Storage #2Samsung 950 Pro 256Gb
    CPU CoolerKraken X62
    Case750D
    Power SupplySeaSonic Platinum 860W
    Keyboard Razer Black Widow
    Mouse J-Tech Digital Verticle Mouse
    Headset Arctis 7
    Mouse Pad Corsair
    Headset/Speakers Corsair 1500
    OS Win 10 x64
    chevy350's Avatar
    Join Date
    Jan 2012
    Reputation
    10
    Posts
    67

    Booting with UEFI maybe? Not well versed on Nvidia cards but does it have dual bios or a bios switch? Just wondering as some of the ref 290x's have a legacy bios and a uefi bios. Seems like it's trying to boot from the card. I have the same board but a 290x, used both card bios and no issues booting with either.
    AMD 2700, Asus ROG Strix X470-F, Samsung 2133@3200 (4gbx4), XFX R9 390X, NZXT Kraken X62, Corsair 750D, SeaSonic 860W, Samsung 950 Pro 256Gb, 2 Intel 520 120Gb SSD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •