Page 4 of 4 FirstFirst ... 2 3 4
Results 31 to 39 of 39
  1. #31
    ROG Member Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    11

    I got a problem with graphics performance after updating to the latest driver which runs the screen on 75 hz. I got really crap 3dmark scores like 6000. If i restart the pc i get good scores like 8500. The problem was the nvidia battery boost. If i disconnect and reconnect the pc to the ac adapter the card is still running on low performance. The solution was to simply disable the battery boost option in the geforce experience. The weird thing is that i didnt get this problem with the previous driver.

  2. #32
    ROG Enthusiast Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    33

    sunny474 thanks for suggestion. I got the same with old driver! After manually changing the refresh rate i got lower performance... Are you sure is this all about battery boost?

  3. #33
    ROG Member Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    11

    Nope,i get the same score both with the older driver which runs the screen on 60hz and with the newer which is 75hz. Approximately 8500. Dunno why you got different scores with different drivers. I just spotted a problem with battery boost. If i unplug the ac adapter and plug it back to the pc the card doesnt get back to it's default performance. That's why i got a score with 6k. Disabling the battery boost solved this issue. Now if i unplug and replug the adapter it can go back to it's deffault performance without rebooting the system.
    My problem was just a silly power management problem.
    The only thing which i encountered so far with the 980m is the annoying coil whine in some games. Such an annoying noise.

  4. #34
    ROG Enthusiast Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    29

    I have a G751JT. Before I install any nVidia drivers, the display rate was reported as 64Hz (?!). After I installed the latest nVidia driver from the nVidia site I get 60Hz. Is there any specifics that you do, guys, to get the 75Hz by default ? Would it be safe to run at custom 75Hz, having that I don't get them by default ?

  5. #35
    ROG Guru: White Belt Array
    Join Date
    Nov 2014
    Reputation
    9
    Posts
    100

    Does anyone have a definitive answer on whether or not running 100hz can ruin the monitor if it seemingly works? MarshalIR commented that inverted pixels can happen which which is pretty bad.

  6. #36
    ROG Guru: Yellow Belt Array
    Join Date
    Dec 2014
    Reputation
    8
    Posts
    131

    New driver, still 75Hz but still no overclocking

  7. #37
    ROG Enthusiast Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    49

    My problem is that even after creating a custom resolution of 1920x1080, in-game, for example, GTA IV EFLC shows only 75 Hz options for all resolutions.

  8. #38
    ROG Member Array
    Join Date
    Oct 2014
    Reputation
    10
    Posts
    7

    Can anybody please confirm that the IPS screen in the g751jt is capable of working full-time at 75 Hz ? It would be a shame to run it at that frequency and after some time to discover the screen is ruined .

  9. #39
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    I've gotten myself a red dot (pixel) on the screen.. Not sure when or why

    I guess this will be the 3rd time it goes back for RMA ...
    The King of the north!

Page 4 of 4 FirstFirst ... 2 3 4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •