Results 1 to 4 of 4
  1. #1
    New ROGer Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    2

    Can't boot from DVD on new ROG G20

    This machine is running Windows 8.1 in SecureBoot. I can get into BIOS/UEFI and disable SecureBoot (by going to Key Management and disabling the SecureBoot keys), then enabling CSM, changing boot order to the DVD, setting the Other OS rather than Windows UEFI and still it won't boot from the DVD. It just ignores it and then brings me back to BIOS. I would like to install Linux but can't unless I can boot from a device other than the HDD.

    Hopefully someone has done this before. It's possible, although unlikely, that the BIOS/UEFI is somehow corrupt and the machine just won't boot from alternate devices.

    This is driving me crazy.

  2. #2
    ROG Guru: Black Belt Array toronto699 PC Specs
    toronto699 PC Specs
    Laptop (Model)G752-VY-DH78K , G751-JYDH72X
    MotherboardRog Tytan G30AB
    Processori7-4770K
    Memory (part number)32GB
    Graphics Card #1Asus Gold20th GTX980Ti
    Sound CardDell X-Fi Audigy SoundBlaster
    Monitor3 Acer K272HL
    Storage #1118 GB/OS
    Storage #22.72 TB
    CPU CoolerIntegrated Liquid-Cooled CPU
    CaseG30AB
    Power SupplyAsus 700 Watt
    Keyboard Razer BlackWidow Ultimate
    Mouse Razer Diamond Back
    Headset Sony Studio Professional , Razer Seiren Mic
    Mouse Pad Razer FireFly
    Headset/Speakers Logittech 5.1 Z-5500
    OS W 10
    Network RouterSagemon Fast 5250 Hub 2000

    Join Date
    Aug 2014
    Reputation
    74
    Posts
    2,415

    Last edited by toronto699; 12-28-2014 at 12:31 AM.

  3. #3
    New ROGer Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    2

    Neither the thread nor the driver page had anything to help me :-(

    I'm starting to think that the BIOS is just not working correctly. Booting from DVD is really not a big deal if SecureBoot isn't running but now the DVD doesn't even show up as an option. I've gotten 5 different boot options at once, all of which are Windows Boot Manager. I wonder if there is something wrong with the motherboard.
    Last edited by rashley; 12-28-2014 at 03:17 AM.

  4. #4
    New ROGer Array
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    2

    Quote Originally Posted by rashley View Post
    Neither the thread nor the driver page had anything to help me :-(

    I'm starting to think that the BIOS is just not working correctly. Booting from DVD is really not a big deal if SecureBoot isn't running but now the DVD doesn't even show up as an option. I've gotten 5 different boot options at once, all of which are Windows Boot Manager. I wonder if there is something wrong with the motherboard.
    Hi,

    Did you find a solution for this? I had 5 boot devices, but after disabling some and setting DVD player as first boot priority, it booted from dvd , but after going back in the bios after a reboot I can only see 3 boot devices and the DVDs is not there anymore and my to shiva drive also disappeared from the boot priority list. Any ideas?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •