Page 2 of 2 FirstFirst 1 2
Results 11 to 19 of 19
  1. #11
    ROG Member Array BlackSteel PC Specs
    BlackSteel PC Specs
    MotherboardAsus ROG Maximus V Formula Z77 (Bios 1903)
    ProcessorIntel I7 3770k 4.7 @ 1.320v (Delid & Water Cooled)
    Memory (part number)Corsair Dominator Platinum 16gb 2133Mhz
    Graphics Card #1Evga Nvidia 980ti SC 6GB (Water Cooled)
    Graphics Card #2Evga Nvidia 980ti SC 6GB (Water Cooled)
    Sound CardCreative Soundblaster ZX
    MonitorAsus PG278Q ROG Swift 27"
    Storage #1Samsung 840 Pro 128gb
    Storage #2Samsung 850 Pro 512gb
    CPU CoolerCustom WC - EK 360 XTX + EK 140 XTC + EK 280 XTC + EK-Dual Bay RES D5 Vario
    CaseEnermax Fulmo GT - Modded
    Power SupplyCorsair AX1200i
    Keyboard Corsair K70 RGB - Cherry mx brown's with O-ring mod
    Mouse Razor Deathadder 2013
    Headset Sennheiser PC 350 SE
    Mouse Pad Razer Goliathus Control 2014 (Large)
    Headset/Speakers Logitech z5500 Digital 5.1
    OS Win7 x64
    Accessory #1 ROCCAT Apuri - Active USB Hub with Mouse Bungee

    Join Date
    Dec 2012
    Reputation
    11
    Posts
    19

    Just wanted to say,

    980ti fixed this problem for me.
    Why would i ride the swing's when i've already been to DisneyLand..

  2. #12
    ROG Member Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    6

    960 fixed the problem for me

  3. #13
    ROG Guru: Yellow Belt Array Crasje's Avatar
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    129

    i have the 980TI, just upgraded MB to the Maximus IX Formula and I still have it...

    *
    Cooler Master Cosmos II (with glass side panel)
    Cooler Master Silent Pro Hybrid 1300W ATX
    ROG Asus Maximus IX Formula
    Intel Core i7-7700k
    Corsair Hydro Series H115i CPU Cooler
    Corsair Vengeance LED 32GB 3000Mhz
    Samsung 960 EVO 500GB NVME M.2 SSD
    Crucial SSD M500 480GB
    Seagate Firecuda 1TB
    Samsung SH-224DB (SATA, 24x)
    ROG Strix Gaming GTX980Ti DC30C 6GD5
    Monitor 1: ASUS ROG Swift PG348Q
    Monitor 2: Samsung HDTV T27D590
    ROG Claymore
    ROG Spatha
    ROG Balteus Qi
    Windows 10

  4. #14
    New ROGer Array
    Join Date
    Jun 2014
    Reputation
    10
    Posts
    1

    Hi, I'm not able to see bios with displayport on my Asus MG279Q, I have a GTX 780 SLI, Is there any solution for this problem? I have tried all possible solutiins I have read, Thanks

  5. #15
    New ROGer Array
    Join Date
    Dec 2017
    Reputation
    10
    Posts
    2

    Unhappy Rog strix gtx1080 AG edition not displaying pos screen with display port...

    Rog strix gtx1080 AG edition not displaying pos screen with display port...

    Same issue here, any ideas? Solutions?

  6. #16
    ROG Guru: White Belt Array wolfy PC Specs
    wolfy PC Specs
    Laptop (Model)Acer swift 3
    MotherboardROG Maximus XI Formula
    ProcessorI9 9900K
    Memory (part number)4x 4 GB kingston hype X DDR4 @3000mhz
    Graphics Card #1Auros 2080 super 8GB
    Monitordell 34" curved+23"ASUS +21" iiyama touch
    Storage #1250 GB M.2 NVMe Samsung+1 500gb M.2
    Storage #22 x 500 ssd +1 x 250GB ssd ocz
    CPU CoolerEKWB watercooling
    CasePhanteks enthoo Primo
    Power SupplyCorsair 1000W
    Keyboard Razor Black widow Chroma
    Mouse Razor Mamba Chroma
    Headset/Speakers Razor /Logitech
    OS Win 10 Pro

    Join Date
    Jun 2011
    Reputation
    12
    Posts
    98

    turn CSM to off in bios this sorts it, well it did for me i have a 1080ti
    ROG MAXIMUS XI FORMULA
    CPU: Intel 9900K @4.7 ghz
    4X8GB fury x ddr4 ram @3000
    1 x Aurous 2080Super 8GB
    1x 250GB Samsung M.2 NVMe
    1x 500GB Samsung M.2l SSD
    2 X 500 GB OCZ SSD
    1000w PSU from corsair
    tower phanteks enthoo primo
    1 x dell 34" curved + 2x 20"
    cpu
    water cooled by EKWB

  7. #17
    New ROGer Array
    Join Date
    Oct 2018
    Reputation
    10
    Posts
    1

    Confirmation this solution works...

    This is still a problem as of Oct 2018 and I can confirm that this solution works. Had the same problem with a Rampage 6 extreme, 2 980ti poseidons and Swift PG348. Bios would only display to my TV via HDMI, disabled CSM per your suggestion and it solved the problem...bios displays on swift monitor only through DP , HDMI kicks on and becomes visible once its at the Windows login screen (at the proper resolution as well, before when i unplugged the TV the splash screen would display ROG logo blown up at way lower resolution on the swift) . Just heed OP's advice and make sure your boot device is UEFI or you're gonna run into a problem. THANK YOU dude, I'd tried everything I knew to do and it was starting to drive me nuts! lol

    Quote Originally Posted by pr1me View Post
    This is a little bit of a Necro but,

    I somehow solved this problem with my board (it may or may not be useful for other boards)
    I have:
    Maximus vii formula (z97).
    Rog swift (DP).
    Qnix qx2710 (DVI).
    Gtx Titan.
    Win 8.1 x64 (UEFI install)
    The bios would always boot on the Qnix (when both monitor are connected).
    The bios would boot on the swift only when it's alone with no other monitor connected to the graphic card.

    I had to change the CSM (Compatibility Support Module) from Enabled to Auto.
    and black magic happenned, the bios grab the swift as main display, even when both monitor are connected.
    Either Auto or disabled would make it work (which disable compatibility and full support secure boot).
    I'm coming from a Rampage III Extreme with old bios, so im not 100% sure if the other uefi bios have this option or not.


    Cheers


    .
    Attachment 49666
    Last edited by Neighborofthebeast668; 10-21-2018 at 05:57 AM.

  8. #18
    ROG Member Array
    Join Date
    Jan 2018
    Reputation
    10
    Posts
    5

    The problem is probably with older Nvidia Graphic cards:
    Please update firmware of your graphic card.

    The problem will be resolved as it was resolved for my computer:

    https://www.nvidia.com/object/nv-uefi-update-x64.html

  9. #19
    ROG Junior Member Array Cinder09 PC Specs
    Cinder09 PC Specs
    MotherboardHero X wifi/Ac
    ProcessorI7 8700k
    Memory (part number)Corsair Vengeance 3000mhz
    Graphics Card #1Aorus 1080Ti
    Sound CardCreative AE-5
    MonitorTuf VG32VQ
    CPU CoolerNzxt X62 Kraken
    Power SupplyCorsair 1200i
    Keyboard Corsair K68
    Mouse Corsair M65
    Headset Hyper X Cloud 2
    Mouse Pad ROG Sheath
    Headset/Speakers Logitech 5.1
    OS Windows 10
    Cinder09's Avatar
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    2

    Quote Originally Posted by falcon291 View Post
    The problem is probably with older Nvidia Graphic cards:
    Please update firmware of your graphic card.

    The problem will be resolved as it was resolved for my computer:

    https://www.nvidia.com/object/nv-uefi-update-x64.html
    Omg thank you ive been having this problem now for 2 months and this fixed it

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •