Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    6

    G751JY problem with left usb ports

    Hello,

    I recently bought a G751JY, and all in all I think it is simply marvellous. Still, when I tried to connect the ROG mouse bundled with the game, it was not recognized the first time I plugged it in. Next, I connected a USB3 external drive, but I did not manage to have it recognized. When I attached it to one of the USB ports on the right side, everything worked like a charm.

    I already tried to uninstall/reinstall the device from the device manager, I also tried to uninstall/reinstall the usb hub, but to no avail.

    Any ideas before I call support?

    Thanks

    Enrico

  2. #2
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2013
    Reputation
    10
    Posts
    220

    The King of the north!

  3. #3
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    6

    Worked perfectly, thank you!

  4. #4
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    5

    Hi.
    I have the same problem with G751JT but I already have 205 BIOS version.
    Can I try something else ?

    Thanks

  5. #5
    ROG Member Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    14

    Update the bios will not solve the problem.
    Asus doesn't have an solutions this is the truth.
    Watch My Video

    https://www.youtube.com/watch?v=LR9KMVT4c_g

    Return it is the best you can do

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •