Results 1 to 10 of 10

Thread: Disable G-sync

  1. #1
    New ROGer Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    4

    Disable G-sync

    Hi,

    In some games I would like to have G-sync off and get high FPS. I can`t seem to disable G-sync, is it permanently enabled?

    For eg) Playing CSGO, cap at 144hz with G-sync enabled when in full screen, and yes its smooth, but I would like higher FPS. If I play in windowed mode, the stutter is unplayable but obv G-sync is OFF.

    Just not sure if there is something I am missing, I have turned G-sync OFF in the Nvidia settings... Just would like to know if it can be disabled.


    Thanks
    Last edited by yoloswag420; 01-16-2015 at 07:32 PM.

  2. #2
    ROG Guru: Yellow Belt Array Volt PC Specs
    Volt PC Specs
    MotherboardGIGABYTE G1.Sniper Z97 ATX
    Processori7-4790K 4.0 GHz
    Memory (part number)ADATA 32GB (8GBx4) DDR3/1600MHz
    Graphics Card #1nVidia Gefroce GTX 1080 w/8 GB
    Sound CardMotherboard G1 - Creative Sound Core3D
    MonitorASUS Rog PG348Q Swift
    Storage #1250 GB Samsung 850 Pro
    Storage #22TB Western Digital Caviar Black SATA-III
    CPU CoolerAsetek 550LC 120mm Liquid Cooling
    CaseCorsair Obsidian 750D
    Keyboard Corsair K70 STRAFE
    Mouse Logitech Pro
    OS Win 10
    Network RouterASUS RT-AC88U
    Volt's Avatar
    Join Date
    Nov 2014
    Reputation
    12
    Posts
    172

    Yes it can be disabled.

    There was a bug with Civilization : Beyond Earth that would not allow you to have screen resolutions beyond 1024x768 with g-sync turned on. I think I had to click the option off in the monitor settings, to do so.

    But there might be a button on the monitor to turn that on/off. I might be confusing it with the 60/120/144 turbo key. Or there might be an option to enable/disable it for a particular game using the "Nvidia GeForce Experience" software.

  3. #3
    ROG Guru: Yellow Belt Array Volt PC Specs
    Volt PC Specs
    MotherboardGIGABYTE G1.Sniper Z97 ATX
    Processori7-4790K 4.0 GHz
    Memory (part number)ADATA 32GB (8GBx4) DDR3/1600MHz
    Graphics Card #1nVidia Gefroce GTX 1080 w/8 GB
    Sound CardMotherboard G1 - Creative Sound Core3D
    MonitorASUS Rog PG348Q Swift
    Storage #1250 GB Samsung 850 Pro
    Storage #22TB Western Digital Caviar Black SATA-III
    CPU CoolerAsetek 550LC 120mm Liquid Cooling
    CaseCorsair Obsidian 750D
    Keyboard Corsair K70 STRAFE
    Mouse Logitech Pro
    OS Win 10
    Network RouterASUS RT-AC88U
    Volt's Avatar
    Join Date
    Nov 2014
    Reputation
    12
    Posts
    172

    This guy shows how to enable g-sync using nvidia control panel settings. So do what he does, in reverse.

    Although you probably already have done so.

    https://www.youtube.com/watch?v=1L6xpfGjBNo

    Maybe running CSGO in window maximized mode could be a way to disable gsync? For it's not really full screen mode. And gsync needs it to be full screen to work.

  4. #4
    New ROGer Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    4

    Hi,

    Yes I have tried the above, and it still turns itself back on lol.

    The problem with playing any games in a window, is I get stuttering, feels like FPS drops. Thought it might of been my drivers but that didnt solve the issue.

    Wondering if there is a fault? How would I find out if it is faulty? Although its only a few games that this happens.
    Last edited by yoloswag420; 01-16-2015 at 10:33 PM.

  5. #5
    ROG Guru: Yellow Belt Array Volt PC Specs
    Volt PC Specs
    MotherboardGIGABYTE G1.Sniper Z97 ATX
    Processori7-4790K 4.0 GHz
    Memory (part number)ADATA 32GB (8GBx4) DDR3/1600MHz
    Graphics Card #1nVidia Gefroce GTX 1080 w/8 GB
    Sound CardMotherboard G1 - Creative Sound Core3D
    MonitorASUS Rog PG348Q Swift
    Storage #1250 GB Samsung 850 Pro
    Storage #22TB Western Digital Caviar Black SATA-III
    CPU CoolerAsetek 550LC 120mm Liquid Cooling
    CaseCorsair Obsidian 750D
    Keyboard Corsair K70 STRAFE
    Mouse Logitech Pro
    OS Win 10
    Network RouterASUS RT-AC88U
    Volt's Avatar
    Join Date
    Nov 2014
    Reputation
    12
    Posts
    172

    Sounds like a bug then. Do you have the most recent nVidia drivers?

    Another workaround might be to enable VSync within CSGO. For I think VSync is suppose to be turned off in order for GSync to work. If the red light in the lower part of your monitor changes to a different color, then gsync is no longer active.

  6. #6
    New ROGer Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    4

    I just tried that, and still it forces itself back on lolol. Its like its doing what it wants to, and not what I want it to do

    Its a pretty weird problem

  7. #7
    New ROGer Array
    Join Date
    Nov 2012
    Reputation
    10
    Posts
    2

    yoloswag420 i have the same problem .
    Put the monitor to 120hz disable g sync on nvidia control panel but when i enter any game it turn on again and the monitor automaticaly go for 144hz.
    WTF is happening , already uninstall and install nvidia drivers.

  8. #8
    New ROGer Array
    Join Date
    Jan 2015
    Reputation
    10
    Posts
    4

    Quote Originally Posted by estevesfr View Post
    yoloswag420 i have the same problem .
    Put the monitor to 120hz disable g sync on nvidia control panel but when i enter any game it turn on again and the monitor automaticaly go for 144hz.
    WTF is happening , already uninstall and install nvidia drivers.
    Yup, its annoying af lol. Also some games if I play in window mode, that stops G-sync but the game stutters.

    I don`t know where to look for the answer so I am contacting Asus about it.

  9. #9
    ROG Guru: Yellow Belt Array Volt PC Specs
    Volt PC Specs
    MotherboardGIGABYTE G1.Sniper Z97 ATX
    Processori7-4790K 4.0 GHz
    Memory (part number)ADATA 32GB (8GBx4) DDR3/1600MHz
    Graphics Card #1nVidia Gefroce GTX 1080 w/8 GB
    Sound CardMotherboard G1 - Creative Sound Core3D
    MonitorASUS Rog PG348Q Swift
    Storage #1250 GB Samsung 850 Pro
    Storage #22TB Western Digital Caviar Black SATA-III
    CPU CoolerAsetek 550LC 120mm Liquid Cooling
    CaseCorsair Obsidian 750D
    Keyboard Corsair K70 STRAFE
    Mouse Logitech Pro
    OS Win 10
    Network RouterASUS RT-AC88U
    Volt's Avatar
    Join Date
    Nov 2014
    Reputation
    12
    Posts
    172

    It's working for me. I experimented a little bit with it today. Here is what I did.

    1 - I opened up the NVIDIA Control Panel.
    2 - Under Display/Set up G-SYNC toggeled off the check box for Enable G-SYNC
    3 - An Apply and Cancel button showed up in the lower left of the window. I hit Apply.
    4 - I then started a game.

    I've only tried it with 2 games so far. Life is Feudal and Fry Cry 4. When I went in those games, I ahd a white button instead of a red button, in my Swift's lower right screen. Also the visible Fraps FPS display fluctuated past 144 at certain times.

    When I went back to desktop to enable g-sync in the nvidia control panel and hit apply, to get it back, I had to restart the game for it to be g-synced.

    For reference I'm using a gtx 970, driver version 347.09, Win 8.1
    Last edited by Volt; 01-18-2015 at 03:57 AM.

  10. #10
    ROG Guru: Yellow Belt Array Deon017 PC Specs
    Deon017 PC Specs
    MotherboardASUS Rampage IV Extreme Black Motherboard
    ProcessorIntel Core i7 4960X Extreme Edition
    Memory (part number)Corsair Vengeance Pro CMY32GX3M4A2133C11 32GB
    Graphics Card #1Asus Poseidon GTX 980Ti
    MonitorAsus Rog Swift 27" 3D Monitor
    Storage #1ASUS RAIDR Express 240GB PCI-E SSD
    Storage #2HDD: Intel 520S 240GB SSD
    CPU CoolerEK Supremacy Elite CPU Waterblock for Intel 2011
    CaseCorsair Obsidian 900D Super Tower Case
    Power SupplyCorsair AX1200i Digital ATX Modular Power Supply
    Keyboard Logitech G19s Gaming Keyboard
    Mouse Asus ROG Gladius
    OS WIN 10
    Network RouterAsus RT-AC3200
    Deon017's Avatar
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    147

    Quote Originally Posted by Volt View Post
    It's working for me. I experimented a little bit with it today. Here is what I did.

    1 - I opened up the NVIDIA Control Panel.
    2 - Under Display/Set up G-SYNC toggeled off the check box for Enable G-SYNC
    3 - An Apply and Cancel button showed up in the lower left of the window. I hit Apply.
    4 - I then started a game.
    I have done this with The Crew as the game has a maximum of 60fps and getting screen tearing - it does disable G-Sync as you explained, just have to re-enable it again after.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •