Page 1 of 2 1 2 LastLast
Results 1 to 10 of 15
  1. #1
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    11

    G751JY, yes, sitting at 800 MHZ & frustrated

    Hi all. I have read a gazillion threads on this site over the past few days, but none really seem to answer the question, so now I am poting for the gurus for elp.

    How do I make my G751JY run faster than 800 MHZ, all the time?
    My HP Envy has the same CPU which always runs in turbo mode at 33X & the cores never more than 33C.
    I have a now ta laptop that is twice as expensive as my Envy, with twice the RAM, 980 Nvidea 4GB GPU over the 760 2GB Nvidea GPU, yet my gamer PC runs, not just benchmark, but actually slower than my HP non gamer PC.

    So, I have 2 questions,

    1: How do I make it run faster, ALL the time
    2: Side note, the Asus website for downloads & support leaves much to be desired, how do I make recovery discs, or do I have to order discs from Asus, & if so, where?

    Thanks for any help in advance.
    Please help me get over my very impending buyers remorse!

    Oh, I am running BIOS 206.

  2. #2
    ROG Enthusiast Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    62

    check the power management, there should be a cpu power management.
    Set the minimum power Level to 100% and it won't clock down anymore.
    I hope you know what I meant...my Win is german.

    Though this does not make sense in my opinion, the cpu will change the clock according to the application and load

  3. #3
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    10

    For recovery, use AsusBacktracker. You'll need a thumb drive atleast 16GB, I'd get a 32GB just in case.

  4. #4
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    4

    at the energy saving power profile it runs max 800mhz
    just set it to max performance or max power or however its called in english (german os to, sry )

  5. #5
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    11

    Thanks & oops, forgot to mention, min & max CPU set for 100%.
    I understand throttling back, but, 800 MHZ, wicked too slow.
    Any other ideas?

  6. #6
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    492

    I do not fully understand what your problem is with the CPU clocks. Is your CPU staying at 800Mhz all the time ? Or does it also go into full Turbo Mode to 3300-3400Mhz ? If it does so, there might just be a problem with the Power Plan. If the CPU is always on 800Mhz then we should search for other possible solutions.

    By the way, your CPU will be fast enough even with a "Balanced" Power plan because it will automatically Downclock and Upclock depending on the usage scenario. I am always using "Balanced" profile, even while I am gaming and I have never felt stutters or that my CPU isn't fast enough. In my honest opinion, it is useless to keep the CPU at 33x-34x all the time for normal usage scenarios. It may be useful in some other special cases, like benchmarking or rendering.

  7. #7
    ROG Member Array
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    11

    It constantly stays at 800MHZ, it is very sluggish.
    I have my power plan set to high performance.
    i'm not a pc idiot, but this rog just does not seem fast as my non gamer HP envy.
    I ran far cry 4 & tabbed to see my cpu speed, no change.
    Big time buyers remorse so far.

  8. #8
    ROG Guru: Orange Belt Array
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    492

    Don't worry! It doesn;t run ike that normally. Have you bought a freedos notebook or did you bought one with OS already installed ? Because this might be a driver related issue. Also, you could download Intel XTU and see if your clock ratios aren't changed by something. In Intel XTU you should check "Manual tunning ---> All Controls" and see if the clock ratio for your CPU are set to 8x instead of 33/34/35x .

    Maybe share some screenshots from Intel XTU or from CPU-Z or HWInfo to see how your CPU clock is changing.

  9. #9
    ROG Guru: Green Belt Array
    Join Date
    Dec 2014
    Reputation
    32
    Posts
    533

    Also check your thermals... there is a chance you have a bad paste job / fan something along those lines keeping you are a reduced operating state. You can use the apps NotroX mentioned in the previous post.

  10. #10
    ROG Enthusiast Array
    Join Date
    Dec 2014
    Reputation
    12
    Posts
    38

    Is there anyway you might be confusing RAM frequency with CPU frequency? The reason I ask is because the DRAM frequency is at 800 Mhz, and cpu is at x33 to x35 multiplier at high power setting wich equates to 3300-3500 Mhz. The only time it drops down to 800 Mhz is when I set my laptop to power saver setting. Are you running any other battery management software perchance? It sounds like something is throttling your CPU. Could you post cpu-z, HW monitor screenies please?

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •