Results 1 to 6 of 6
  1. #1
    ROG Member Array
    Join Date
    Apr 2015
    Reputation
    9
    Posts
    6

    G750JM - Not powering up!

    Hello everyone.

    I'm trying to get my girlfriend'ss new machine (a few days old) to turn on/power up,
    but nothing happens. Currently the battery led is flashing as if it's charging. So far I've
    tried to turn it on both with and without the battery but nothing happens when I press the
    power button. From what I understand from her, the machine had finished a bunch of updates
    when it was shut down and then left to fully charge.

    I have no clue to what is wrong currently so some advice would be appreciated, however I do suspect
    that the bios was automatically flashed while it was updating which could be the cause to the problem.

    Thank you in advance.


    /Zora
    Last edited by Zora; 04-12-2015 at 01:02 AM.

  2. #2
    ROG Guru: Platinum Belt Array hmscott PC Specs
    hmscott PC Specs
    Laptop (Model)Asus G750JH-DB71 (legacy)
    MotherboardAsus G750JH Intel HM87
    ProcessorIntel i7-4700HQ XTU Cores 36x/35x/34x/34x Cache 36x -50mV undervolt
    Memory (part number)Hyundai Electronics HMT41GS6AFR8A-PB 1.35v DDR3L-1600MHz
    Graphics Card #1Nvidia 780m Asus GPU Tweak OC 932mhz/6300mhz
    Sound CardRealtek v6.0.1.7469 driver
    MonitorAUO B173HW02 V1 Custom Refresh 85hz
    Storage #1RAID0 2x M.2 SATA Crucial MX200 512GB CT500MX200SSD6
    Storage #2Crucial 512GB 2.5" MX200 CT500MX200SSD1
    Power Supply230w AC Power Adapter 19.5v
    Keyboard Logitech k400 Wireless KB/Trackpad
    Headset Sony MDR-XB500 Wired and Sennheiser RS-220 Wireless TOSLINK
    OS Windows 8.1 + 8 Linux VM's + Windows 10 Technical Preview
    Network RouterAsus RT-AC68U DLINK DIR-655

    Join Date
    Jun 2013
    Reputation
    44
    Posts
    5,357

    Quote Originally Posted by Zora View Post
    Hello everyone.
    I'm trying to get my girlfriend'ss new machine (a few days old) to turn on/power up,
    but nothing happens. Currently the battery led is flashing as if it's charging. So far I've
    tried to turn it on both with and without the battery but nothing happens when I press the
    power button. From what I understand from her, the machine had finished a bunch of updates
    when it was shut down and then left to fully charge.

    I have no clue to what is wrong currently so some advice would be appreciated, however I do suspect
    that the bios was automatically flashed while it was updating which could be the cause to the problem.

    Thank you in advance.

    /Zora
    Hi Zora, the charging light shouldn't be blinking, that is an indicator that something is wrong with charging.

    You can try a power reset. Power down, pull out the power cable from the laptop, pull out the battery, and then press and hold the Power button for 20 sec to 1 minute - then put it back together and try powering up.

    If that doesn't work, you should take back the laptop to where you bought it, explain the problem, and ask for a new in the box replacement.

    Please come back and let us know how it works out

  3. #3
    New ROGer Array
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    2

    I got a brand new G750jw delivered this afternoon, can't even witch it on, just black screen and no drive activity

  4. #4
    ROG Guru: Platinum Belt Array hmscott PC Specs
    hmscott PC Specs
    Laptop (Model)Asus G750JH-DB71 (legacy)
    MotherboardAsus G750JH Intel HM87
    ProcessorIntel i7-4700HQ XTU Cores 36x/35x/34x/34x Cache 36x -50mV undervolt
    Memory (part number)Hyundai Electronics HMT41GS6AFR8A-PB 1.35v DDR3L-1600MHz
    Graphics Card #1Nvidia 780m Asus GPU Tweak OC 932mhz/6300mhz
    Sound CardRealtek v6.0.1.7469 driver
    MonitorAUO B173HW02 V1 Custom Refresh 85hz
    Storage #1RAID0 2x M.2 SATA Crucial MX200 512GB CT500MX200SSD6
    Storage #2Crucial 512GB 2.5" MX200 CT500MX200SSD1
    Power Supply230w AC Power Adapter 19.5v
    Keyboard Logitech k400 Wireless KB/Trackpad
    Headset Sony MDR-XB500 Wired and Sennheiser RS-220 Wireless TOSLINK
    OS Windows 8.1 + 8 Linux VM's + Windows 10 Technical Preview
    Network RouterAsus RT-AC68U DLINK DIR-655

    Join Date
    Jun 2013
    Reputation
    44
    Posts
    5,357

    Quote Originally Posted by deanosbeano View Post
    I got a brand new G750jw delivered this afternoon, can't even witch it on, just black screen and no drive activity
    deanosbeano, did you plug it in? The battery may have discharged during storage. When you plug it in does the 2nd light from the left turn Green - showing it is charging?

    Leave it charge for an hour or two and try again.

    If that doesn't work you can try the Power reset, pull the power cable, take out the battery, and press and hold the Power Button for 30 seconds to 1 minute and then put it back together and try to power up again.

    If it still won't power up, report it as DOA to the seller and get a replacement.

  5. #5
    ROG Guru: Orange Belt Array
    Join Date
    Sep 2013
    Reputation
    11
    Posts
    320

    Hi,
    i get the blinking light if i have shutdown from a new mavericks install without a proper power management.
    it was resolved by just unplugging from the power and then physically removing the battery for a few seconds.
    Asus G750JX-CV050H||GTX770M||24GB ram||120hz 3D screen||
    1TB Samsung 840 EVO SSD||500GB Crucial M4 SSD||500GB Crucial M4 SSD in DVD Bay
    free bag and mouse
    win 8.1||win 7||win xp||server 2008||os x mavericks||linux mint 16

  6. #6
    ROG Member Array
    Join Date
    Apr 2015
    Reputation
    9
    Posts
    6

    Quote Originally Posted by hmscott View Post
    Hi Zora, the charging light shouldn't be blinking, that is an indicator that something is wrong with charging.

    You can try a power reset. Power down, pull out the power cable from the laptop, pull out the battery, and then press and hold the Power button for 20 sec to 1 minute - then put it back together and try powering up.

    If that doesn't work, you should take back the laptop to where you bought it, explain the problem, and ask for a new in the box replacement.

    Please come back and let us know how it works out
    We ended up with having to file an RMA case on it. Turns out the the motherboard was faulty and was replaced.
    However, now the laptop is having an occassional issue where it won't begin to charge unless the AC adapter has been
    pulled from the socket and back in - sort of saying it seems like the AC adapter needs to be "reset" from time to time.
    Otherwise there haven't been other issues since she got it home.

    /Z

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •