Results 1 to 10 of 10
  1. #1
    armystrong
    Guest

    My new Asus g53sw xn1 having Wifi issues!

    Just got it and I am mind blown how awesome it is but I can't even get 1mb download while my phone in my hand is getting 25mbps. Also I don't know how to install drivers and stuff and need help!

    Thank-you!

  2. #2
    ROG Guru: Black Belt Array JRd1st's Avatar
    Join Date
    Aug 2011
    Reputation
    28
    Posts
    2,224

    Go here - http://www.asusrog.com/forums/showth...eros-WiFi-Card and follow the instructions.

    ALSO, you may have to open the bottom of your notebook to make sure the antenna wires are connected to your WiFi card . . .

    MAke sure you have an Atheros Card, first. I assume you do since the performance sucks. lol
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  3. #3
    armystrong
    Guest
    Ehhh I don't want to open it up I seen how hard it is on Youtube. Does it void the warranty?

  4. #4
    ROG Guru: Blue Belt Array fuzon1337's Avatar
    Join Date
    Sep 2011
    Reputation
    18
    Posts
    878

    It is no problem to open up your notebook. It is 2 screws under your notebook that you have to screw out and voila, you can open up (square panel). I don't think it wil void warranty since you have the opportunity to upgrade RAM and WiFI card
    Asus G73SW-91058V 3D
    - Intel Centrino Ultimate-N 6300
    - BIOS 205

  5. #5
    armystrong
    Guest
    Ok thank-you if nothing else works I will do!

  6. #6
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    If it's getting a connection, but it's just slow.....I seriously doubt that the antennas are loose. It just sounds like a driver configuration issue to me.

  7. #7
    armystrong
    Guest
    It's weird at one moment google chrome would be getting 15mbps and firefox 1mbps than the next firefox will be fast and chrome slow... I downloaded Portal from steam in about 30 minutes. Is it a browser issue?

  8. #8
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    Quote Originally Posted by armystrong View Post
    It's weird at one moment google chrome would be getting 15mbps and firefox 1mbps than the next firefox will be fast and chrome slow... I downloaded Portal from steam in about 30 minutes. Is it a browser issue?
    If the slowdown is intermittent, it could be your internet connection being flaky or it could be an issue in the connection between the laptop and your router. These are completely different & unrelated problems, so to narrow down the troubleshooting, forget about internet speeds for now and focus on the wireless connection to your router.

    • Take a look at the Wireless Network Connection status window. (Click the wireless icon in the notification area, right-click on your network, and select "Status.")
      -> What speed does it show there?
      -> Check it frequently to see whether it fluctuates much.
    • Log onto your router. Check the logs for error entries that indicate your laptop connection is being frequently de-authorized or otherwise disconnected.

  9. #9
    armystrong
    Guest
    It's not my router because I had my family's laptop and this side beside and I was testing use my iPhone too.

  10. #10
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    I wasn't suggesting there's something wrong with your router. I was suggesting that you need to determine whether the problem actually lies in the wireless connection (and therefore the settings) between the G53 and the router. You can't use internet speeds to evaluate that, because there are too many other factors that can impact the internet speeds.

Similar Threads

  1. New WiFi Card to G73
    By fuzon1337 in forum G Series Gaming Notebooks
    Replies: 7
    Last Post: 11-20-2011, 09:08 AM
  2. G74sx-dh73-3d Wifi issues... :(
    By Lismail0 in forum G Series Gaming Notebooks
    Replies: 5
    Last Post: 11-02-2011, 03:50 AM
  3. Options for replacing the Atheros wifi card G53SW
    By mrmcgoo in forum G Series Gaming Notebooks
    Replies: 9
    Last Post: 10-06-2011, 11:50 AM
  4. ROG connect (can't get it to work on WIFI)
    By bullydog in forum Other Series Motherboards
    Replies: 7
    Last Post: 09-10-2011, 05:58 AM
  5. G53SW touchpad issues
    By Donald_W in forum G Series Gaming Notebooks
    Replies: 16
    Last Post: 09-09-2011, 08:20 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •