Results 1 to 3 of 3
  1. #1
    ROG Junior Member Array
    Join Date
    Apr 2015
    Reputation
    10
    Posts
    2

    Cool 2013 Asus Rampage extreme IV Not Running Asus Matrix GTX 980 sli in Pcie 3.0

    Hello Everyone,

    This is my first post ever and I'm looking for help with my Asus GTX Matrix 980's in Sli.

    I have an Asus Rampage Extreme IV, I bought new in 2013 and yesterday I up graded my video cards to Asus GTX matrix 980's in sli, I put them in the proper slots and before I installed them I up dated my Bios to the latest update, everything is running great except in my GPUZ, it is still running PCEI 2.0, any advice would be greatly appreciated.

    My System

    Asus Rampage extreme IV
    64g DDr3 1600 MHZ
    I7 3940 cpu
    2x Asus Matrix GTX 980's
    3X 27" ASUS Monitors
    3x500G Samsung SSd
    2X2TB 7200 RPM HD

  2. #2
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,254

    There is an exploit to enable PCIe 3.0 on the X79 platform. Shouldn't be hard to google.

  3. #3
    ROG Guru: Brown Belt Array Antronman's Avatar
    Join Date
    Dec 2013
    Reputation
    29
    Posts
    1,374

    It is actually now listed as officially supported.

    Before, it was not. Now, it is.

    Maybe you need a BIOS update?

    Either that, or check your BIOS menu.
    Say hi to the next generation.

    Peace is a lie, there is only Passion
    Through passion, I gain strength
    Through strength, I gain victory
    Through victory, my chains are broken
    The Republic of Gamers shall free me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •