Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
  1. #11
    freezeex
    Guest
    I did bring it to bestbuy. But I didn't show them how it crash when rest I res my plam on it. It start at random time, I just can't control it. For now, its fine when I put some pressure. but I know its going to happen again.

  2. #12
    freezeex
    Guest
    Since the problem is still not solved, should I just contact the ASUS for an repair?
    Its 3 month old now so I think there is still a factory warranty right?

  3. #13
    ROG Guru: White Belt Array
    Join Date
    Sep 2010
    Reputation
    10
    Posts
    75

    Freezeex yes you have Factory warranty.

    see http://www.asusrog.com/forums/showth...rranty-amp-RMA for contact details on getting your RMA processed, you may have to go through the tech support routine before they hand you a RMA number but no big problems there since it sounds like the pressure is revealing a hardware defect with your motherboard... be it a short circuit from something pressing on it or components losing contact due to a solder joint I couldn't tell ya off hand.

  4. #14
    freezeex
    Guest
    I just realize that the heat is also a part of a matter.
    but, thx I will fill up the RMA form and see how it goes

Page 2 of 2 FirstFirst 1 2

Similar Threads

  1. G71GX-RX05 Problem
    By Pmadison in forum GX/GM/GU Series Gaming Notebooks
    Replies: 6
    Last Post: 03-30-2011, 03:20 AM
  2. AC Power Supply Problem
    By thumper64 in forum G Series Gaming Notebooks
    Replies: 9
    Last Post: 12-30-2010, 03:28 AM
  3. Rampage Formula extreme boot problem
    By dittopb in forum Other Series Motherboards
    Replies: 2
    Last Post: 11-26-2010, 05:04 PM
  4. Problem with overclocking programs with R3E
    By AnthonyLackey in forum Overclocking & Tweaking
    Replies: 3
    Last Post: 08-05-2010, 04:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •