Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    May 2015

    Love the G751JT-CH71 Laptop (Just have some minor issues)

    So a few months ago I purchased the Asus ROG G751JT-CH71 and I absolutely love it. I have no major issues with this laptop, it runs everything I've thrown at it beyond acceptably. The screen is beautiful, the keyboard feels right and it just overall looks and feels like a high end laptop.

    That being said I have a few issues that I'm unsure of.

    1. My start up time is quick for not having an SSD installed... However I have noticed that although it starts up quick, if I open a web browser (Chrome specifically) it refuses to connect to the internet for around 15-30 seconds. This makes no sense to me as I have the LAN cable plugged directly into the port. I don't quite understand the delay here. To go more in depth. I start up > log in > give it a few seconds to warm itself up > open Chrome > no connection even though the connection is visible in the bottom saying connected. This isn't just a chrome problem either. It is the same on IE and Firefox.

    2. This thing is a fingerprint/screen smudge monster. What do you guys use to clean your screen and keyboards? This isn't really an issue I just find myself having to wipe the screen/keyboard down weekly.

    3. Although I didn't buy this PC specifically for the game, I am a big time League of Legends player. We're talking 12 hour sessions weekly and a few hours daily after work. I know this isn't the right spot for this but it bothers me more than anything else. Every few matches or sometimes EVERY match when I hit the "Continue" button at the end of the match to take me back to the scores and stats screen, the Launcher doesn't show up. Nothing shows up. Just my desktop and whatever I have running in the background. The only way I can get back to the launcher is by ending the LoLPatcher in my processes and restarting the entire game. I have reinstalled the entire game twice. I have tried the fixer. I have tried many fixes, but it always happens. No matter what I try. This would be the icing on the cake if anyone knew the answer to this.

    Other than those minor issues (which I'm positive are fixable), I would 100% buy another ROG in the future.

  2. #2
    ROG Member Array ATXmax PC Specs
    ATXmax PC Specs
    Laptop (Model)G751JM
    MotherboardASUSTeK COMPUTER INC.
    ProcessorIntel Core i7-4710HQ @3.5GHz
    Memory (part number)Corsair Vengeance 16GB
    Graphics Card #1NVIDIA GeForce 860m
    Graphics Card #2Intel HD Graphics 4600
    Monitor17" Touch Screen
    Storage #11TB HDD 5400 RPM
    Storage #2Travelstar 1TB 7200 RPM
    OS Windows 8.1

    Join Date
    Apr 2014

    1. Welcome to laptop gaming buddy. I have issues with the wifi occasionally as well, my solution is to just sign out, then sign back in. Worse case scenerio I'll do a quick restart.

    2. I found some electronic wipes at walmart for $5 that work really well, other than that idk what to tell you. I've had 3 ROG laptops and they are all like that.

    3. Sounds like yet another game poorly optimized for our systems, but I can't tell you for sure.

  3. #3
    ROG Member Array
    Join Date
    Mar 2015

    Your network ,even with cable need time to settle services. You can try disable DHCP on your network card like this:

    - Network sharing center -> change adapter setting (upper left) -> find your Ethernet adapter -> Details -> write IP4 address, subnet mask, Getway and DNS.
    - Go one back and scrol to "Internet protocol ver.4" -> "Use the following ..." and type in your IP4 , subnet mask and Getway
    - Now enable last 2 fields and type in DNS settings (one will be ok.)

    Save everything and reboot. If this will work faster then it is your router problem. in fact it is not problem, your router is little slower.

    If that does not work create new file on desktop with .bat extension and edit it. Inside copy paste:

    ping -t

    and save. You can put it in "start up" folder (start->programs->startup), and reboot.

    on start up black terminal will open and untill you get :

    Reply from bytes=32 time=8ms TTL=60

    or something similar (Reply from "some IP") you do NOT have connection to the internet.
    If you have ping response but no Internet in Browser, it is browser issue, mostly with wrong proxy or something.

    Try this first, and i am sorry if this is too much detail but if you know these stuff just ignore my post.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts