Results 1 to 6 of 6
  1. #1
    New ROGer Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    1

    Games Lag ( FPS drops) on my Asus ROG G501JW

    Specs are GTX 960 4 GB , I7 4720HQ , 12 GB ram , I tried playing AC 4, Far Cry 3 , Even Battlefield Bad Company all on low , and it still lags . Help please

  2. #2
    ROG Member Array
    Join Date
    May 2015
    Reputation
    10
    Posts
    10

    are you playing on battery? or while plugged in? if you're playing on battery then don't expect to get the best performance since the battery cannot full support the hardware since its quite heavy. sorry for the bad english

  3. #3
    ROG Enthusiast Array
    Join Date
    Jul 2015
    Reputation
    10
    Posts
    26

    i wonder its like that/ but on the lenovo Y50 the fps is much better even when unplugged where as the specs of the G501 is better and more updated than that of lenovo Y50
    (((((((((((

  4. #4
    ROG Guru: Black Belt Array toronto699 PC Specs
    toronto699 PC Specs
    Laptop (Model)G752-VY-DH78K , G751-JYDH72X
    MotherboardRog Tytan G30AB
    Processori7-4770K
    Memory (part number)32GB
    Graphics Card #1Asus Gold20th GTX980Ti
    Sound CardDell X-Fi Audigy SoundBlaster
    Monitor3 Acer K272HL
    Storage #1118 GB/OS
    Storage #22.72 TB
    CPU CoolerIntegrated Liquid-Cooled CPU
    CaseG30AB
    Power SupplyAsus 700 Watt
    Keyboard Razer BlackWidow Ultimate
    Mouse Razer Diamond Back
    Headset Sony Studio Professional , Razer Seiren Mic
    Mouse Pad Razer FireFly
    Headset/Speakers Logittech 5.1 Z-5500
    OS W 10
    Network RouterSagemon Fast 5250 Hub 2000

    Join Date
    Aug 2014
    Reputation
    74
    Posts
    2,394

    is Gamefirst lll on your g501, if it is try uninstalling it ,

  5. #5
    ROG Member Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    6

    Quote Originally Posted by HiImJr View Post
    Specs are GTX 960 4 GB , I7 4720HQ , 12 GB ram , I tried playing AC 4, Far Cry 3 , Even Battlefield Bad Company all on low , and it still lags . Help please
    Try checking what GPU you are using, sometimes it launches the games using the integrated graphics card. To do that, you have to check your Nvidia control panel.

  6. #6
    ROG Enthusiast Array kaps26's Avatar
    Join Date
    Jul 2015
    Reputation
    10
    Posts
    28


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •