Results 1 to 7 of 7
  1. #1
    ROG Member Array
    Join Date
    Sep 2011
    Reputation
    10
    Posts
    17

    G-73 Sw Monitor not starting up; blank display!

    My laptop monitor just would not start up today. I have tried to start it quite a few times today. I stayed up till 2 today to do a project and when I woke up, everything except the monitor would start up. There would be nothing on display, it would just be blank. Mine is a G-73 Sw. I am pretty frustrated as it has been less than six months since I bought it and I feel like it is a waste. It did not come cheap with a $1300 price tag, especially considering I am still a student. I am really bummed. Can anyone help me out here?

    I really hope it is not the GPU..... and I hope that the monitor issue is easily fixable. Could it be faulty LCD? I hope it is nothing too bad.

    Any help is appreciated. Thanks!

  2. #2
    ROG Guru: Black Belt Array JRd1st's Avatar
    Join Date
    Aug 2011
    Reputation
    28
    Posts
    2,224

    Could be the GPU, the cable going to the display, the display, or a driver gone bad. Do you have an external monitor or tv with hdmi you could try?
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  3. #3
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    Quote Originally Posted by Devilonearth666 View Post
    My laptop monitor just would not start up today. I have tried to start it quite a few times today. I stayed up till 2 today to do a project and when I woke up, everything except the monitor would start up. There would be nothing on display, it would just be blank. Mine is a G-73 Sw. I am pretty frustrated as it has been less than six months since I bought it and I feel like it is a waste. It did not come cheap with a $1300 price tag, especially considering I am still a student. I am really bummed. Can anyone help me out here?

    I really hope it is not the GPU..... and I hope that the monitor issue is easily fixable. Could it be faulty LCD? I hope it is nothing too bad.

    Any help is appreciated. Thanks!
    When you first power it up, do you see the Asus logo? Can you press F2 and access the BIOS? If there's no display even before you boot Windows, that would suggest a hardware failure of the sort JR described. If you can get it to display anything...the BIOS, or perhaps try a bootable disc.....then Windows might be the problem.

  4. #4
    ROG Member Array
    Join Date
    Sep 2011
    Reputation
    10
    Posts
    17

    No, I do not see the asus logo, or anything for that matter. The problem started just 10 hours after my last session with it, i closed it at 2, it was all good, no sign of trouble and when i tried to power it up at 12 at noon, it would not display anything? So, what is the best fix in this situation? I doubt it is the GPU, I've never had any problems with it. The LCD display also worked smooth, though there were quite a few visible dead pixels.

    and no, I do not have an external monitor with HDMI

  5. #5
    ROG Guru: Black Belt Array JRd1st's Avatar
    Join Date
    Aug 2011
    Reputation
    28
    Posts
    2,224

    How about an external monitor with VGA?

    Do you feel like it's booting but with no display? Or that it shuts down? Or that it's stuck in a bad bootup?
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  6. #6
    ROG Member Array
    Join Date
    Nov 2011
    Reputation
    10
    Posts
    23

    Multiple people on this forum seem to be having this problem, myself included. You will probably have to rma.

    Search "black screen" or "blank display", weird thing is that they are all different g notebooks.

  7. #7
    ROG Guru: Black Belt Array
    Join Date
    Oct 2011
    Reputation
    31
    Posts
    2,916

    Quote Originally Posted by Devilonearth666 View Post
    No, I do not see the asus logo, or anything for that matter. The problem started just 10 hours after my last session with it, i closed it at 2, it was all good, no sign of trouble and when i tried to power it up at 12 at noon, it would not display anything? So, what is the best fix in this situation? I doubt it is the GPU, I've never had any problems with it. The LCD display also worked smooth, though there were quite a few visible dead pixels.

    and no, I do not have an external monitor with HDMI
    Unfortunately, there's not much you can try without a working display. As JR mentiioned, I would make every effort to determine whether you can get any video on an external monitor. That would be very helpful diagnostically, as it suggests whether the GPU itself is simply not functioning, or whether it's a problem with the built-in monitor and/or it connections.

    You could try opening it up to check the connections between the M/B and the display panel, but that's a shot in the dark (so to speak). You may just have to RMA it.

Similar Threads

  1. Blank Screen with G1sn
    By clexidra in forum G Series Gaming Notebooks
    Replies: 5
    Last Post: 10-09-2011, 05:13 PM
  2. Replies: 4
    Last Post: 08-27-2011, 03:19 PM
  3. G73H Suddenly Starting to Overheat
    By Lou Chou in forum G Series Gaming Notebooks
    Replies: 1
    Last Post: 08-07-2011, 02:48 AM
  4. 12 secs before starting BIOS
    By t3chn0l0g1c in forum Other Series Motherboards
    Replies: 8
    Last Post: 02-28-2011, 06:07 PM
  5. Replies: 1
    Last Post: 02-03-2011, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •