Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    2

    Motion blur problem with my swift.

    I was using it one day like normal and I noticed that the motion blur was extremely high for no reason on the 144hz setting. Using 60hz and 120hz without ULMB had less motion blur than 144hz. Tried different cables/GPUs/Motherboards.

    Has anyone else encountered this issue ? Should I RMA it ?

  2. #2
    Ex-employee Array
    Join Date
    Jun 2020
    Reputation
    108
    Posts
    2,154

    Hi Danny,

    You have the ROG SWIFT PG278Q, correct? The monitor has 1ms response time and is optimized to reduce any type of motion blur. Most people that have this monitor have reported to have very fluid gameplay at 144Hz with low to no motion blur.

    Here's a very good review below:
    http://forums.blurbusters.com/viewtopic.php?f=5&t=1177

    How many games have you tried so far? Have you experienced this issue in each game?

    Cheers,
    Bahz
    Last edited by Bahz; 06-19-2015 at 07:11 AM.

  3. #3
    New ROGer Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    2

    I have played CSGO alone for over 1.5k hours on this monitor, I noticed easily when something was wrong with the motion blur. Turning left and right caused more motion blur than my second 60hz monitor with the motion blur setting on. I cant tell tell the different between the 60hz and 144hz motion blur tests on blurbusters.com

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •