Results 1 to 2 of 2
  1. #1
    ROG Enthusiast Array InFAMAS-ONE PC Specs
    InFAMAS-ONE PC Specs
    Laptop (Model)N/A
    MotherboardRampage V Extreme
    Processori7 5960X
    Memory (part number)Corsair Vengeance 64GB 2400Mhz
    Graphics Card #1ROG-STRIX-GTX1080TI-011G-GAMING
    Graphics Card #2ROG-STRIX-GTX1080TI-011G-GAMING
    MonitorASUS ROG PG278Q
    Storage #1Samsung 960 Evo M2
    CaseRaijintek NYX Pro
    Power SupplyCorsair AX1200i
    Mouse ROG Spatha
    OS Win 10 Pro x64
    InFAMAS-ONE's Avatar
    Join Date
    Apr 2014
    Reputation
    11
    Posts
    68

    Drivers Needed! Specifically for Windows 10

    Greetings.

    I would like to make a plea to ASUS / ASUS ROG to keep on top of drivers.

    Pretty much my entire system is ROG products, am I am a little disturbed by how irregular driver updates are, and how this can quickly cause problems.

    I'll explain a little...

    I have a RAIDR express. I also use a RAMDISK (ASUS RAMDISK), and SSD Tweakit will not find my RAMDISK if I want to Auto-optimize.
    It used to, but now that the actual RAMDISK software has been updated, SSD Tweakit can't recognise the RAMDISK I have created anymore.. The RAIDR has been out for some time, and there have been no revisions to SSD Tweakit since the product was launched.
    I am using this as an operating drive, and now that I have Windows 10, it doesn't look like the optimise functions are doing anything at all, even if I
    manually direct everything to my RAMDISK from inside SSD Tweakit.

    Then there's GPU Tweak. I am currently using v2.8.3.0. This installed fine, and when I restarted my PC after installation, it popped up like it should.
    It will not however recocnise my GPU's (Does not display GPU in top-right). If I try to Overclock my cards, the next time I start Windows, GPU Tweak will not start.
    It will not auto-run on start up, nor can I get it to run by trying to open the application manually.

    Like other people, I am also experiencing frustration over DTS Interactive 5.1 not working. Apparently this has been going on since Windows 10 was first opened up to the community as a trial version. I know my board uses a Realtek audio device, so it would fall on Realtek to ensure the driver works. Sadly, as it's on an ASUS board, it is partly your responsibility too, ASUS.

    I understand that you guys may not be aware of such things unless the community puts forth these problems on your forums, and as we are doing so now, I hope you will be swift in improving the software for all your products.
    However, I must state that it has been no secret that Windows 10 has been in development for some time, and was soon to be released.
    Many companies have released drivers that they have developed through communication with Microsoft in anticipation for the release of Windows 10.
    I would expect no less from ASUS and ASUS ROG. I have only found a handful of Windows 10 drivers on the ASUS website for my Motherboard, but there are still no Windows 10 drivers/utilities for anything else. I aknowledge that writing software drivers for a new operating system is a BIG job, and with the launch of a new O.S. there are bound to be a few problems.
    Your products are by far my favorite in terms of sheer performance and quality. Please don't let out-dated drivers and software render
    your fantastic products a waste of money.

    I hope I have not been out of line here, and that you will take this simple request seriously, and it'd be nice if there were some news about any planned revisions, and when we could expect them.

    Many thanks, System specs below:
    Last edited by InFAMAS-ONE; 08-06-2015 at 09:31 PM.

  2. #2
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    111
    Posts
    4,182

    Well these forums are users helping users, there are on occasion CL Customer Loyalty Representatives that drop in sometimes. That said I would keep an eye open at Asus Support Downloads for updated drivers and contact Asus through Support to insure they are advised of the issue. So far you are the first to post about this issue. One thing you could try would be to run the program in compatibility mode that might help out.
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •