Results 1 to 6 of 6
  1. #1
    ROG Member Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    6

    G750JX Backlight Keyboard not working

    Title says it all but here's a more detailed explaination of what I did:
    I just got my pc back from an RMA and I found that they formatted it. No big deal: did ALL the updates, reinstalled 8.1, updated everything again, then I go on and download BIOS 209 from the Asus siteand Flash it in with Winflash. Everything went well except for one thing: the keyboard doesn't light up. At all. And if I press Fn+F4 (or F3) the LED brightness doesn't even show up (for you guys that know how it works it has 3 levels and it should always say at what level of brightness your keyboard is set).

    Once I noticed that I tried EVERY ATK driver currently on the site but still it doesn't work, it's the one and only thing that is not working, everything else is perfect, even the other Fn +Fwhatever functions work. They keyboard is the only one. Anyone who can help? More details will be given if asked.

  2. #2
    ROG Member Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    6

    If it is of any help: just did a factory reset: didn't solve the problem. Starting to think this is a hardware related problem

  3. #3
    ROG Guru: White Belt Array
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    117

    I dont know how to fix it, but its most likely from the update you did to the bios, so if possible try to revert back to the version you had

  4. #4
    ROG Member Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    6

    Maybe, trying everything out right now I just realized I didn't even install java, dunno if it's somehow related but... Yeah xD

  5. #5
    ROG Guru: Brown Belt Array Darnassus PC Specs
    Darnassus PC Specs
    Laptop (Model)G752VS -=-=- G750JX
    MotherboardASUSTeK COMPUTER INC. G752VS (U3E1) -=-=- ASUSTeK COMPUTER INC. G750JX (SOCKET 0)
    Processori7 6700HQ @ 2.60GHz -=-=- i7-4700HQ CPU @ 2.40GHz - 3.40GHz
    Memory (part number)2x16gb (M471A2K43BB1-CRC) -=-=- 2x8gb (HMT41GS6AFR8A-PB)
    Graphics Card #1GTX 1070 (8GB) -=-=- GTX 770M (3GB)
    Sound CardRealtek High Definition Audio / NVIDIA High Definition Audio
    MonitorGSync IPS 75HZ -=-=- Chi Mei 60Hz (Overclocked to 85Hz)
    Storage #1Samsung SSD 960 EVO 250GB x2 -=-=- LITEONIT LCS-256M6S
    Storage #2HGST HTS721010A9E630 -=-=- ST1000LM024 HN-M101MBB
    CPU CoolerStock -=-=- Stock
    CaseStock -=-=- Stock
    Power SupplyStock -=-=- Stock
    Keyboard Stock -=-=- Stock
    Mouse Razer Naga Epic 1st Generation
    Headset SPH 2500
    Mouse Pad Razer Goliathus
    OS Winblows 10 Pro -=-=- Winblows 8.1 Pro
    Network RouterCG3000v2
    Darnassus's Avatar
    Join Date
    Dec 2013
    Reputation
    61
    Posts
    1,644

    Lol they really need to take down BIOS 209 or update it to say "If you're on 208 do not upgrade" because so many people come back with problems..

    Edit: You said RMA but what exactly did they do? If they dismantled the unit, there's a good chance the shoddy tech guy forgot to seat the cable that handles the LEDs to the board.

    The keyboard has three ribbons if I remember correctly. It's been a while.
    Gosh Blue Lady.. ❤

    JOIN THE ASUS T-SHOOT DISCORD <-- Clicky!

  6. #6
    ROG Member Array
    Join Date
    May 2014
    Reputation
    10
    Posts
    6

    I had burnt pixels on the screen and the left fan making a weird noise, nothing keyboard related but yes, the fan problem definitely needs a dismsntle to fix. It doesn't make sense though because the caps lockcLED wouldn't turn on if it was hardware related. Plus if it was hardware related it should show me the little indicator with the 3 levels of brightness, but that doesn't show up either.

    EDIT: I'm re-installing 8.1 now after the factory reset, still haven't touched the drivers or the bios, just did the basic obligatory updates. The factory reset did not prove useful btw. Every fn combination works like a charm except for fn+f3 and fn+f4 :/ just in case: the f3 and f4 keys are not broken, they do work fine
    Last edited by QuellaVolpe; 08-08-2015 at 11:18 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •