Results 1 to 3 of 3
  1. #1
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    5

    g750JH USB\wifi issues after windows 10 upgrade

    Hello guys
    I got a g750JH.
    Upgraded to windows 10 last weekend, , and usb ports dont work with storage devices. they work just fine with my wireless headset\mouse\keyboard\all types of connectors, but when I connect a usb flash drive, it makes that sound when a usb device is connected, but it does not show it in "this PC" window.

    I looked in the asus website to try and get an update for the usb driver, but didnt find anything, i also tried windows update and to update through the device manager, no luck either. I used a software called driver fusion, but it didnt fix the issue.

    Wifi speed is dead too, when i trying the driver update, but since i cant download it, and cant connect a usb to transfer the driver, i am kind of stuck!

    Any suggestions?

    Thanks!

  2. #2
    ROG Guru: Green Belt Array Maxter's Avatar
    Join Date
    Aug 2013
    Reputation
    13
    Posts
    598

    there are some drivers that you need. you'll find them in the windows 8.1 section. I listed them somewhere in the forums, I don't remember which one. I think the intel management and I forget the other ones... look around though

  3. #3
    ROG Member Array
    Join Date
    Jan 2013
    Reputation
    10
    Posts
    5

    Okay, first, you are awesome! Thanks.
    I was able to locate your drivers list:
    1) chipset drivers, 2) Intel management engine interface, and 3) ATK drivers (this one is under the Windows 10 option)

    On Asus support website, I could only find the ATK driver, no Intel management engine interface nor chipset drivers.
    Any suggestions?

    Update1, forgot to mention, I updated my wireless driver and its working, for those interested, this is the link:
    http://www.killernetworking.com/supp...iver-downloads
    This is for those who have the killer-N card.

    update2: When I run the ATK package, i get the following error message, I assume my verison is up to date, or should i remove the older 1 and install this one?
    Last edited by Phantom_120; 08-13-2015 at 08:46 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •