Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14
  1. #11
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by Dreano View Post
    Okay old thread but anyway. My pair don't seem to charge. The light comes on blue then just goes off. Is there a problem?
    If you're talking about the battery, I assume you're referring to the Strix Wireless and not the Strix 7.1. When charging the Strix Wireless headset, there should be a constant blue light on the power button to indicate that it's charging (or orange when fully charged). The indicator appears to be working and so If the headset is not charging, it means you need to either change the battery (by an ASUS service center), or use an appropriate charger - maybe there's not enough or too much current which triggers the OCP (over-current protection).

  2. #12
    ROG Member Array
    Join Date
    Apr 2018
    Reputation
    10
    Posts
    15

    Thanks. I am referring to the 7.1 wireless https://www.amazon.co.uk/ASUS-Wirele.../dp/B01HQOMSY8 (not the centurion). I left it on 'charge' for 5 hours and nothing. Also the light just goes off so there's no charging at all. Using the same USB from my PC as before. Think I'll just get a replacement from Amazon.

  3. #13
    Administrator Array MasterC@ASUS's Avatar
    Join Date
    Aug 2014
    Reputation
    96
    Posts
    1,492

    Quote Originally Posted by Dreano View Post
    Thanks. I am referring to the 7.1 wireless https://www.amazon.co.uk/ASUS-Wirele.../dp/B01HQOMSY8 (not the centurion). I left it on 'charge' for 5 hours and nothing. Also the light just goes off so there's no charging at all. Using the same USB from my PC as before. Think I'll just get a replacement from Amazon.
    That is the Strix Wireless, we're careful about labeling it as 7.1 because there are two drivers simulating a virtual surround environment (both Strix 7.1 and the Centurion have 10 drivers - 5 for each ear). Just in case, check if any other methods of charging work (phone chargers or another USB port).

  4. #14
    New ROGer Array
    Join Date
    Feb 2019
    Reputation
    10
    Posts
    3

    i have the same headset and the same problem aswell. bought it 3 days ago. it was working fine, charged it for 4-5 hours and when i tried to use it again i saw it doesn't working anymore. it works with the cable tho.

Page 2 of 2 FirstFirst 1 2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •