Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    Asus Maximus VIII GENE and Dual Monitor issues

    Hello everyone !

    So, I've got some of the weirdest issues with my MAXIMUS VIII GENE board.

    Some programs using 3D crash when using dual monitor mode. It seems like the switch between iGPU and Discreet GPU isn't working. To avoid this issue, I have to switch back to one monitor mode, open the program and switch to dual monitor again.

    I've also got decreased graphic performances when using some programs in dual monitor mode ie : Unity or Unreal engine 4 (perfs drop from 150Fps to 15)

    Oh, and also, I've got coil whine in the CPU area when a GPU is plugged in. Weirdly enough, it doesn't happen when the same

    What I did try to fix it:

    I already have disabled iGPU in the UEFI, as well as Dual Screen Monitoring.
    I have tested the issue without a discreet graphic card, the two screens were directly plugged in the motherboard and the problem was the same.

    Same thing with another graphics card.

    I have updated BIOS to 1102 to no avail

    I have updated several versions of drivers, including the latest Catalyst 15.11 BETA to no avail

    I have plugged my GPU into another computer and no issues were to be noted.

    My rig is as follows :

    MB : Asus Maximus VIII gene
    Ram : G.skill Ripjaw V 32Go
    GPU : Asus AMD fury X
    CPU : Intel 6700K

    If you guys help me fix my problem, youll be my heroes

    Cheers!

  2. #2
    ROG Guru: Grand Master Array
    Join Date
    Oct 2012
    Reputation
    339
    Posts
    15,255

    1. What connection are you using for your monitors?

    2. Are you connecting both monitors to your AMD Fury X?

  3. #3
    New ROGer Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    Hey Chino, thanks for your reply.

    I'm using the HDMI port for one screen and Display Port for the other one. The Fury x only has one HDMI and three DP. Both monitors are connected to the Fury x

  4. #4
    New ROGer Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    Bump ?

  5. #5
    New ROGer Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    4

    Problem found

    Alright, so if anyone asks him/herself the same question than I did, here's the solution to the following issues :

    Programs requiering 3D don't load when using dual monitor.
    Decreased performances in dual screen

    The culprit was : Asus Sonic Suite if you want to fix all your issues, the only thing to do is to uninstall this piece of filth and your computer will be working normally again !

    I find it absolutely crazy no one here or from asus support ever heard of this before. Well, now it is here for the record, I hope it'll help some people.
    I've had this issue since september, and I can't tell you how happy and relieved I am now that I can use my computer properly !

    NOTE : SonicSuite V2.2.16 released on 2015/11/25 does NOT fix the issue.

    Moderators, you may set this topic to resolved.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •