Results 1 to 9 of 9
  1. #1
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    17

    ROG Swift is dying??? Already????

    SO I woke up this morning, and just like any other day Turned on my Desktop sat down to sort through e-mails and noticed things looked very very odd.

    For some reason everything on screen looked as if it was being scaled or interpolated like I wasn't running the native resolution of the monitor. To top it off I notice a weird flicker going on.

    Thinking something changed, I checked my resolution and refresh rate and all was normal. I tried changing down to 1920x1080 and back to 2560x1440, and things looked like crap still. I powered off the system unplugged the monitor for about 30 minutes came back turned it all on and still crappy image... I thought well maybe something happened with the video card, the drivers, the cable, tried it all and still my image on screen looks like crap. SO I broke out the ROG G751JT Laptop and hooked the monitor to it with a mini DP to DP cable and the image was still off like it is doing some sort of weird interpolation like it isn't running native resolution.

    As a last resort I tried to do the All reset option on the monitor still with no luck.

    What is going on? How In the world can this premium monitor be dying already???? Are there any user updateable firmware options I could try? Someone please help!

  2. #2
    ROG Guru: Black Belt Array Korth PC Specs
    Korth PC Specs
    MotherboardASUS X99 R5E (BIOS2101/1902)
    ProcessorHaswell-EP E5-1680-3 SR20H/R2 (4.4GHz)
    Memory (part number)Vengeance LPX 4x8GB SS DDR4-3000 (CMK32GX4M4C3000C15)
    Graphics Card #1NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Graphics Card #2NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Sound CardJDS Labs O2+ODAC (RevB), USB2 UAC1
    MonitorASUS PG278Q
    Storage #1Samsung 850 PRO 512GB SSDs, 4xSATA3 RAID0
    Storage #2Comay BladeDrive E28 3200GB SSD, 8xPCIe2
    CPU CoolerRaijintek NEMESIS/TISIS, AS5, 2xNH-A14
    CaseObsidian 750D (original), 6xNH-A14
    Power SupplyZalman/FSP ZM1250 Platinum
    Headset Pilot P51 PTT *modded*
    OS Arch, Gentoo, Win7x64, Win10x64
    Network RouterActiontec T3200M VDSL2 Gateway
    Accessory #1 TP-Link AC1900 Archer T9E, 1xPCIe
    Accessory #2 ASUS/Infineon SLB9635 TPM (TT1.2/FW3.19)
    Accessory #3 ASUS OC Panel I (FW0501)
    Korth's Avatar
    Join Date
    Mar 2015
    Reputation
    152
    Posts
    2,719

    Reinstall your GPU (NVidia?) drivers, DirectX, etc, and restart? Check all connectors, confirm your GPU card(s) is firmly seated? Is your GPU dying, does it seem to run hotter under load than before?

    Did you inadvertently kick the DisplayPort cable, damage or bend a connector point, mash it between the desk and the wall?
    Just asking because I've done it (once) myself, lol.

  3. #3
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    17

    tried all the above, and you must have missed where I tried plugging it in to my ROD G751JT notebook and had the same results...

  4. #4
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    17

    Called Monday to try to get an RMA setup... they said it would take 48 hours to check stock and get back with me.....

    since 48 hours had passed I called back up they said the stock check had not yet been completed, I had them double check my e-mail and send a test e-mail out to make sure nothing happened there. So the wait continues

    $799.99 for a monitor bought on 2/11/15 that is dying this is not good

    The flickering is getting worse (again it almost looks like it is interlaced), the backlight dimming and brightening back up is getting worse, and the text / image quality being blurry in most modes is getting really annoying really fast.

    This video doesn't show everything but shows some of the issues

    https://www.youtube.com/watch?v=eIiZ2UOs53g

  5. #5
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    17

    Thursday and still nothing.... is there anyone here from Asus that might be able to expedite this or help out?? This monitor is getting worse and worse and I use it quite a bit for both work and play and can not be down.

  6. #6
    Ex-employee Array
    Join Date
    Jun 2020
    Reputation
    108
    Posts
    2,154

    Hi Nintari,

    Sorry to hear about the problem with your monitor. Can you PM me your full name, contact details and ticket#? I'll get in touch with someone at ASUS North America.

    Thanks,
    Bahz

  7. #7
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    17

    Bahz I have PMed you the information requested

    To update everyone else I did finally receive the RMA e-mail with the link to enter in my credit card information. I'm a little disappointed that there was no place to input my Work information for the Ship to.... hopefully whatever carrier is used requires a signature because I do not like the thought of an $799 monitor just sitting on my front porch.

    Using the Asus support site where I am supposed to able to track the RMA I have only seen this:


    The system can't find records of your inquiry!

    We recommend you contact your reseller or nearest
    ASUS Service Center.

    Note:

    Due to our internal process, the repair status of your machine will be available the day after it has been delivered at the ASUS Service Center.


    This has been 3 days after I submitted my credit card info...so at this point I can not track the RMA, nor obtain shipping information to make sure of when it arrives.

    I am trying to give things a chance though as the initial RMA did say it would be 1-3 days possibly before the replacement would be shipped. so I am hoping to see an e-mail or update possibly today.

  8. #8
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    17

    Just as another update... my screen now seems to randomly go black on me this happened twice in a one hour period last night, but didn't happen the day before. Prior to that it happened a few times, I hear the sound of a device being disconnected in windows, the screen goes black when in a game... I hear the reconnect sound, I alt tab back to the desktop and then back in to game and it is fine.

  9. #9
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    17

    my replacement arrived yesterday but I didn't have time to really mess with it at all. MFG Date is April 2015.... I hope that any issues like other people are experiencing and I went through are resolved with newer models, I'd hate to see this thing die so soon!!!

    I do have to call Asus support though, I haven't received any instructions on where to send my old monitor back to lol... no e-mails, nothing in the packing list RMA paperwork etc.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •