Page 2 of 2 FirstFirst 1 2
Results 11 to 12 of 12
  1. #11
    ROG Member Array Chubbitto PC Specs
    Chubbitto PC Specs
    MotherboardAsus Maximus Impact VII
    ProcessorIntel Core i5-4690K
    Memory (part number)Cosair Dominator Platinum 8Gb 1866Mhz
    Graphics Card #1Nvidia Geforce GTX970 - MSI
    Sound CardBuilt-In
    MonitorSamsung UHD 55" TV
    Storage #1OCZ-Agility 3 - 120Gb
    Storage #2WD Red - 1Tb
    CPU CoolerCorsair H100i
    CaseCorsair Obsidian 250D
    Power SupplyCorsair RM650W Gold
    Keyboard Logitech K800
    Mouse Logitech G700s
    Headset/Speakers Logitech Z-5500 Digital
    Network RouterASUS DSL-AC68U
    Accessory #1 Samsung SM951 256Gb PCIe 3.0 x4

    Join Date
    Sep 2015
    Reputation
    10
    Posts
    7

    Hahahaha, Well said Rhys. The whole board went back to ASUS through my supplier.

    I checked the pins and they were all pretty straight, I know one guy had an issue with them on here.

    Not the best design IMO, but not so terrible that it would have such a design flow. Strange thing was the Wireless/Bluetooth device worked fine, it was just the M.2 port that doesn't work.

    As a side anecdote, I ended up doing a big clean of my room after having this whole issue, and it appears I threw out the box with my M.2 drive snugly inside. So now I am down a SSD too. I blame ASUS, as it would have been safe inside my PC had the M.2 drive worked from the beginning. Yes, I am externalising responsibility.

  2. #12
    New ROGer Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    1

    Hey Chubbito, fellow Maximus VII Impact owner here. Exactly the same problem.

    Bought a nice 250GB SM951 NVMe for my board but it finds absolutely nothing. The only small indication is that the PCIe slot speed changes from x16 to x8 when the SSD is connected.

    Have tried tutorials, Youtube videos, all sorts. Rolled back BIOSes even. But I cannot get it to find the drive, so I can't install Windows.

Page 2 of 2 FirstFirst 1 2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •