Results 1 to 8 of 8
  1. #1
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    Strange Bios Issue after W10 upgrade - G75VX

    So i upgraded to W10, now i can't access my bios, it doesn't even show a post. When I turn power on, its just no screen, then black screen, then windows.

    When I hold the F2 button to enter bios on startup, the screen remains blank and no lights are on other then the power light (and battery if its plugged in) no other key does nothing. When its stuck on the black screen, I can just press the power button and it turns off and it will boot up like nothing ever happened

    I tried shift + restart and entering bios via advanced options, same resualt as holding F2.
    Tried turning off hybrid shutoff in power options, no change.
    tried cold booting, no change
    tried draining power unlpugged and no battery, no change.
    tried removing HDD, got no post, just blank screen.

    Is it possible my GPU isn't displaying the post or bios for some reason and it is indeed launching?

    anyone have an ideas?
    Last edited by Dataanti; 09-02-2015 at 06:35 AM.

  2. #2
    ROG Guru: Green Belt Array Maxter's Avatar
    Join Date
    Aug 2013
    Reputation
    13
    Posts
    598

    I got the G750JW. I have to press ESC for BIOS, not F2. Maybe try ESC?

  3. #3
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    Quote Originally Posted by Maxter View Post
    I got the G750JW. I have to press ESC for BIOS, not F2. Maybe try ESC?
    Tried allllll the buttons, none do anything other then F2 which makes it hang on the blackscreen :/

    EDIT tried ESC again and noticed something odd... i would press it and it would hang on the black screen UNTIL i pressed enter and then it would continue to boot windows.
    Last edited by Dataanti; 09-03-2015 at 05:25 AM.

  4. #4
    ROG Guru: Yellow Belt Array
    Join Date
    Mar 2012
    Reputation
    33
    Posts
    164

    I repeatedly press F2 to get in bios. I don't hold it. Because if you hold F2 to soon during boot the bios will flag the key as stuck and ignore it.

    Have you tried with an external monitor?

    And if you manage to get into the bios I would recommend doing a load (recommended) defaults.
    Asus ROG G55VW:
    CPU: i7 3630QM
    GFX: Geforce GTX660M with 2GB ram
    RAM: 2x8Gb 2133MHz Kingston HyperX Impact (surprisingly the G55VW uses the 2133 X.M.P. profile)
    Storage: RAID0 with 2x 256Gb Crucial SSDs (both msata, one in a sata adapter)
    OS: Windows 10 x64

  5. #5
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    i have not tried an external monitor yet, i do not have one handy until the weekend but i will certainly try it. and as for holding F2, ive tried tapping, holding everything. im thinking its more of a multiple display issue, normally i have this laptop pugged into a TV and i use it like a desktop but im on a field exercise right now so i dont have any other screen avalible :/

  6. #6
    ROG Member Array
    Join Date
    Aug 2014
    Reputation
    10
    Posts
    8

    okay so i finally got to a TV i can use and the bios and post shows on the tv but not my laptop screen. i have my laptops screen identified as my #1 screen in windows and i cant find an option in the bios to select a different screen, what should i do?

  7. #7
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    20

    I have the exact same problem, any solutions?
    Asus, do you hear?!

  8. #8
    ROG Member Array
    Join Date
    Apr 2013
    Reputation
    10
    Posts
    20

    It seems that asus doesn't give a **** about our problems, it took our money already. Know that asus, this g75vx was my first asus machine, and an expensive one.
    Thanks to your great product quality and the inexistent support even here on your official forums, it will be my last asus product as well.
    Clevo here i come!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •