Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    4

    Exclamation G750 JX (2013) has something rattling inside

    I've seen references to this issue both for my G750 JX and other models.

    I only noticed it recently so no idea if it was there from the beginning. Basically when powered down and closed if I pick up the unit and move it around there is a rattling sound from the left side at the rear, around where the fan is. It's like a small piece of metal or wire moving around.

    I've noticed that if I hold the unit vertically and move it around that the noise appears to cease and then returns if I hold it horizontally again.

    I seen suggestions of a loose screw, a piece broken off somewhere due to overheating or that the externally facing fan blades might be loose.

    I called local ASUS Support who have booked an RMA. They didn't have any other comments. Just wondering if I need to send it in since the unit functions okay, or at least it appears to and since I've looked after it what if it gets taken apart, they find little or nothing and it comes back not looking as good as when it left.

    Any thoughts or advice appreciated!

  2. #2
    ROG Guru: Green Belt Array Maxter's Avatar
    Join Date
    Aug 2013
    Reputation
    13
    Posts
    598

    Quote Originally Posted by fanzypanz View Post
    I've seen references to this issue both for my G750 JX and other models.

    I only noticed it recently so no idea if it was there from the beginning. Basically when powered down and closed if I pick up the unit and move it around there is a rattling sound from the left side at the rear, around where the fan is. It's like a small piece of metal or wire moving around.

    I've noticed that if I hold the unit vertically and move it around that the noise appears to cease and then returns if I hold it horizontally again.

    I seen suggestions of a loose screw, a piece broken off somewhere due to overheating or that the externally facing fan blades might be loose.

    I called local ASUS Support who have booked an RMA. They didn't have any other comments. Just wondering if I need to send it in since the unit functions okay, or at least it appears to and since I've looked after it what if it gets taken apart, they find little or nothing and it comes back not looking as good as when it left.

    Any thoughts or advice appreciated!
    I have the same issue with my G750JW. I will take it to bestbuy in a few months when I'm done writing this research proposal. Aside from the loose thing going left and right, the computer seems fine, however.

  3. #3
    New ROGer Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    4

    Quote Originally Posted by Maxter View Post
    I have the same issue with my G750JW. I will take it to bestbuy in a few months when I'm done writing this research proposal. Aside from the loose thing going left and right, the computer seems fine, however.
    Thanks. Yes it seems a common issue with these units but still otherwise okay.

    The odd thing was I only noticed the issue following hearing a tapping sound from the same area while the machine was running which I mistook for rain on the window outside which is what it sounded like. It continued once the rain had stopped so at that point I noticed it was the computer

    The tapping sound hasn't returned since, I guess moving the unit around shifted whatever it was that was causing it. Wondering now was it something hitting against the fan, which couldn't have been good I'm sure.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •