Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    2

    New ROG G20AJ, low FPS (under 25) in all games.

    Pretty much ready to send this thing back. Online chat support wasn't able to help. Brand new G20AJ. i3 model with the GTX745. Bought to play older and/or more casual games on my TV from the couch. Been trying to run older games such as LFD2, BF3 and the first Mass Effect. Even on medium to low settings the PC can't maintain at least 25 FPS. BF3 on all low is in the teens. My RoG laptop form 2010 is getting about 3 times the frames in these games.

    What is going on? I was told I don't need the 2nd power supply. I've updated the drivers to include video, chipset and vga. Tried running Razor game booster. Manually shutting down unnecessary services to free up memory. Nothing is working. It feels like you're playing on a laptop on battery power only (no power brick).

    Only thing I can think of is that it's not sending video processing to the GTX from the intel HD graphics. But tech support said no way to determine which the PC is running off of. I have power set to high perf, but again still nothing. Two days now been messing around and have pretty much given up. RMAing it unless anyone else can help out. Thanks.

  2. #2
    ROG Enthusiast Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    33

    Just a thought, sometimes people overlook things. Check if your HDMI cable is connected to your video card HDMI not the onboard HDMI . Worth checking
    Last edited by Gengaku; 09-05-2015 at 10:12 PM.

  3. #3
    New ROGer Array
    Join Date
    Sep 2015
    Reputation
    10
    Posts
    2

    haha ya i made sure i did that

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •