Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    17

    Need for Speed Most Wanted (2012) problem

    Hi guys,
    I recently grabbed this game from Origin because it was there for free.
    Unfortunately the game is not working when using Xonar Phoebus sound card. I called to EA customer service and we discovered that sound card is causing that game is not starting. Game freezes when I start it right after the loading screen. Game also don't have a sounds in the loading screen. When I stop the Asus sound card and connect for example bluetooth headset, the works just fine.
    Does anyone have solution for this or experiencin same problems?
    I've found that there's a lot similar situations over the internet but no one really doesn't know the solution.
    I'd really like to hear what Asus has to say about this.
    Cheers.

  2. #2
    ROG Guru: White Belt Array Florin's Avatar
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    121

    You resolve this by simply putting the game in Run as administrator mode.
    i7-4790k + Corsair H80i | Asus Maximus VII Ranger | 16 GB Corsair Vengeance DDR3 1866 | Sapphire R9-290 OC Vapor-X 4GB | Asus Xonar Phoebus + Audio Technica M50 | 1xSSD Corsair 120 GB | 4x1 TB Seagate HDD | Corsair CX750M | Corsair Carbide 300R | Razer Taipan + Logitech G11 | Windows 10 64bit

  3. #3
    ROG Member Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    17

    Quote Originally Posted by Florin View Post
    You resolve this by simply putting the game in Run as administrator mode.
    It's working sometimes when running it as admin. And when it does, there is no sound at all and the game will stuck when I choose "quit", only way to shut it is to close it from the task manager.
    As I said, working fine with Phoebus disabled.

  4. #4
    ROG Enthusiast Array Sneeky PC Specs
    Sneeky PC Specs
    MotherboardHero vii
    Processorintel 4690k
    Memory (part number)16 gig avexir core red DDR3 2133
    Graphics Card #1asus strix 980
    Sound CardRog Phoebus
    MonitorROG SWIFT PG278Q
    Storage #1samsung evo 850 250gig
    Storage #2WD black 1TB
    CPU Coolercorsair h100i gtx
    Casephanteks Enthoo pro
    Power Supplycorsair HXi 750
    Keyboard cougar 700k
    Mouse cougar 700m
    Headset Qpad QH90
    Headset/Speakers Edifier S760D
    OS win10 pro x64

    Join Date
    May 2015
    Reputation
    10
    Posts
    62

    works fine for me , phoebus solo latest win 10 driver

  5. #5
    ROG Member Array
    Join Date
    Aug 2013
    Reputation
    10
    Posts
    17

    Quote Originally Posted by Sneeky View Post
    works fine for me , phoebus solo latest win 10 driver
    Interesting...do you have DDL? If I disable my asus and run the game and then put it back on game works fine, no sounds though.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •