Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    6

    No more surround in windows 10

    I no longer have surround sound in windows 10 - only my front left/right speakers. I have the logitech 5.1 speakers paired with the Asus Phoebus card.

    I tried installing win 8.1 drivers and didn't have luck. Can anyone help me? It's frustrating as hell. Whenever i do a speaker test in windows, I only get sound coming from those 2.

  2. #2
    ROG Member Array
    Join Date
    Oct 2012
    Reputation
    10
    Posts
    6

    Fixed it! Turns out I had to reset my logitech speakers (who knew?).

  3. #3
    ROG Member Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    6

    What model Logitech speakers?

  4. #4
    ROG Guru: Black Belt Array toronto699 PC Specs
    toronto699 PC Specs
    Laptop (Model)G752-VY-DH78K , G751-JYDH72X
    MotherboardRog Tytan G30AB
    Processori7-4770K
    Memory (part number)32GB
    Graphics Card #1Asus Gold20th GTX980Ti
    Sound CardDell X-Fi Audigy SoundBlaster
    Monitor3 Acer K272HL
    Storage #1118 GB/OS
    Storage #22.72 TB
    CPU CoolerIntegrated Liquid-Cooled CPU
    CaseG30AB
    Power SupplyAsus 700 Watt
    Keyboard Razer BlackWidow Ultimate
    Mouse Razer Diamond Back
    Headset Sony Studio Professional , Razer Seiren Mic
    Mouse Pad Razer FireFly
    Headset/Speakers Logittech 5.1 Z-5500
    OS W 10
    Network RouterSagemon Fast 5250 Hub 2000

    Join Date
    Aug 2014
    Reputation
    73
    Posts
    2,364

    I have Logitech 5.1 Z-5500 two things I had to do to get 5.1 set the speakers to 7.1 or
    second option was to turn on speaker fill it did not matter if I was using a W8.1 driver or a W10 driver, W10 sound is kinda messed up either option worked for me
    Last edited by toronto699; 10-24-2015 at 02:31 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •