Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    New ROGer Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    1

    ASUS Strix Tactic Pro Not WORKING or EVEN DETECTED.

    Good day guys, I recently bought an ASUS Tactic PRO on a local store here in my country. Unfortunately they are not actually an ASUS certified store, they are just a simple computer shop who sells stuff. Though I can try and talk to them for replacement, but remains to be seen.

    So on to the problem, I plugged in the ASUS Strix Tactic Pro keyboard on to my computer and it worked fine, so I decided to download its software / drivers. I downloaded the latest stable release (Not the newer BETA Version). During installation, it prompted me to also download the latest firmware as well, I suppose the new driver also requires the latest firmware so I clicked YES. I downloaded the latest stable release firmware as well who happen to be version 1.09 and theres a binary file, I opened it, It says click "INTO LOADER" and Press UPDATE to update firmware, and so I did. When its done, I clicked FINISH. It worked properly, I suppose the drivers and firmware update will work best after I restart my system. so the LED Lights flashed, and they didnt turned ON. after the boot process the keyboard isnt functioning anymore not it is detected. I tried it on another computer, it doesnt work. Also tried it on several laptops, NO LUCK AT ALL. I figured, it must be drivers so I downloaded and tried all of the rest of the drivers, NO LUCK. So the last thing that came into mind is the firmware, I think I should be reseting it to its factory default. Unfortunately, the firmware update program doesnt react at all, no buttons to be clicked (Buttons are grayed out).

    The thing is, the keyboard doesnt light up, except the P1 P3 the M and the NKRO Lights. They are at the lowest possible dim lighting. I really think that the firmware is corrupted and I dont know how to reset it to factory default.

    I have read a couple of people having the same problem as me, and doesnt seem to have a solution posted. Dont know how to contact ASUS about this either.

  2. #2
    New ROGer Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    1

    Angry STRIX Tactic Pro: Not working or being detected by computer

    Hi All,

    I updated the keyboard's firmware on Saturday night to version 1.09 and it worked fine, but after turning my computer on and off the keyboard is completely unresponsive. I think that the firmware has either become corrupt or is a dodgy version.

    The only lights being lit up on the keyboard are the P1, P3, M and NKRO keys, but they are at the dimmest setting.

    Any help would be greatly appreciated,
    Thanks

  3. #3
    ROG Guru: Orange Belt Array
    Join Date
    Jun 2015
    Reputation
    21
    Posts
    432

    Have you tried updating the firmware? You can download the firmware on their website at the link below:
    https://www.asus.com/Keyboards-Mice/...Desk_Download/
    Under others tab.

    Also for the firmware update you need to open it twice as it has to erase the BIOS and then you open again to update the BIOS. It does look like a corrupted firmware file that's causing the issue for you, hope this works.

  4. #4
    ROG Guru: Orange Belt Array
    Join Date
    Jun 2015
    Reputation
    21
    Posts
    432

    It appears that you didn't install the firmware correctly, I've been using 1.09 for awhile now and don't have any issues. You need to open the firmware file twice, once it clears the firmware then you open again to update and it works fine afterwards.

  5. #5
    New ROGer Array
    Join Date
    Nov 2014
    Reputation
    10
    Posts
    1

    I am late but I'll give an answer anyway, so anyone facing the same problem, which looks happening frequently, knows what is going on.

    This is most likely the case where the firmware is corrupted and the keyboard just lockups at booting phase (runs on an ARM cortex M0 cpu). Unfortunately there is no easy way to revert or recover it because Asus did'nt implement a user way to do it, trying to flash it again with the firmware updater wont work. So the easiest way is, of course, to send it back under warranty.
    The hard way, which invalidates the warranty, consists in doing some cpu debugging using ARM's SWD (Serial Wire Debug). This process is not for everyone, it requires an swd debugger, some knowledge and some manual abilty because Asus forgot to put any kind of swd connector or pins on the board.

  6. #6
    ROG Member Array edmond2016 PC Specs
    edmond2016 PC Specs
    Laptop (Model)ASUS K43SM
    MotherboardASUS Z170 PRO GAMING
    ProcessorIntel Core I5-6600 K (Skylake)
    Memory (part number)HyperX Fury 8GB DDR4
    Graphics Card #1ASUS STRIX GTX960 DC2OC 4GD5
    Sound CardOnkyo TX - SR343 A/V Receiver
    MonitorBenQ XL2720Z
    Storage #1HyperX Fury 240GB SSD
    Storage #2Seagate 2TB 7200rpm HDD
    CPU CoolerCorsair H60 Liquid Cooler
    CaseAerocool AERO-1000
    Power SupplyCorsair VS550 550W
    Keyboard ASUS STRIX TACTIC PRO Gaming Keyboard
    Headset HyperX Cloud II
    Headset/Speakers Bose Acoustimass 6 Series V
    OS Windows 10 64-bit

    Join Date
    Jun 2016
    Reputation
    10
    Posts
    5

    Quote Originally Posted by InfernoStorm View Post
    Have you tried updating the firmware? You can download the firmware on their website at the link below:
    https://www.asus.com/Keyboards-Mice/...Desk_Download/
    Under others tab.

    Also for the firmware update you need to open it twice as it has to erase the BIOS and then you open again to update the BIOS. It does look like a corrupted firmware file that's causing the issue for you, hope this works.
    what do you mean you need to open the updater twice?

    is it open the FWupdate then close then open again then start to bootload?

  7. #7
    New ROGer Array
    Join Date
    Sep 2016
    Reputation
    10
    Posts
    1

    Unhappy fwupdate does not work !

    Quote Originally Posted by edmond2016 View Post
    what do you mean you need to open the updater twice?

    is it open the FWupdate then close then open again then start to bootload?
    I got to say that i also got the same problem here.prompted to run the fware upgrade twice , but keyboard not working after fware upgrade.
    funny thing is that strix software suggests the fware upgrade itself , atleast give the user a warning that this could brick your keyboard so people can atleaset avoid it.
    very bad software design IMO.

    not too sure how and why asus released a $$$ keyboard and providing thrash software along with it. im really happy about the keyboard but the software
    will not cut it.
    to fix this issue , seems like you have to send the keyboard for RMA.
    good luck dude , i'll let you know how my RMA process goes and probably more insight on the asus after service as well. cheers.

  8. #8
    Ex-employee Array
    Join Date
    Jun 2020
    Reputation
    108
    Posts
    2,154

    I have already forwarded your feedback to our team, they will add warning message during the update process.
    Last edited by Bahz; 09-19-2016 at 08:51 AM.

  9. #9
    Ex-employee Array
    Join Date
    Jun 2020
    Reputation
    108
    Posts
    2,154

    Our peripherals team has come out with new firmware version that addresses this issue, I have sent you both a message with the unofficial firmware to first to use for now. This is scheduled to be updated to our product page very shortly.

    Please let me know if you have any other issues with this new version.

  10. #10
    New ROGer Array
    Join Date
    Oct 2016
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Bahz View Post
    Our peripherals team has come out with new firmware version that addresses this issue, I have sent you both a message with the unofficial firmware to first to use for now. This is scheduled to be updated to our product page very shortly.

    Please let me know if you have any other issues with this new version.
    Hi, I have the same problem, update firmware error and peripherical not recognized.
    Can you send me the unofficial firmware please?

    ps: sorry for my bad english

Page 1 of 3 1 2 3 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •