Results 1 to 8 of 8
  1. #1
    ROG Member Array Kreisau's Avatar
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    6

    Low Performance G73JH-BST7

    I bought my g73 about 2 months ago and it came with a modified windows. after a time (when i started playing games), i realized i was getting low performance on my laptop. then, i did a fresh format with my own windows and installed the drivers in ROG forums. there was a little ascendance on performance but not normal. I'm saying not normal because, my friend has an ASUS k53s with nvidia 540m and he's getting 40-50 fps and I'm getting 15-20 fps at skyrim. By the way, the laptop has been freezing at random times since i bought it and two weeks ago i took the laptop to the service because of this freezing problem. today i got it and tried playing skyrim and fps was still the same. (btw, after the format i did nearly all the things which has been said on the forums about gsod, vbios, stuttering and etc.) and i don't think this is the normal performance of this laptop or this graphic card.
    what is the problem? or what should i do?

  2. #2
    TeamROG Moderator Array xeromist PC Specs
    xeromist PC Specs
    Laptop (Model)Dell Inspiron 15 7567
    MotherboardMSI x470 Gaming Plus
    ProcessorAMD 2600X
    Memory (part number)16GB Crucial Ballistix Elite 3600
    Graphics Card #1ASUS GTX 1080 Strix
    MonitorBenQ BL3200PT
    Storage #1Intel 600p NVMe
    CPU CoolerWraith
    Casecustom Antec 900
    Power SupplyCorsair HX1000
    Keyboard Logitech Orion Spark
    Mouse Logitech MX500
    Headset Plantronics 777 with Oregon Aero upgrade
    xeromist's Avatar
    Join Date
    Jul 2010
    Reputation
    318
    Posts
    7,757

    What did the service people do about the freezing? Has that been fixed?
    * Support disease research with Folding@Home *

    < < < Click the drop-down above my avatar for my PC specs!

  3. #3
    ROG Guru: Black Belt Array JRd1st's Avatar
    Join Date
    Aug 2011
    Reputation
    28
    Posts
    2,224

    Did you do this - http://rog.asus.com/forum/showthread...eros-WiFi-Card. (Only if you have an Atheros wifi card. )
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  4. #4
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Take a look at NVIDIA Control Panel on your friend's laptop and see how he has it configured. Is "Power management mode" configured to "Adaptive" or "Prefer maximum performance"? Is Vertical Sync and Antialiasing turned off?

    Have you tried ThrottleStop? See http://rog.asus.com/forum/showthread...-how-to-fix-it

    Do you have a Seagate Momentus XT HDD? In http://forums.seagate.com/t5/Momentu...-in/td-p/55656 discusses a lag issue with the Momentus XT. One user works around the problem by using Crystal Disk to disable AAM/APM on the drive. Unfortunately, this workaround must be implemented on each boot.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  5. #5
    ROG Member Array Kreisau's Avatar
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    6

    service people said abou freezing problem that they didnt observe any. but they said they cleaned the fans and i think it was about heating and so im not getting any freezing at all.

    i got the latest drivers (not betas) and i was using throttle stop before i handed over the laptop to the service. now i installed radeon pro and configurated it. now, at high quality settings i am getting 25-40 fps. it seems normal for me right now but what do you think about it?

    while we were comparing the latops, we use the same options at games just with a difference, his resolution is 1366x768 at standart, mine is 1600x900. so that, anti alisasing and vsync is on.

    i took a look at device manager and looked for the model, its seagate but not xt series. thank you, anyway.

  6. #6
    ROG Member Array Kreisau's Avatar
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    6

    Now, it started again! started freezing at random times again. it doesnt matter what I am doing when it happens, the screen freezes(the last frame of the desktop stays) and I cant do anything except pressing the shut down button. laptop doesnt respond anything I do at that time.
    What is this problem?

  7. #7
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    14

    try hard resetting your bios, remove battery and power supply unit, press your power button for 10 seconds+, plug back and on.

  8. #8
    ROG Member Array Kreisau's Avatar
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    6

    hard resetted the bios by kalist0's way and restored to factory settings from bios about an hour ago but it freezed again 10 minutes ago. what this coul be related to? is there anyone experienced that problem before?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •