Results 1 to 5 of 5
  1. #1
    New ROGer Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    4

    ROG G751jy Can't turn off monitor after windows 10 update

    Hello guys, I have the problem I wrote in the title.
    When I press fn+f7 the monitor goes off for a couple of seconds and then goes on again. This is happening since the windows 10 update. No change in software, so they are all the same I had in windows 8.1.
    I did all the updates through windows update and all the drivers are up to date. I also checked all the power management options and they are set right.
    Unfortunately this is a major problem for me because I use my pc for work and when I render at night times my screen is always on.

    The only two times I get it to work is in the lock screen (the one where you put the password for the login) and rebooting windows in safe mode. There it works again, so I think it may be some background process that decide to turn back on the screen.
    Another thing that maybe could help, screensaver not works anymore neither, I set it to activate after 1 minute but nothing happens.

    Can you please help me? this is driving me mad!
    Thank you in advance!

  2. #2
    ROG Guru: Blue Belt Array Gps3dx PC Specs
    Gps3dx PC Specs
    Laptop (Model)Current: G751JT | Retired: G55VW, G51JX
    MotherboardInc M.2 slot
    Storage #1Samsungs EVO 850 128GB
    Storage #21TB HGST Travelstar 7K1000 (HTS721010A9E630)
    CPU CoolerMother Nature & Thermodynamics laws
    Mouse Logitech MX 518
    Headset/Speakers Logitech T6060
    OS Cleaned installed Windows 10 HOME x64
    Accessory #1 Leap Motion

    Join Date
    Feb 2015
    Reputation
    71
    Posts
    784

    (face palm) another great win10 upgrade I see ( hip hip hooray MS !)
    I understand that you have not implemented nor read my "GUIDE: HOW TO (EASILY!) UPGRADE FROM WIN7 SP1/8.1 WITHOUT GOING THROUGH THE UPGRADE PROCESS ITSELF !"

    My suggestion is that you don't waste your time figuring out what working/not/half working/bug working/ etc..etc...
    Do your self a favor and CLEAN INSTALL WINDOWS 10 -> THEN INSTALL THE NECESSARY DRIVERS for your laptop.
    I promise this behavior won't happen after clean install with THE NECESSARY DRIVERS.

  3. #3
    New ROGer Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    4

    First of all: THANK YOU for helping me. It's been almost 3 weeks that I'm trying everything I found on google with no results. Maybe tomorrow or thursday I could try your guide, I really hope it will solve the problem (Mostly because I'll have to reinstall all of my softwares, and they are a lot).
    I was really happy to see the upgrade to windows 10 went good until I found out this problem...maybe it was too good to be true

    thank you again, I will post again with the result!
    Last edited by brombe; 10-29-2015 at 02:43 PM. Reason: Update

  4. #4
    New ROGer Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    4

    Update: before formatting I tried to update the ATK drivers of the keyboard (today there where a new version). Apparently it's caused by them, as soon I uninstalled them the fn+f7 combination started to work. howewer, the top left buttons dont work anymore and neither the lights of the keyboard works.
    Is it possible to just fix this? Working with my laptop it's not so easy to reinstall everything (I don't even have another pc now if something goes wrong).

    NEW UPDATE: I formatted and reinstalled windows. Of course nothing changed because this is 99% ATK drivers' fault.
    As soon as I install them (no matter what version, I even tried the 32 bit ones and the one from windows 8.1) the monitor goes off for a second then turn on again.
    On device manager under keyboard I have Advanced ps/2 keyboard PC/AT (101/102 buttons) , or whatever is the english translation... is it right?
    Last edited by brombe; 10-30-2015 at 01:00 PM.

  5. #5
    New ROGer Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    4

    6510

    SOLUTION FOUND

    Go to device manager and DISABLE HID Game Controller.
    As simple as that. I don't even have a controller.
    now everything works fine, the auto shutdown of the screen and even screensavers. How that are connected, I don't know

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •