Results 1 to 2 of 2
  1. #1
    New ROGer Array
    Join Date
    Oct 2015

    Unhappy Asus X99 Deluxe - first ever RMA in 15 years

    Hi All,

    Normally I wouldn't post however I feel like these issues need to be heard. So after deciding to upgrade from my old X58 Nehalem i7 920 build (which I am typing from now) - it's been 6 years and with the prices of DDR4 falling it was just time to upgrade.

    So two weeks ago I picked up the below parts

    i7 5960X
    Asus X99 Deluxe (updated to BIOS: 1901)
    H110i GT
    Corsair Dominator DDR4 16GB (2x8) 2666mhz
    Corsair 900D
    Win7 64bit

    I installed Win7 64 on my old Agility 4 SSD while waiting for my new Samsung EVO 850's to arrive. Everything has been running stock, no OC at all - (I need stability first before any tweaks), apart from some futile and failed attempts at OCing - this was the first suspicion I had with the mb. My EVO's arrived yesterday, I installed 1, turned PC on and it booted into UEFI fine. I configured the primary boot drive to be my Agility 4 and rebooted.

    first issue: POSTed to windows logo, froze and rebooted again in an annoying loop. I turned everything off and began to unplug everything.

    second issue: NO POST (monitor black), LED BOOT_DEVICE on motherboard lit up red. I unplugged everything, triple checked CPU fan header, unplugged all SATA cables, booted with both ram dimms, then tried with a single ram dimm to no avail.. nothing.. still nothing.

    At this point I gob-smacked thinking I did something wrong.. I had exhausted all avenues so I then tried to re-flash BIOS back to an older one - I tried 1004, 1702, 1801 and still nothing.

    third issue: after the re-flash to BIOS 1004, LED BOOT_DEVICE changed to LED CPU with CODE 76 - which manual states as PCH DXE Initialization (PCH module.

    At this point we are into 2-3 hours of frustration so I decided to call it quits and bring it back to the vendor today.

    Went into store today and service techie set the X99 Deluxe on test bench, installed a brand new 5820k, cooler master LGA2011-3 fan, different ram single stick (Gskill), and a different power supply. Fired her up and bamm - Nothing. Code 76. MB is bricked, RMA'd and I got my refund...

    This has been a very concerning 48hrs and for the first time in 15 years I am extremely worried about Asus products. I did some digging around and it seems like Asus X99 have been subjected to numerous issues i.e. USB overload issues, NO POST, Slow and random boots, I also read that some X99 boards have killed some CPUs (source: google "5960X Dead")

    I am now stuck between a rock and a hard place and am hoping the good people here could assist in me with my questions:

    1. Do I give Asus another chance? X99-A, PRO, Deluxe, Sabertooth or Rampage 5 Extreme?? given the number of people also having the same issues I am very weary - maybe it's best to avoid Asus for X99 chipset altogether.. any thoughts?

    2. MSI X99A MPower, X99A Gaming 7, X99A SLI Plus - I have heard good things about MSI - thoughts?

    3. Gigabyte X99 UD4P - what about gigabyte?

    4. Are there any other choices I should seriously look into???

    **I have mentioned the above motherboards as they are available locally (for PICK UP) for me here in Sydney, Australia which is critical for me - I wouldn't want to be going through an RMA process via posting my gear away - the entire process is just too time consuming and painful.

    I read reviews and it seems like it is Hit or Miss, some people have reported stability and great OCing capabilities. Deep down, I still want to stay with the X99 Deluxe as it is jammed packed features that I would use - WiFi, heaps of USB ports and USB headers, the fan extension card (I have so many fans)

    But then I think about the nightmare of going through these issues again - HELP!


  2. #2
    ROG Enthusiast Array matrixleader PC Specs
    matrixleader PC Specs
    Laptop (Model)EUROCOM Sky X9
    MotherboardIntel Sunrise Point Z170
    ProcessorIntel Skylake i7-6700K @ 4.2 GHz
    Memory (part number)Samsung 64GB DDR4 RAM @ 2400 MHz
    Graphics Card #1GeForce GTX 980 8.0GB GDDR5 (Desktop Version)
    Sound CardSound Blaster 3D Audio
    MonitorLG LP173WF4-SPD1 17.3" 1920x1080 IPS FHD (16:9) LED Antiglare Matte Screen with G-SYNC Technology
    Storage #12 x Samsung 950 Pro 512GB M.2 NVMe PCIe x4 SSD (RAID 0)
    Storage #22x Samsung Spinpoint M9T ST2000LM003 5400 RPM 32MB Cache 2TB HDD (RAID 0)
    CPU CoolerIC Diamong Thermal Paste
    Power Supply660W AC Power Adapter
    Mouse Logitech G602
    Mouse Pad Razer Manticor
    Headset/Speakers Onkyo Speakers
    OS Windows 10 Pro
    Network RouterRT-AC68U
    matrixleader's Avatar
    Join Date
    Feb 2015

    Stay away from all ASUS products! Their product have 0 quality control

    I had the X-99 Deluxe and overclocked my 5930K to 4.4GHZ no problem. The biggest issue with it is the slow boot time, it takes about 15 seconds from a cold boot just to display the ASUS splash screen. Tried all BIOS, disabled DRAM Training, no luck. Then it's another 15 seconds to boot into Windows! If I turn one of my cheap laptops lying around it would be in Windows in 5 seconds since it has an SSD also.

    Another issue with it is flaky USB ports. some of them work with some devices, others don't, you need to sit and test which devices work with which USB ports. I wouldn't buy this motherboard again or any ASUS motherboard even if it was for 10 USD!

    Don't get me starteed on the quality of their monitors (PG278Q anyone), routers, and laptops. Cheap Taiwanese company

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts