Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Jul 2015
    Reputation
    10
    Posts
    9

    Question G751JY FPS problems with various games

    I have strange fps drops(slight freezes) with different games.
    These are my laptop specs:

    Proseccor: i7-4720HQ
    GPU: Geforce GTX 980M, driver version 353.62
    Memory 8+8 Gigs (8 originally, another 8 gigs added in store)
    Hard drive: 1 tb Hdd + 256 ssd

    I have fps problems with some of my games and some have no problems.

    I have tested with following games ( games and whether they are installed to the hdd or sdd).

    Skyrim (no problems, ssd. Had random fps drops when in hdd)
    Star wars old republic (no problems, hdd )
    Kingdom (no problems, hdd)
    The war of mine (no problems, hdd)
    Starcraft 2 (no problems, ssd)
    Galactic civilizations 3 (no problems, hdd)

    Sunless sea (problems, hdd)
    Pillars of eternity (problems, tested both sdd and hdd)
    Starpoint gemini 2 (problems, hdd)
    Divinity dragon commander (problems, but only randomly, hdd)
    Shadowrun Hong Kong (problems, ssd)

    To check if the problem is with the hard drive, i ran two diagnostic programs to check their health.
    (CrystalDiskInfo for both SDD and HDD and manufacturer´s tool (WinDFT) for HDD). Both gave good results and no problems.

    To check if the problem is with RAM i ran windows memory diagnostic tool with standard settings. Results show no problems.

    What you guys think? What could be the problem? Or is it just driver problem? Thanks in advance!

  2. #2
    ROG Member Array
    Join Date
    Dec 2014
    Reputation
    10
    Posts
    24

    I would check your temps. Heat might be throttling your system. Do a search on this forum and you will find that this is quite a common problem. A quick look at your games shows that the older ones are running with no problems ( starcraft etc) That might be your first clue. Older games are less demanding and they don't push your temps as high. Good luck!

  3. #3
    ROG Guru: Black Belt Array Korth PC Specs
    Korth PC Specs
    MotherboardASUS X99 R5E (BIOS2101/1902)
    ProcessorHaswell-EP E5-1680-3 SR20H/R2 (4.4GHz)
    Memory (part number)Vengeance LPX 4x8GB SS DDR4-3000 (CMK32GX4M4C3000C15)
    Graphics Card #1NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Graphics Card #2NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Sound CardJDS Labs O2+ODAC (RevB), USB2 UAC1
    MonitorASUS PG278Q
    Storage #1Samsung 850 PRO 512GB SSDs, 4xSATA3 RAID0
    Storage #2Comay BladeDrive E28 3200GB SSD, 8xPCIe2
    CPU CoolerRaijintek NEMESIS/TISIS, AS5, 2xNH-A14
    CaseObsidian 750D (original), 6xNH-A14
    Power SupplyZalman/FSP ZM1250 Platinum
    Headset Pilot P51 PTT *modded*
    OS Arch, Gentoo, Win7x64, Win10x64
    Network RouterActiontec T3200M VDSL2 Gateway
    Accessory #1 TP-Link AC1900 Archer T9E, 1xPCIe
    Accessory #2 ASUS/Infineon SLB9635 TPM (TT1.2/FW3.19)
    Accessory #3 ASUS OC Panel I (FW0501)
    Korth's Avatar
    Join Date
    Mar 2015
    Reputation
    152
    Posts
    2,719

    If the problems always occur only in certain games then the software or drivers could be at fault. The sorts of things NVidia patches up after too many people complain, lol.

  4. #4
    ROG Member Array
    Join Date
    Jul 2015
    Reputation
    10
    Posts
    9

    I checked temps when playing using hwinfo64.
    After playing starpoint gemini 2 with max settings for one hour max temps were 70 degrees for cpu. No throttling
    After playing starcraft 2 with max settings for two hours max temps were 80 degrees for cpu. No throttling

    Also problems usually occur almost immediately after I start playing. Also changing graphic settings between lowest and
    highest settings does not change things.

    Some older games also have fps problems, like majesty 2.

    Just praying it is software problem and not hardware problem.
    Last edited by patosa1989; 11-06-2015 at 07:13 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •