Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    1

    Question black screen after updating nvidia drivers

    Hey guys, I have quite a big issue with my Asus laptop.

    I've installed new drivers for my Nvidia Geforce GTX 770M on my laptop, and then I was asked to restart the computer.
    After doing so, when the computer booted up again, the screen was completely black, not even the windows logo nor the 'Republic of Gamers' one started up. That's why I wasn't able to resolve this issue by starting up windows in safe mode, since I couldn't see what was on the screen no matter what.

    And yes, I am absolutely certain that everything else besides the screen works, I was able to blindly put in my password, and my external keyboard lit up, which indicated that I succesfully logged in, and was even able to hear the sound of skype booting up.

    Concerning the screen, it wasn't even lit-up, completely black, not black-lit.

    Is there any way to deal with this issue, or at least restore windows to factory defaults so I could re-install an older driver?

    I've also tried booting it up about 10 times, it didn't fix itself.

    I'm not sure which Asus ROG laptop I have, but I know that it has an nVidia Geforce GTX 770M, 6GB of RAM, and an intel core i7.

    Sorry for not putting in the correct tags, I'm new around here.

    Update:
    I've tried connecting my laptop to another screen, laptop, and even a TV through both VGA and HDMI, the screen said 'No signal'.
    I've also tried booting it to safe mode, but that's not so easy to achieve because I CAN'T see anything I'm doing. I'm not even sure if I DID boot it in safe mode, I hoped that if I forced the laptop to instantly shut down by holding down the power button, then turning it on again, it would give me the screen with the 3 possibilities of booting up windows, and that I've also picked the correct one.

    As I mentioned previously, everything else besides the screen is working, the laptop is fully functional, I can hear sounds coming from different programs that start on boot up.

    I also don't seem to be able to control the brightness of my laptop's keyboard by holding down the Fn + f4/f5 keys. Just a minor thing, but maybe that might hint to the root of the problem.

    I tried plugging it in to my TV with an HDMI cable, turned it off, turned it back on, and on the TV screen I could see a single, static picture of the Republic of Gamers logo which usually shows up as the first thing when you turn the computer on. That was the only thing on the TV, even if I was already logged in to my account on the laptop.

    Thanks for answers in advance.
    Last edited by deezebee; 11-14-2015 at 04:26 PM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •