Page 2 of 2 FirstFirst 1 2
Results 11 to 16 of 16
  1. #11
    ROG Guru: Gold Belt Array dstrakele's Avatar
    Join Date
    Sep 2011
    Reputation
    89
    Posts
    4,437

    Well, Thank you Mr. Know-It-All! (hey - that actually IS a very good point! - damn you!)

    Could there be any changes he could make in BIOS settings to troubleshoot further? Are you attempting a UEFI/GPT Windows boot for instance?

    On the other hand, BIOS settings changes would fail to explain why the issue reoccurs after a reset...

    EDIT: Suppose the video driver is corrupted in a fashion that makes it configured for an external monitor when none is connected? In such a scenario, it may be attempting to display the ASUS Splash screen on the nonexistent monitor. I know that on my clean Windows install instance running the NVIDIA 295.36 BETA driver, it will sometimes reconfigure to a single display, even though I have an external monitor attached. Who's to say the reverse can't happen?
    Last edited by dstrakele; 12-22-2011 at 10:12 PM.
    G74SX-A1 - stock hardware - BIOS 202 - 2nd Monitor VISIO VF551XVT

  2. #12
    ROG Guru: Black Belt Array JRd1st's Avatar
    Join Date
    Aug 2011
    Reputation
    28
    Posts
    2,224

    He should disconnect any peripherals, and also go into the BIOS and restore optimal defaults (f9)

    If that doesn't work I advise the standard thing;
    1. Exchange at reseller if possible
    or
    2. Set up RMA (and hope it's still bad when the techs check it out.)
    Read the User's Manual for more info.



    G74SX-A1 BIOS 203
    Intel 6230 WiFi/BT
    LG E2350 LED LCD Monitor
    Intel Series 510 120 GB SSD

    Drivers, Apps and How To's
    Latest nVidia Drivers

    JRd1st on DeviantArt.com

  3. #13
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    5

    kalist0, I had the exact same problem as you are experiencing, and much more. My G74SX has been a tremendous source of problems and frustrations.

    Since the first day, the SPACE key was not functioning properly.

    On the third day after I received my 'new' laptop, I was playing Arkham City and suddenly the screen went blank and my laptop emitted a loud "BZZZZ" noise. I forced a shut down and switched it on again. The button lights came on but nothing was displayed on the screen. Restarted the laptop 3 times, still the problem remained.

    Took it my local repair centre the very next day, and they said it was a motherboard problem. My laptop's SPACE key was fixed and the motherboard changed, so these are fine now. But after the repair, something has gone wrong with my speakers! When playing Arkham City, there will be a lot of fuzz when main characters speak, and also when the music becomes high pitched. I have downloaded and reinstalled the sound driver, but the problem persists! The sound was fine before I had sent my laptop for repairs! So the very next day after I had my laptop repaired, I went back AGAIN to the repair centre. This time I spoke to the supervisor, who was pretty clueless about my laptop model and the problems that have entailed. Said he would lodge a complaint for me to the HQ in Taiwan, but I am going to ask him for a replacement.

    I paid A LOT of money for my G74SX, I don't expect to receive a bundle of problems! I have been far too patient and cool with Asus. How can Asus claim "No.1 in Quality and Services" when so many of their products are problematic?! And I dare say that so many of their products are problematic due to my personal experiences (this is my 2nd Asus laptop), and from observing many other frustrated people at the repair centre, both times I went.

    I hope an Asus representative will read this: Asus, GET YOUR ACT TOGETHER, especially if you make bold statements!

    Edit: It has been a week after this post, and my speakers do sound fuzzy when I play other games, Youtube videos (have played the videos on this laptop and my old one for comparison) and music CDs. On the rare occasion though, the fuzz disappears. Still awaiting a response from my local Asus centre regarding this issue! And now my SPACE key is acting up again! So sick of all these problems that i'm losing the energy to vent on...
    Last edited by Drakohl; 12-30-2011 at 08:05 AM. Reason: Added information

  4. #14
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    14

    hi guys, just to inform you all of my solution. basically i RMA'd my lappie and they had to change the motherboard and graphic card to settle my issue. got it back within two weeks.

  5. #15
    ROG Member Array
    Join Date
    Dec 2011
    Reputation
    10
    Posts
    5

    Quote Originally Posted by kalist0 View Post
    hi guys, just to inform you all of my solution. basically i RMA'd my lappie and they had to change the motherboard and graphic card to settle my issue. got it back within two weeks.
    I contacted Asus last week, and they had already agreed to replace my unit but never informed me. They were unable to specify when the replacement unit would be in. It's highly likely that a bad batch of G series laptops were shipped to Malaysia, hence the similar problems kalist0 and I faced. I hope the new unit will be in proper working order when it arrives. Have not been buying any other games as i'm waiting to get the (hopefully problem free) replacement unit first.

    Hopefully you won't have any more problems with your laptop either, kalist0.

  6. #16
    New ROGer Array
    Join Date
    Mar 2012
    Reputation
    10
    Posts
    1

    Same issue for me.

    I am having same issue suddenly. I hibernated it at work, unplugged external monitor, put it in laptop bag and went home. Tried starting it that evening and graphics were weird....like pixely like when a video card overheats, then blank screen. When I use the screen switch I can see something for a quick second, but all out of shape, then blank screen again. For sure video card/MB issue I would have to say...

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •