Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    Banned Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    88

    Gaming Headset Not Making Any Sound

    My gaming headset isn't playing audio. I downloaded its driver and I can hear beeps in the ear-cans when I plug it into a USB port, but nothing else. What am I doing wrong?

  2. #2
    ROG Guru: Black Belt Array Korth PC Specs
    Korth PC Specs
    MotherboardASUS X99 R5E (BIOS2101/1902)
    ProcessorHaswell-EP E5-1680-3 SR20H/R2 (4.4GHz)
    Memory (part number)Vengeance LPX 4x8GB SS DDR4-3000 (CMK32GX4M4C3000C15)
    Graphics Card #1NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Graphics Card #2NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Sound CardJDS Labs O2+ODAC (RevB), USB2 UAC1
    MonitorASUS PG278Q
    Storage #1Samsung 850 PRO 512GB SSDs, 4xSATA3 RAID0
    Storage #2Comay BladeDrive E28 3200GB SSD, 8xPCIe2
    CPU CoolerRaijintek NEMESIS/TISIS, AS5, 2xNH-A14
    CaseObsidian 750D (original), 6xNH-A14
    Power SupplyZalman/FSP ZM1250 Platinum
    Headset Pilot P51 PTT *modded*
    OS Arch, Gentoo, Win7x64, Win10x64
    Network RouterActiontec T3200M VDSL2 Gateway
    Accessory #1 TP-Link AC1900 Archer T9E, 1xPCIe
    Accessory #2 ASUS/Infineon SLB9635 TPM (TT1.2/FW3.19)
    Accessory #3 ASUS OC Panel I (FW0501)
    Korth's Avatar
    Join Date
    Mar 2015
    Reputation
    152
    Posts
    2,719

    Probably a driver problem (you installed the wrong driver for that headset) or software problem (you need to install Logitech/Corsair/SteelSeries/etc software to make it work) or some audio setting is misconfigured (muted) somewhere in your operating system.

    Possibly a USB problem. Or the headphone jack is improperly connected to the audio source. Or a component in your audio chip/card hardware is dead.

    Can you list your system specs?

  3. #3
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba OCZ VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse Razer Basilisk
    Headset Sennheiser HD6XX / Modmic 5
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,359

    You can also right click on the speaker on the bottom right of your screen and click playback devices and see that your headphones are set as the default device.

  4. #4
    Banned Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    88

    I've got a Corsair Headset device. It has a USB port connector. When I plug it into the front panel, the sPC recognizes it by name and I here its initial tones, but there is no audio when I play a video or the like. I can plug my old earbuds into the headphone jack (not a USB port) and hear videos, and I can plug some old PC speakers into the audio section of the I/O area in the back and get sound, but I can't get sound with my Corsair headset even though the Rampage v Extreme recognizes it.

  5. #5
    Banned Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    88

    Quote Originally Posted by Nate152 View Post
    You can also right click on the speaker on the bottom right of your screen and click playback devices and see that your headphones are set as the default device.
    I check there and they are recognized by name as a default device and even make a sound when prompted to do so from there, but I still can't hear anything else like a Youtube video.

  6. #6
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba OCZ VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse Razer Basilisk
    Headset Sennheiser HD6XX / Modmic 5
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,359

    I'm not a big fan of usb headsets they always gave me some sort of problem. Make sure you have it connected to a usb 2.0 port, the blue ones are usb 3.0.

  7. #7
    Banned Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    88

    Okay, just got it and sounds great (lol, I'm giddy)! Nate152, your mention of default device got me looking through my control panel for default devices.

    This helped too: http://forum.corsair.com/v3/showthread.php?t=117715

  8. #8
    Banned Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    88

    Counter Strike, here I come. . ..

  9. #9
    Banned Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    88

    Thanks, guys!

  10. #10
    Moderator Array Nate152 PC Specs
    Nate152 PC Specs
    MotherboardROG Maximus IX Code
    Processori7-7700k 5.2GHz Delidded
    Memory (part number)16GB G.Skill Trident Z 4025MHz 17-17-17-39-2T
    Graphics Card #1Titan Xp - EKFC waterblock
    Graphics Card #2Titan Xp
    Sound CardROG SupremeFX 2015
    MonitorHP ZR30w
    Storage #1Toshiba OCZ VX500 256GB
    CPU CoolerSwiftech Apogee GTZ
    CaseThermaltake Armor+ VH6000
    Power SupplyEVGA Supernova 1600w Titanium
    Keyboard Cyberpower Skorpion K2
    Mouse Razer Basilisk
    Headset Sennheiser HD6XX / Modmic 5
    OS Windows 10 Home 64 bit
    Accessory #1 Asus optical drive
    Accessory #2 Koolance ERM-2K3U
    Nate152's Avatar
    Join Date
    Feb 2013
    Reputation
    308
    Posts
    16,359

    You're welcome

    Good to hear you got it working !

    There are enhancements and adjustments if you're not 100% happy with the sound.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •