Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1
    ROG Member Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    6

    GL752VW screen goes black.

    So, I have an issue where sometimes my screen just goes black on my GL752VW. Randomly it will just stop showing image, but the sound will continue. I have a friend who says this has been an issue here and there with ROG laptops. This does not seem to matter whether it's during gaming or during OS work. Should I just bring it back to the store, or is there something I can do to fix the issue at home. I absolutely love the laptop, but I can't just have it stop working on me like that.

    I have uninstalled and reinstalled all the GPU drivers, Intel and nVidia.

  2. #2
    ROG Member Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    6

    I figured it was a hardware fault. I exchanged the laptop.

  3. #3
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    9

    me too

    I also have a gl752vw and it happened to me 3 times but only for a few seconds. When your laptop goes black screen does it recover? I want to know if my laptop has hardware defects before its too late.

  4. #4
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    12

    Quote Originally Posted by mocoyR View Post
    I also have a gl752vw and it happened to me 3 times but only for a few seconds. When your laptop goes black screen does it recover? I want to know if my laptop has hardware defects before its too late.
    I had this happen to me, except my device would stay black and wouldn't recover until a restart.
    i updated the bios and so far I've not experienced any more blackouts.

  5. #5
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    24

    Quote Originally Posted by ColdNorthMenace View Post
    I figured it was a hardware fault. I exchanged the laptop.
    If it happens again, there have been reports on the forums as indicated by prototype that a bios update has eliminated this problem. The latest bios updates for the GL752 can be found at: http://www.asus.com/us/ROG-Republic-...Desk_Download/

    And here are the instructions on how to complete the bios update per the manual. Note: You'll need a flash drive.

    Click image for larger version. 

Name:	Bios 1.JPG 
Views:	103 
Size:	37.4 KB 
ID:	54476
    Click image for larger version. 

Name:	Bios 2.JPG 
Views:	95 
Size:	30.2 KB 
ID:	54477

  6. #6
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    9

    Unhappy Backlight keyboard not working

    pls help. after I updated the bios 210 the backlight of the keyboard is not working.

  7. #7
    ROG Enthusiast Array ATR-42's Avatar
    Join Date
    Jun 2014
    Reputation
    10
    Posts
    31

    Quote Originally Posted by mocoyR View Post
    pls help. after I updated the bios 210 the backlight of the keyboard is not working.
    have you tried reinstalling the ASUS ATK drivers again?
    Asus GL752V- win 10, 16gb ram, 960m, i7 6700, SSD
    Acer Predator Helios 500, i7 8750H, GTX1070
    Desktop- win 10, i7 6700k, 16gb ram, evga 1080ti, nvme

  8. #8
    ROG Member Array
    Join Date
    Jun 2014
    Reputation
    10
    Posts
    11

    My friend laptop GL752VW has this problem too. Black screen suddenly while using and I can't do anything with it. Force close Windows, and press the power button, nothing show on the screen even backlight key.

  9. #9
    ROG Enthusiast Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    37

    Mine turns black when I put some electronic device just in the gap to the left of the touchpad, under the keyboard. But as soon I put the electronic device off, it shows the image regulary. Has happened with ipad, iphone.... Still doesn't happen all the time. Must be some EM field, or maybe the closed-screen detector.

  10. #10
    New ROGer Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    1

    I recieved my RoG GL752VW a weeks ago, It will randomly goto anidle state as if turning off but It will start up immediately where it left off if I move the mouse or touch a key, today 2/17/16 It has been doing it over and over again. I have downloaded, rolled back and updated every driver for everything, I have tried OEM driver through ASUS qnd that didnt work, It is not a heat issue and it happens anytime. Gaming or not gaming, I am currently restoring to original state... Deff need help if anyone knows how to fix. Or even cause of issue...

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •