Results 1 to 7 of 7
  1. #1
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    3

    Angry GL551JW-WH71(WX) graphic issues

    Hi, I just bought this gaming laptop from new egg that cannot run game properly. issues are:
    1) every time i play game, there is color dots and black screen appears than goes away repeatedly.
    2) some times it shows me that a crashed 3D images or black ring shape( literally huge black ring shape that fits entire screen ).
    3) when i play Witcher 3 the graphic driver stops working than the game is not responding.
    Is anyone having graphic issues as mine?
    do you think this notebook is defective one? or do you think this is just a software issue?
    solutions are welcome!
    Last edited by bongochoom; 12-03-2015 at 06:59 AM.

  2. #2
    ROG Member Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    6

    Lightbulb contact newegg support

    Have you tried contacting Newegg support about it? they should know if that's a defective product. Try updating your drivers too.

  3. #3
    ROG Member Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    6

    Quote Originally Posted by bongochoom View Post
    Hi, I just bought this gaming laptop from new egg that cannot run game properly. issues are:
    1) every time i play game, there is color dots and black screen appears than goes away repeatedly.
    2) some times it shows me that a crashed 3D images or black ring shape( literally huge black ring shape that fits entire screen ).
    3) when i play Witcher 3 the graphic driver stops working than the game is not responding.
    Is anyone having graphic issues as mine?
    do you think this notebook is defective one? or do you think this is just a software issue?
    solutions are welcome!
    You don't have a defective laptop. You have a defective graphics card, the 860M. Nvidia has been lazy as hell taking over 2 months to fix the graphics card, and put out a beta driver, version 359.12 that should fix it.

    Try downloading driver 359.12 from NVidia's website and see if that helps.

  4. #4
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    3

    To AMSteveHNo96

    Quote Originally Posted by SteveHNo96 View Post
    You don't have a defective laptop. You have a defective graphics card, the 860M. Nvidia has been lazy as hell taking over 2 months to fix the graphics card, and put out a beta driver, version 359.12 that should fix it.

    Try downloading driver 359.12 from NVidia's website and see if that helps.
    Operating System: Windows 10 Home 64-bit (10.0, Build 10586)
    Processor: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz (8 CPUs), ~2.6GHz
    ---------------
    Display Devices
    ---------------
    Card name: Intel(R) HD Graphics 4600
    Card name: NVIDIA GeForce GTX 960M
    Manufacturer: NVIDIA
    Chip type: GeForce GTX 960M

    do they have hot fix for GTX960m too?
    thank you

  5. #5
    ROG Member Array
    Join Date
    Nov 2015
    Reputation
    10
    Posts
    6

    Quote Originally Posted by bongochoom View Post
    Operating System: Windows 10 Home 64-bit (10.0, Build 10586)
    Processor: Intel(R) Core(TM) i7-4720HQ CPU @ 2.60GHz (8 CPUs), ~2.6GHz
    ---------------
    Display Devices
    ---------------
    Card name: Intel(R) HD Graphics 4600
    Card name: NVIDIA GeForce GTX 960M
    Manufacturer: NVIDIA
    Chip type: GeForce GTX 960M

    do they have hot fix for GTX960m too?
    thank you
    You might want to check with NVidia. A few people have reported problems with the 960 graphic card, along with the i7-47xx graphics processor.

  6. #6
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    3

    Quote Originally Posted by SteveHNo96 View Post
    You might want to check with NVidia. A few people have reported problems with the 960 graphic card, along with the i7-47xx graphics processor.
    can I have some links If you have them?

  7. #7
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    6

    Quote Originally Posted by SteveHNo96 View Post
    You might want to check with NVidia. A few people have reported problems with the 960 graphic card, along with the i7-47xx graphics processor.
    Ive had this problem with my 960m card in my ROG GL551JW, the only solution I got from them was to wait for a fix, and that was over a month ago, and upgrading to newer gpu drivers make the error worse. If anyone has a solution to this, please let me know

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •