Results 1 to 9 of 9
  1. #1
    New ROGer Array
    Join Date
    Aug 2015
    Reputation
    10
    Posts
    2

    Angry G752VT left usb port not working

    Hello

    I have bought a g752vt laptop to replace my g751vt stolen in october
    Curiously different model but almost same issue:
    2 left usb ports are not working with external hard drive
    random parasit noise even with sound off

    On my g751, i had to send it 2x before getting the motherboard replaced

    If you have the same issue and find a software solution, please share it

    Asus, please you have wonderful laptop but please improve your poor quality

    Note : laptops were bought in France : one in the #1 shop and the g752 on internet

  2. #2
    ROG Enthusiast Array matrixleader PC Specs
    matrixleader PC Specs
    Laptop (Model)EUROCOM Sky X9
    MotherboardIntel Sunrise Point Z170
    ProcessorIntel Skylake i7-6700K @ 4.2 GHz
    Memory (part number)Samsung 64GB DDR4 RAM @ 2400 MHz
    Graphics Card #1GeForce GTX 980 8.0GB GDDR5 (Desktop Version)
    Sound CardSound Blaster 3D Audio
    MonitorLG LP173WF4-SPD1 17.3" 1920x1080 IPS FHD (16:9) LED Antiglare Matte Screen with G-SYNC Technology
    Storage #12 x Samsung 950 Pro 512GB M.2 NVMe PCIe x4 SSD (RAID 0)
    Storage #22x Samsung Spinpoint M9T ST2000LM003 5400 RPM 32MB Cache 2TB HDD (RAID 0)
    CPU CoolerIC Diamong Thermal Paste
    Power Supply660W AC Power Adapter
    Mouse Logitech G602
    Mouse Pad Razer Manticor
    Headset/Speakers Onkyo Speakers
    OS Windows 10 Pro
    Network RouterRT-AC68U
    matrixleader's Avatar
    Join Date
    Feb 2015
    Reputation
    10
    Posts
    73

    LOL, DE JA VU, same problem with the G750JX, G751JY, and now the G752 series, This is a joke, ASUS cannot make left USB ports. Period.

  3. #3
    ROG Guru: Orange Belt Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    310

    As a g751jy user, I find this funny and sad at the same time...

  4. #4
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,108

    You missed the G75 VW and G75 VX all had this same problem. this is the fisrt post of a G752 that has the issue maybe a random issue or maybe the rest haven't got around to noticing it yet?
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  5. #5
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    I have a G752VT-RH71. I think it depends on the power consumption of the external hdd. My WD Passport 1.5TB wont work on lefthand usb, but my ADATA 1.8TB and the stock 1TB hdd I removed and put into an external hdd enclosure both worked on the same usb ports.

  6. #6
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    7

    Mine is G752VT-T7020T,I also have issues with the left USB ports,but more specifically,when using USB 3.0 devices.
    I'm now using a very old logitech USB 2.0 hub to connect my mouse & seagate external HDD,both working fine no disconnections so far.

  7. #7
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,108

    Corporal, nothing funny about this, it been an issue since the G75VW, from that model on, my best guess is that its the actual connection to the mother board of this Daughter board. Many over the years have fixed the issue by RMA for repairs. Myself I just use a 4 port hub and a right angle connector on the right hand ports
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  8. #8
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,108

    Yes that is the exact same issue we have had all along. USB 2.0 on the left port are no issue. Its just USB 3.0 devices that have the issue on the left ports. USB 3.0 requires 500 ml/a even using a hub that powered hub still requires 500 ml/a from the USB 3.0 port.
    So no we have several people with G752 that this issue continues on with.
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  9. #9
    ROG Guru: Blue Belt Array Gps3dx PC Specs
    Gps3dx PC Specs
    Laptop (Model)Current: G751JT | Retired: G55VW, G51JX
    MotherboardInc M.2 slot
    Storage #1Samsungs EVO 850 128GB
    Storage #21TB HGST Travelstar 7K1000 (HTS721010A9E630)
    CPU CoolerMother Nature & Thermodynamics laws
    Mouse Logitech MX 518
    Headset/Speakers Logitech T6060
    OS Cleaned installed Windows 10 HOME x64
    Accessory #1 Leap Motion

    Join Date
    Feb 2015
    Reputation
    71
    Posts
    772

    Quote Originally Posted by Clintlgm View Post
    Corporal, nothing funny about this, it been an issue since the G75VW, from that model on, my best guess is that its the actual connection to the mother board of this Daughter board. Many over the years have fixed the issue by RMA for repairs. Myself I just use a 4 port hub and a right angle connector on the right hand ports
    @Clintlgm - is correct.
    The USB 3.0 left ports power issue is SYSTEMATIC through out the ROG serie.
    I don't understand how to nobody make a collective sue against asus....
    forcing them to provide a solution - free of charge - to all ROG laptops users.

    The big absurd in all of this - Asus rep doesn't even more an eye brows to reply on the matter in their OWN forum !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •