Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    19
    Posts
    16

    G752VY: Samsung 950 PRO SSD NVMe Working - Here's How I Did It

    I've noticed a lot of people seem to be having some issues with the 950 Samsung NVMe installations.

    I have the G752VY series (the one with the 980M Geforce).

    I bought a Samsung 950 PRO 512 Gig NVMe SSD.
    I bought a Samsung 850 EVO 1 Terabyte

    1) Opened up laptop and replaced the 1 Terabyte HDD with Samsung 850 EVO 2.5 Sata SSD.

    2) Added in the Samsung PRO 512 NVMe SSD to the other m2 slot available (the first slot was occupied by the default Samsung 951 128 Gig SSD that came factory installed.

    3) Loaded up windows as regular (didn't do anything or touch bios, so it's booting as regular from the 128 gig SSD

    4) ALL new drives recognized (the 850 Pro and the 950 Pro) by windows, though they are not initiallized or partitioned just yet. At this point, with the new Samsung 950 NVMe added but with nothing on it just yet, the computer had no problem loading up into windows or even detecting it as a drive from the default windows partition manager

    5) Used the Samsung Migration Software to CLONE default SSD (128 gig Samsung 951 NVMe) to the Samsung 950 PRO 512 NVMe drive.

    6)I partitioned the Samsung 850 drive

    7) Now here is where the problems began. It seems the bios has an issue recognizing BOTH m2 SSD drives at once. The bios just gave two of the exact same boot up options (the Samsung 951 default drive). Previously, there was NO issue when I had not cloned windows to the 950 PRO drive yet . But now that I had cloned the 951 to the 950 drive and had BOTH drives in the m2 slots, there was an issue and windows would NOT boot up (i got the dreaded blue error screen during startup and would be taken to Advanced Startup Options menu -- nothing fixed it)

    8) I tried swapping the m2 drives into each other's slot. Still no fix. I tried removing the 850 SSD and putting back the default 2.5 HDD. No fix. I even tried booting up with nothing in the SATA 2.5 slot (no HDD or 850 SSD). Still would not boot.

    9) It worked when I removed the ORIGIONAL 128 Samsung 951 NVMe from the m2 slot, and ONLY had the SAMSUNG 950 PRO 512 in. At this point, the computer booted up just fine and windows 10 worked wonderfully. Both the Samsung EVO 850 and the Samsung 950 PRO now work. Speeds of the Samsung read at about 2.5 gigs and write at about 1.5-2 gigs -- SO the speeds are NVMe level and the drive is working.

    So final points:

    The bios (at least on my G752VY) does not seem to support TWO m2 drives that are NVMe (when each drive is a clone of the other). As stated, I was able to boot up with both m2 NVME drives in when the SAMSUNG 950 was empty. once I cloned the other drive to it, it stopped. I'm not sure if this is a bios issues. If I can format the origional Samsung 951 SSD so there is no bootable windows / cloned drive data on it, it may work just fine. But it's a ***** to try and wipe it, since I can't have both drives in at once so I have not yt.

    I also bought a ROG GL552 and a Samsung EVO 850 m2 SATA III drive. I had issues with cloning the HDD and booting from the SSD, but figured it out. I'll post this solution in another thread.

    Anyways, hope that helps you guys!

  2. #2
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    Yes, you cannot have 2 disks with the same exact operating system (clones). I have tried with with my G752VT the one with the 970M - hehehe. So I don't have m.2, but I installed a Samsung 850 evo 250GB sata3 ssd in the drive bay. I Put the 1TB hdd in the optical bay using a caddy, booted from hdd, installed magician and cloned the hdd to the ssd. When I rebooted, even when changing the bios config to boot from the ssd, windows booted to the ssd, but the hdd was disabled because according to windows, there is another drive with the same signature.

    To format the hdd, you can use paragon hard drive manager or any other partitioning software.

  3. #3
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,126

    Yes since you can't put this in a ext. enclosure I would just remove your working 950 and 2nd drive, put the original 128GB back in and use Mini Tool partition Wizard from a Boot USB/disk. it will boot up in a PE state and allow your to Clean/Delete and initialize as a logical disk. then all 3 will work
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  4. #4
    ROG Guru: Gold Belt Array Clintlgm PC Specs
    Clintlgm PC Specs
    Laptop (Model)Asus G752VY DH72
    MotherboardAsus Z97 Pro WiFi and /Z97 Pro A
    ProcessorI7 4790K
    Storage #1512 GB M.2 Samsung 960 Pro
    Storage #21 TB Samsun 850 Pro
    CaseCool Master Haf
    OS Win 8.1 Pro and Win 10 Pro
    Clintlgm's Avatar
    Join Date
    Jul 2012
    Reputation
    105
    Posts
    4,126

    I think maybe if you hit the Esc key on boot up, that will bring up a boot menu, from that menu select the SSD you want to boot from that might work if it does then you and delete the partitons on the old SSD and initialize it as a Logical drive. end of problems.
    G752VY-DH72 Win 10 Pro
    512 GB M.2 Samsung 960 Pro
    1 TB Samsung 850 pro 2.5 format
    980m GTX 4 GB
    32GB DDR 4 Standard RAM

    Z97 PRO WiFi I7 4790K
    Windows 10 Pro
    Z97 -A
    Windows 10 Pro

  5. #5
    ROG Member Array
    Join Date
    Dec 2015
    Reputation
    19
    Posts
    16

    Ok, got it working. I took the advice and tried the Mini Tool Partion Wizard. I remove the Samsung 950 PRO from the m2 slot and put the CD that had the Mini Tool Partition Wizard BOOT version into the drive. Turned on computer, hit ESC and booted into the mini tool partition wizard. however, it would NOT boot up properly and would hang up trying to load.

    Finally, I used the Macrum Backup Boot disk I created with Macrum to boot into the Marcrum recovery area. There was no partition manager options, but I just cloned one of the non OS partitions that was on my 850 EVO drive (remember, I have three drives the 850 EVO in the 2.5 drive slot and the 951 NVMe that's in the default m2 slot. I removed the 950 PRO while doing this).

    This fixed the issue. I just had to reboot, hit ESC, change the boot order to load up the 950 as the default bootable device again, restart and wala, booted just fine into windows off the Samsung 950 WHILE also having the Samsung 951 NVMe 128 gig in the origional m2 slot. I formatted it while in windows as an extra storage drive.

    So, it's all working perfectly now!

    SO for other people trying to keep the 128 Samsung 951 NVM as a backup storage drive, Mini Tool Partition Wizard might not work -- you will need to format it / delete the OS parition on it with some other way or program to make it work.

    Ok, done here I think. Computer is working perfectly.

    Also note that I compared the Samsung 950 PRO vs the Samsung 951 128 GB (the default SSD that comes with the laptop) vs the 850 1TB 2.5 SATA with benchmark software since I have ALL three in my computer now.

    See the post: https://rog.asus.com/forum/showthrea...s-850-EVO-READ

  6. #6
    ROG Member Array
    Join Date
    Dec 2012
    Reputation
    10
    Posts
    20

    I was able to have both m.2 slots filled with 950 Pros (Win 10 on each) and a 1 tb 850 Pro. You have to do a boot over-ride in the bios to get to the drive you want to keep as the OS.
    After getting in to OS I used diskpart to clean the second 950 with the OS from a prior install.

  7. #7
    ROG Enthusiast Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    32

    Hello everybody!

    There is a new BIOS for the G752VY out (208) which update IRST
    Hopefully it fixes some issues
    http://www.asus.com/support/Download...vXVIePKB4o/45/

  8. #8
    ROG Member Array
    Join Date
    Oct 2015
    Reputation
    10
    Posts
    10

    Quote Originally Posted by dbodyguru View Post
    Computer is working perfectly.
    I seriously doubt that. Is Samsung Magician working? Do you have the Samsung NVMe Controller driver installed? Also, you don't need to clone the drive (unless you want all that Asus bloatware it comes with). You can do a clean install of Windows with the IRST drivers. But it still isn't "working perfectly" because of the driver and Magician issues. I've had my VL running a 950 Pro with a clean install of Windows 10 for over a month now and you're right it is fast as hell but it could be faster. Unfortunately, that won't be solved without a BIOS update and the jury is still out on whether this latest one is it.

  9. #9
    New ROGer Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    3

    This information is from TomsHardware.com

    http://www.tomshardware.com/reviews/...sd,4313-2.html

    Samsung 950 Pro SSD Review
    By Chris RamseyerOCTOBER 22, 2015 7:00 AM

    In RAID, the 950 Pros appear as an Intel software array. Samsung's driver does not recognize them, preventing you from installing it. The same thing happens to Intel's SSD 750s in RAID. Until Samsung adjusts its software to support RAID arrays, you'll have to use Microsoft's NVMe driver built into Windows 10, 8.x and available as a download for Windows 7. Per-drive performance drops, unfortunately, which will become obvious in certain workloads when we compare a single 950 Pro to two in RAID 0. Microsoft's implementation is more conservative, serving as a catch-all to support all revisions of NVMe. It's good enough to get your system up and running, basically.

  10. #10
    Banned Array JustinThyme PC Specs
    JustinThyme PC Specs
    Laptop (Model)G752VY-DH72
    MotherboardRampage VI Extreme
    ProcessorI9 9940X
    Memory (part number)64GB DDR4 8x8 Corsair Dominator Platinum 3800 MHz @ C17
    Graphics Card #1ASUS Strix 2080Ti O11G @ 2.1GHz
    Graphics Card #2ASUS Strix 2080Ti O11G @ 2.1Ghz
    Graphics Card #3ROG Nvlink
    Graphics Card #4Have to feed animals
    Sound CardExternal Audioengine D1 24 bit 192kbps DAC
    MonitorASUS PG348Q @ 100Hz
    Storage #1Intel 905P 480GB U2 flavor
    Storage #2Samsung 850 EVO 1TB X2 in RAID 0, 960 PRO 1TB DIMM.2_1
    CPU CoolerHeatKiller IV PRO and VRM blocks ,Dual D5 PWM serial, 2X 480, 1X 360 RADS
    CasePhanteks Enthoo Elite 8X LL120 PWM, 3X LL140 PWM, 12 SP120 PWM 1x AF140 PWM
    Power SupplyCorsair AX 1500i
    Keyboard ASUS Claymore
    Mouse ASUS Spatha, Logitech MX Master
    Headset Sennheiser HD 700
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Audioengine A5+ with SVS SB-1000 Sub
    OS Win10 Pro 1809
    Network RouterNetGear NightHawk X10
    Accessory #1 NetGear Prosafe 10GBe Switch
    Accessory #2 Qnap TVS-682 NAS modded with I7 CPU

    Join Date
    Nov 2013
    Reputation
    144
    Posts
    3,858

    Personally speaking I don't consider the lack of Samsung drivers or Samsung magician to a be consideration to deduct from the term "working perfectly". My G752VY-DH72 came with a Samsung SM951 NVMe 256GB SSD with no Samsung Drivers or Samsung magician and was working as intended by the manufacturer right out of the box, which could be termed as working perfectly. I cloned that drive onto a 950 pro without changing drivers and gained performance as I expected as the larger 512GB size has been consistently bench-marking with better results so with it performing better than the original do I now say its not working perfectly? Also no IRST drivers were installed or needed and it took me less time to uninstall the boatware than it would to do a clean install and spend half a day or better fighting drivers.

    To each his own, IMO my machine is working perfectly with a 512GB 950 pro and OEM drivers. Monday Ill be replacing the 7200 rpm 1TB drive with a Samsung 850 EVO and call it a day. Im not seeing a second M2 drive in my future. 512GB is more than enough for OS and software and 1TB onboard for data amd multimedia storage will also suffice. At home I have over 10TB NAS storage and also have 8TB of portable usb 3.0 drives. I think Im all set for storage needs.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •