Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19
  1. #1
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    1

    Linux installation in ASUS ROG GL552VW-DH71

    Hello,

    I recently bought an ASUS ROG GL552VW-DH71 and I tried to installl Ubuntu 14.04.0 . I couldn't, it is really problematic. I also tried with other linux distributions (fedora 23, linux mind, ubuntu 15.10) .

    When the live Cd is loading the following error message is showed :

    nouveau E[ PIBUS] [000:01:00.0] HUB:0x6013d4 0x00005700 (0x1c 408200)
    nouveau E[ DRM]failed to idle channel 0xccc0001 [DRM]

    The live cd often doesn't finish loading, when by luck the live cd load the touchppad is not working , the wifi is not detected the sopund is not working at all. After installing , ubuntu stop working after restarting. Could you please help me.

    Cheers

  2. #2
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    2

    I managed to boot it using Mint 19.3 with nouveau.modeset=0 and with the December Arch Linux ISO.
    It has trouble for some reason with newer kernel versions so avoid them (https://bugzilla.kernel.org/show_bug.cgi?id=109081)
    Touchpad still has no driver, and wireless works fine (intel 7265 chip).

    Somo Fn keys still have issues, but by far the major pain is now having the newer kernels since they are the ones who include the Skylake support.

  3. #3
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    2

    I have this machine running under Linux and various flavors. Here are some tips. Message me or reply here if you have trouble with the below because I am doing this from memory.

    Kernels below 4.3 (pretty much any distro at the end of December): Add "nouveau.modeset=0 tpm_tis.interrupts=0 acpi_osi=! acpi_backlight=native i915.preliminary_hw_support=1 idle=nomwait"

    The Nouveau command disables the NVidia card, which you need to do until you get proper drivers installed (use something like Bumblebee).
    The ACPI commands make your keyboard hotkeys work properly
    The i915 command tells the older kernel to use the "beta" Skylake support, which you will certainly want.
    The idle command is needed to make the new Skylake chipset speed up and down properly without locking up. I was seeing occasional lockups without the idle setting.

    With these settings, I have full function keys, screen lighting, etc, the cpu is at full speed and everything works great EXCEPT I have no touchpad support. As far as I can tell, the kernel does not support the touchpad in this machine/configuration at present. There are multiple bugs raised within the Linux community if you look around. I am hoping we will see a fix to this soon. I tried to debug the device but due to lack of time I don't think I will be able to find a fix on my own.

    After install, set X windows up to not use the NVidia drivers and you can drop the nouveau.modeset parameter. I use the Mesa open source drivers.

    For 4.3 and above kernels (which I have custom compiled from source at this point but should be rolling out on some distros soon) you can drop the i915.preliminary_hw_support and tpm_tis.interrupts. You don't need those on the latest kernel as far as I can tell.

    Don't use things like "nolapic" and other stuff you read on the internet because all that does is drop you down to one core and limit your hardware significantly. Might as well not have the new computer if you use those things.

    FWIW I think Elementary OS's latest ISO works "out of the box" with only the nouveau.modeset=0 directive. Also, it was kind of tricky to get Arch Linux to work with my home wifi due to WPA based encryption. I got it working, but if you have a similar setup be advised it took a little time to get the commands right with this wireless card.

    If you are a developer or familiar with the tools for some other reason, you can build your 4.3 kernel and its faster. Download the latest sources and find a guide online for building the kernel. It took me some time to build and run the new kernel but it did allow me to get better utilization of the CPU and graphics card.

    Quote Originally Posted by calcuchimac View Post
    Hello,

    I recently bought an ASUS ROG GL552VW-DH71 and I tried to installl Ubuntu 14.04.0 . I couldn't, it is really problematic. I also tried with other linux distributions (fedora 23, linux mind, ubuntu 15.10) .

    When the live Cd is loading the following error message is showed :

    nouveau E[ PIBUS] [000:01:00.0] HUB:0x6013d4 0x00005700 (0x1c 408200)
    nouveau E[ DRM]failed to idle channel 0xccc0001 [DRM]

    The live cd often doesn't finish loading, when by luck the live cd load the touchppad is not working , the wifi is not detected the sopund is not working at all. After installing , ubuntu stop working after restarting. Could you please help me.

    Cheers

  4. #4
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    2

    Quote Originally Posted by vishneda View Post
    For 4.3 and above kernels (which I have custom compiled from source at this point but should be rolling out on some distros soon) you can drop the i915.preliminary_hw_support and tpm_tis.interrupts. You don't need those on the latest kernel as far as I can tell.

    Don't use things like "nolapic" and other stuff you read on the internet because all that does is drop you down to one core and limit your hardware significantly. Might as well not have the new computer if you use those things.
    How are you able to boot kernels >= 4.3?
    It only booted so far with acpi=off or nolapic with me. Tried to play with several things, cstates etc... but nothing did the trick.
    So far I'm using 4.4rc8 with nolapic since it just works.
    I have two bootloader options. One for 4.1LTS with bumblebee enabled but a lot of buggy hardware and one for 4.4 with all but one core disabled yet with important stuff (such as suspend and resume, fanspeed, etc...) working fine.

    I was hoping for 4.4 to have the touchpad driver, but it seems to be a freedesktop.org thing, not with the kernel.

    Do you have any more information you can share?

    Thanks for sharing

  5. #5
    New ROGer Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    2

    Hi!

    I am able to boot with 4.2.x and 4.3.x. However, I am using 4.3.3 and have been since mid December when it came out.

    If you boot with nolapic, you won't have full use of the hardware and cpu threading will be disabled. I had no issues using the machine this way, but it was only supporting one thread of cpu activity instead of 8 as it should be. Using the kernel parameters I provided, I am booting various distributions (CentOS, Fedora, Arch, Elementary as examples) with no issues.

    I do have new information to share. Fedora recently rolled out 4.3.3 as a kernel support and I upgraded to this today. With the new Fedora 4.3.3 kernel, I have full use of the touchpad . The reason is actually something I missed/didn't know about the hardware under the hood. In order to get the touchpad working, the i2c_designware bus support must be compiled as a kernel module. I didn't have that in previous builds and thus, I was unable to use the touchpad. As of tonight, I am using the touchpad, all function keys, and full hardware support on this machine running on Linux!

    If you can tolerate (or like) Fedora, I would recommned getting the Fedora 23 distribution and installing this on your machine. In order to install, you may need to use the "4.2.x" kernel parameters I provided above. Once you get it booted, you can run "dnf update" and upgrade to the latest kernel, which will be 4.3.3. From there, you will need to use the "4.3.x" kernel parameters I provided above. Using this distro and the parameters I listed, this machine is functioning quite well on Linux.

    I hope this helps. I will check back in a couple of days to see if it worked for you.

    Quote Originally Posted by claudiop View Post
    How are you able to boot kernels >= 4.3?
    It only booted so far with acpi=off or nolapic with me. Tried to play with several things, cstates etc... but nothing did the trick.
    So far I'm using 4.4rc8 with nolapic since it just works.
    I have two bootloader options. One for 4.1LTS with bumblebee enabled but a lot of buggy hardware and one for 4.4 with all but one core disabled yet with important stuff (such as suspend and resume, fanspeed, etc...) working fine.

    I was hoping for 4.4 to have the touchpad driver, but it seems to be a freedesktop.org thing, not with the kernel.

    Do you have any more information you can share?

    Thanks for sharing

  6. #6
    New ROGer Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    2

    With 4.3.3 I only needed to update grub with "acpi_osi=Linux idle=nomwait"

    Also my touchpad and keyboard lighting is working after this.

    Now I just need to figure out how to get the GTX960m working.

  7. #7
    ROG Member Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    7

    Quote Originally Posted by kinappy View Post
    With 4.3.3 I only needed to update grub with "acpi_osi=Linux idle=nomwait"

    Also my touchpad and keyboard lighting is working after this.

    Now I just need to figure out how to get the GTX960m working.
    Any luck installing the NVIDIA drivers on Linux?? Cheers!

  8. #8
    New ROGer Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    2

    Quote Originally Posted by erick.chumit View Post
    Any luck installing the NVIDIA drivers on Linux?? Cheers!
    I tried bumblebee but it broke X and never had time to check what the problem was so I'll have to get back to it later.

  9. #9
    ROG Member Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    11

    Okey guys,
    I have managed to run NVIDIA driver with Bumblebee. I am running archlinux with kernel 4.4.1 and the NVIDIA 361 (beta) driver. They are marked as stable in the archlinux repository.

    This guide was helpfull:
    https://wiki.archlinux.org/index.php...Intel.2FNVIDIA


    - BTW, the linux is producing more heat than the windows. Why is that?
    - Do i need to change any kernel options with this kernel? Thank you!

    UPDATE:
    That NVIDIA module is not running quite well. When i have enabled bumblebeed service and reboot the system freezes. And when I boot up again and enter my credentials into GDM - the system freezes again. There is error output in the logs since everything is frozen so don't know what is the issue here. When i disable and stop the bumblebee service there are no issues.
    However i think that this is related to this bug. I guess we have to wait for Bumblebee 4.0
    Until then we can use the mesa drivers. At least we can run wayland with these drivers :P
    Last edited by set_killer; 02-10-2016 at 07:44 PM.

  10. #10
    ROG Member Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    11

    Also the sound is terrible. Its vary quiet. Do you have the same problem?

    Thank you.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •