Results 1 to 3 of 3
  1. #1
    New ROGer Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    1

    Latest win 10 update killed my xonar phoebus sound card software!!!

    Hi



    First of all thanks for taking the time to help me out here...



    Two days ago on the 16th January 2016 my PC updated and required a reboot, so I dutifully did as I was asked, worrying as to whether everything would still be OK as in the past win 10 updates have pretty much messed with everything from display drivers to my antivirus not working hmmmph!



    So I waited for the update to install and yes to my dismay another problem, NO SOUND!



    I have an Asus Xonar Phoebus Rog sound card, so I headed off to their website to see if I could download some updated drivers, and yes their they were. Thankfully, I downloaded them and installed them, YeY! We have sound.

    My motherboard is MSI Z97 Gaming 7.

    I also have Realtek Digital Output and AMD High Definition Audio Device (could these be interfering ? They didn't before)



    BUT!!!

    Neither the software (Sonic Studio Pro) that controls the card nor the Dolby Home Theatre works any more and also I cannot record properly using cool edit pro, it sounds like I am recording off an old tape deck and mono mike. Now I am all for nostalgia but if I want that sound I will download a filter lol.

    All this worked prior to the updates.



    So please, please, please can anyone help ?

    I cant find updates for the Dolby software (which I am pretty sure is why Sonic Studio wont work) anywhere, their site simply instructs me to head on over to Asus site (which I did) to DL the latest drivers, which they have but with no Dolby nor Sonic Studio. The thing is this.

    Without the software the sound card sounds rubbish lol, no eq, no bass boost, no voice clarity, no surround sound etc. I could go on, but seriously without the Sonic Studio and Dolby (or other software, which I don't yet know about, so if anyone knows please also let me know.) the card quite simply cannot work.

    The software is needed to control it, so I would have thought it was pretty integral and I cant believe that Asus didn't release it with the updated drivers. Hmmmph...



    But if anyone knows a work around or of any way to get it all working again all suggestions welcome



    Cheers



    Aeon

  2. #2
    ROG Enthusiast Array
    Join Date
    Nov 2013
    Reputation
    10
    Posts
    41

    Not surprised at all. I've given up on this a long time ago.

    Actually Surround Sound functions without all that stuff (discrete, real 100% genuine true surround sound) through the analog outs. Most of the Surround Sound you get from stereo sources are artifacts actually because very rarely is there real surround encoded in this manner outside of movies and certain games that have the Dolby Pro Logic logo on it.

    Some of those features are mainly there because of the crappiness of computer speaker manufacturers and uninformed consumers. Also electronic manufacturers just suck period, especially in the age of disposable iPhones and stuff.

    You can get an AVR and be done with sound cards by simply using HDMI connections (assuming what you get functions without issues). Or you can try to find one (usually an expensive one) that has analog 5.1/7.1 inputs, if you want to use a sound card with it. You have an EQ that will always work in this case and a Dolby Pro Logic decoder.

    I've grown increasingly fed up with the offers of various sound card manufacturers and just think it's an attempt at the end of the day to drive people away from discrete cards or force them to constantly upgrade their hardware.

    Try looking at computer speaker set offerings, just terrible in this day and age, if you ask me.

    To be honest with you. You're at the mercy of the corporate overlords who care nothing about your problems or with providing you with a product that works 100% right for more than a few years or even providing you with a product that even meets your needs, when the vast majority don't share them or market products towards the suckers that don't have a clue.

    As for the microphone issues? This is a lost cause. Not much you can do except get a USB microphone headset that has decent support from it's manufacturer or try an offering from a different sound card manufacturer.

    A lot of people on here say how happy they are with their Creative sound cards, but a quick look at the negative reviews on Amazon and a look on the forums suggests otherwise.

    P.S. Sonic Sound Studio user interface has since been discontinued. You'll have to use the old interface or get a new Strix card from ASUS.
    Last edited by SoundMan; 01-18-2016 at 08:25 PM.

  3. #3
    ROG Guru: White Belt Array Florin's Avatar
    Join Date
    Dec 2013
    Reputation
    10
    Posts
    121

    Don`t blame Win 10 for other`s problems.

    To solve your problem just un-install everything related to the soundcard and install the latest driver on their page. You`ll have the old interface and the Dolby Home Theater app.

    If you really want the old driver that had Sonic Studio Pro i can provide a temporary link to it, since i see from the ASUS site it`s not available anymore.
    i7-4790k + Corsair H80i | Asus Maximus VII Ranger | 16 GB Corsair Vengeance DDR3 1866 | Sapphire R9-290 OC Vapor-X 4GB | Asus Xonar Phoebus + Audio Technica M50 | 1xSSD Corsair 120 GB | 4x1 TB Seagate HDD | Corsair CX750M | Corsair Carbide 300R | Razer Taipan + Logitech G11 | Windows 10 64bit

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •