Results 1 to 4 of 4
  1. #1
    ROG Member Array
    Join Date
    Sep 2011
    Reputation
    10
    Posts
    6

    Problem with ASUS G74 - shut down and can no longer turn on

    hi all, as the title I have a problem with my asus g74, while I was using it, it has shut down and now I can no longer turn it on, I noticed that the LED indicator of the power supply was turned off, now if I wait a few minutes and reconnect the power supply to the power the LED light back on, but it immediately shuts off if I connect it to the laptop.

    This made me think (hope ..) that the problem is the power supply, however, I tried to connect the adapter to an old asus laptop and it seems to work correctly (this laptop requires 90W, the power supply of the g74 is 150W ) but if I connect the power supply of my old asus (90W) at the g74, led is blinking and the laptop does not turn on, but I do not know if this may be due to the fact that i'm using an underpowered power supply.

    assume that I have not a battery.

    what do you think can be the problem, power adapter or laptop?

    edit: forgot to mention that if once the LED on the power supply is turned off by connecting it to the G74 this does not lights up for some time after disconnecting from the laptop

    thx for help and sorry for my bad english.
    Last edited by Acciaio; 01-15-2016 at 01:21 PM.

  2. #2
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    Probably a bad power adapter. If you have a voltmeter you can check the voltage output of your power adapter. Should be equal or greater than the rated output voltage. You can also try to charge the battery with the laptop off. If you connect the power adapter to the laptop even when off, does its led turn off? It should be on all the time. Could also be that the battery or board is shorted. Try also to remove the battery and power on laptop using only the power adaptor.

  3. #3
    ROG Member Array
    Join Date
    Sep 2011
    Reputation
    10
    Posts
    6

    thx for reply
    Unfortunately, my worst fears have come true, I tried with a new power supply and get the same results, no LED lights up on the PC either with or without battery.
    at this point I think it is the laptop, i can only turn to assistance and it is also out of warranty.
    some idea of what it might cost?

  4. #4
    ROG Guru: White Belt Array
    Join Date
    Aug 2015
    Reputation
    12
    Posts
    113

    It could be the DC/DC board, basically the board the power button is connected to...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •