Results 1 to 2 of 2
  1. #1
    ROG Member Array
    Join Date
    Nov 2015

    G751 and Linux Mint 17.3 64bit

    Before reading you should now I managed to install Mint 17.3 beside Windows 10 on my HDD

    Alternative title: Why is the linuxinstallation so difficult and user-unfriendly??

    Hey all,
    I tried forever to get Linux Mint 17.3 x64 on our G751(NVIDIA 980m) installed, but to say the least: this linuxinstallation isnt easy.
    I mean its not just swearing arround, the whole installation procedure its really totally messed up and/or made for experts.

    First: I successfully made a bootable UEFI pendrive using rufus. Then beeing excited I tried to boot:
    Booting from the pendrive will throw errors and then stop loading:

    1) Ignoring BGRT: invalid status 0 (expected 1)
    2) Error parsing PCC subspaces from PCCT
    3) ACPI PCC probe failed

    Ok, googling arround I found this errormessages are just some linux-garbage, and the real issue is our gfx-card. So in GRUB
    I pressed "e" to get to the commandline and quickly added a additional "nouveau.setmode=0" and voila the Linux Mint Desktop
    appears. Nice, I tried arround and decided to like it and to install beside my Windows 10.
    But I do not trust Linux for good reason, so first I tried installing it on another pendrive.

    The nightmare began:
    Installation on the other pendrive endet w/o errors, so far so good.
    But booting from it, nothing worked, just a blank screen. WTF?

    Ok, force switchoff our G751 and tried booting again: Ahh Linux noted, that it could not start and let me into grub.
    Easyly pressed "e" and added our noeveau.setmode=0. Didnt help at all. Still blank screen.

    I do not bore the hell outta you by writing what I tried with all the time I wasted on this garbage.
    I will just tell you my conclusion for the only way to boot into Mate-Desktop:
    Force switchoff the G751 during blankscreenboot to get into grub, then pick recovery, then in the recovery select continue bootup.

    Once booted up, I successfully updated the whole system, no change.
    I tried to install NVIDIA Drivers, failed install.
    Do not think you could easiely edit the grub.cfg, because its extremely write protected, and you cannot remove this protection.

    I have to admit, that i barely touched Linux, so its most probably my fault due my obviously very low IQ low experience and my unwillness to spent more weeks in studing
    how to install Linux, so I might do not deserve to have it.
    So my conclusion on this is: beeing already 2016 Linux is still only for experts/nerds. Or ppl willing to pay someone to setup the system.

    Apart from this sarcasm, please do not get me wrong, I liked the Linux Mint Mate very much and I would love to have it as my main OS.
    Its just the installation is way beyond my capabilities.
    I really wonder why there is no automatic fail-safe boot in vga or ega mode if previous boot attempts fail? During bootup there has to be a fancy bootscreen with 16bit colours!! WTF?

    Obvously I am not gonna try to install it beside from Windows 10, as it will screw the bootloader f0 sh0.

    Anyway, maybe here are some hints that help other folks, to get at least to the desktop of Linux Mint 17.3

    Last edited by bululu; 01-19-2016 at 03:25 PM.

  2. #2
    ROG Member Array
    Join Date
    Nov 2015

    I managed to let Mint boot from the flash drive by adding "nomodeset" to kerneloptions in GRUB, but there are still the problems with the NVidia drivers.
    But surprise: Next time I wanted to boot, there was no more the windows, but grub on my mainhdd, even i said to install the bootmanager on sdc (flash)

    So all this messed my system up and I decided to install mint "behind" the Windows 10 partition, hoping this will fix the junk and let me get into windows again.

    It did, and also I could install the nvidia drivers, weird, that this do not work when booting from pendrive.
    Anyway, I still have to use the nomodeset option, but now I can dualboot both OSes.

    Its still very User-unfriendly but it works, somehow
    Last edited by bululu; 01-19-2016 at 03:23 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts