Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    ROG Member Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    7

    How to Dual Boot Windows 7 & Windows 10 x64 on ROG GL552VW (Windows 10 pre-install) ?

    Hello all,

    I know this subject has been discussed extensively in this forum as well as in others. And I swear I have read quite a lot of forums on how to resolve this. But almost all how-tos say the same steps which sound very easy. Thus, I am starting to believe that my situation is specific or something's wrong.

    Here's my story:

    I have Windows 7 x64 ISO file (The one you can actually choose which version to install). I've followed several tutorials on how to create a bootable UEFI DVD or UEFI USB (GPT partition, bootx64, etc etc) and I succeeded. Then I set the Boot options to: NO-SECURITY-BOOT/NO-FAST-BOOT/ENABLE-CSM on the Boot options and In that I have also been able to boot from the UEFI USB (Yes, by choosing UEFI USB, and not the regular USB). I then realized that, once in the the Win7 Setup, it didn't detect the same USB I used to open the setup. Strange. But anyway, I found a program that adds some Intel USB 3.0 drivers to the USB installation and was finally able to run the setup and continue with the installation.

    **A note here: it's strange that when CSM is disabled, the boot menu does see the UEFI: USB option but doesn't work. I have to set the CSM to enabled and choose UEFI USB. It's kind of contradictory.

    Any way, going forward. For those of you who have this laptop, you are aware that there is a D: DATA partition disc that comes from the factory. I erased that partition and used that to install W7. I got to run the Setup and was able to install it successfully. After installation, I get to see W7 and W10 in the WIndows Boot Manager. But then I realized some things about the installation:

    1. If I don't enable the CSM compatibility option, I still see W7 in the boot manager but it hangs on the "Starting Windows" screen and never starts up. Only if I set CSM, can I start up W7.

    2. Once I'm there, it's like the USB problem all over again. There are no USB drivers.

    3. There are a whole bunch of OTHER missing drivers too, that are NOT found nor detected. Heck, I don't even have a mouse (since the USB ports don't work, I can't plug in an external mouse either). I had to enable Mouse Keys from Accessibility to move around or use the TAB button which is a PITA. I don't have Ethernet, USB, Trackpad, Sound, etc. I don't know if this is normal?

    In general, W7 is useless right now. I mean I can't do anything. I was able to download the Intel AC WiFi drivers (I downloaded it in W10 and copied the file to the partition of W7 while on W10, ...GEEZ) and so at least I have WiFi, but I can't do much still. If I go to Device Manager, it has something like 15-20 Unknown Devices which includes a lot of stuff.

    For any of you guys who were able to clean install or dual boot install W7 with UEFI, am I doing something wrong or is this normal? Did you deal with the same stuff here?

    Also, I though because the installation was on an USB with UEFI, should'nt I be able to (after the installation) enable back again the security boot/fast-boot/ and disable the CSM thing like it was before? Or will I have to leave these options forever as long as I have W7? I don't get it.

    I would greatly appreciate any suggestions.

    Thanks Cheers!

  2. #2
    ROG Enthusiast Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    26

    I did W7/W10 dual boot on G751JY. What I did differently was clean install on a new SSD for both of them, W7 first and then W10. With W7 I had same kind of problems. Asus does not seem to provide W7 drivers. There was a topic on this forum, which helped me and now I have a functional W7. In the beginning, I had no network at all, fortunately usb did work, display drivers were not there, audio was not there, etc. I had to manually find and install everything. Most of the stuff came from asus support site, mostly using W8.1 drivers...

  3. #3
    ROG Guru: Black Belt Array Korth PC Specs
    Korth PC Specs
    MotherboardASUS X99 R5E (BIOS2101/1902)
    ProcessorHaswell-EP E5-1680-3 SR20H/R2 (4.4GHz)
    Memory (part number)Vengeance LPX 4x8GB SS DDR4-3000 (CMK32GX4M4C3000C15)
    Graphics Card #1NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Graphics Card #2NVIDIA Quadro GP100GL/16GB, 16xPCIe3, NVLink1 (SLI-HB)
    Sound CardJDS Labs O2+ODAC (RevB), USB2 UAC1
    MonitorASUS PG278Q
    Storage #1Samsung 850 PRO 512GB SSDs, 4xSATA3 RAID0
    Storage #2Comay BladeDrive E28 3200GB SSD, 8xPCIe2
    CPU CoolerRaijintek NEMESIS/TISIS, AS5, 2xNH-A14
    CaseObsidian 750D (original), 6xNH-A14
    Power SupplyZalman/FSP ZM1250 Platinum
    Headset Pilot P51 PTT *modded*
    OS Arch, Gentoo, Win7x64, Win10x64
    Network RouterActiontec T3200M VDSL2 Gateway
    Accessory #1 TP-Link AC1900 Archer T9E, 1xPCIe
    Accessory #2 ASUS/Infineon SLB9635 TPM (TT1.2/FW3.19)
    Accessory #3 ASUS OC Panel I (FW0501)
    Korth's Avatar
    Join Date
    Mar 2015
    Reputation
    152
    Posts
    2,719

    I've had problems installing Win7/Win10 multiboots on the same drive and same machine when using Microsoft's garbage tools. Physically swapping between Win7 and Win10 drives is workable, but it's a bit too much hassle for a laptop.

    The only way I've been able to configure it successfully was by running WinOS boot instances in linux VMware. But configuring linux and configuring a hypervisor is more involved than simply installing Windows.

  4. #4
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    Probably, the new laptop hardware do not support generic drivers found in win7. Why not use virtual machines? I was always using virtualbox to run xp and linux programs in my win7 before. Havent tried windows 7 in win10 though. I'll try when i get home. But i think it will work just fine.

  5. #5
    ROG Member Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Saipher View Post
    I did W7/W10 dual boot on G751JY. What I did differently was clean install on a new SSD for both of them, W7 first and then W10. With W7 I had same kind of problems. Asus does not seem to provide W7 drivers. There was a topic on this forum, which helped me and now I have a functional W7. In the beginning, I had no network at all, fortunately usb did work, display drivers were not there, audio was not there, etc. I had to manually find and install everything. Most of the stuff came from asus support site, mostly using W8.1 drivers...
    Interesting. When installing W7, what options did you configure on your BOOT menu? Did you have to enable CSM? Disable security-boot?

  6. #6
    ROG Member Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Julskey View Post
    Probably, the new laptop hardware do not support generic drivers found in win7. Why not use virtual machines? I was always using virtualbox to run xp and linux programs in my win7 before. Havent tried windows 7 in win10 though. I'll try when i get home. But i think it will work just fine.
    I did try with a virtual machine. In fact, I had VM Ware with Win7, Win Vista, Win XP, and Ubuntu. The thing is that when I ran some heavy software I need, the VM crashed or so. I really don't know what was going on. Thus, I wanna try with a Native Installation of W7 and not virtual one. Thanks

  7. #7
    ROG Enthusiast Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    26

    Quote Originally Posted by erick.chumit View Post
    Interesting. When installing W7, what options did you configure on your BOOT menu? Did you have to enable CSM? Disable security-boot?
    Yes and yes.

  8. #8
    ROG Member Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    7

    Quote Originally Posted by Saipher View Post
    Yes and yes.
    Did you get any trouble detecting the USB Controller Driver in W7?

    Mine is missing the USB Controller Driver, some PCI Communications Controller and PCI Data Acquisition and Signal Processing Controller. I really don't know what's the deal but I can't even connect a Mouse (Because we are all aware that the ASUS TrackPad is a NO-GO on W7).

  9. #9
    ROG Enthusiast Array
    Join Date
    Dec 2015
    Reputation
    10
    Posts
    26

    No problem with USB for me on G751JY.

  10. #10
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    How to Dual Boot Windows 7 & Windows 10 x64 on ROG GL552VW (Windows 10 pre-in...

    Hi All,

    I've got a GL552VW arriving tomorrow along with an m.2 ssd drive and win 7 pro 64. I'd like to install win 7 in the ssd and leave win 10 on the 1 TB drive. Is this going to work? I've installed win 7 on a different asus machine that came with win 8, so I'm familiar with all the bios changes and driver hunting, no worries there. Don't care about the fact that there is no trackpad driver in win 7.

    Unfortunately, a bunch of apps I use do not yet support 10 or function properly in it and a VM will not work. It'll be a single purpose machine (audio recording), no gaming, no web browsing, etc.

    Thanks!!
    Last edited by rjaudio; 02-07-2016 at 04:24 PM.

Page 1 of 2 1 2 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •