Results 1 to 5 of 5
  1. #1
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    Asus Rog g751jm Service bay doesn't open [solved]

    Hello guys i recently purchased this laptop in Russia, the first thing i wanted to do is to upgrade the ram and install a new SSD and i was very excited with the Asus service bay specially that it doesn't void warranty to open it like my previous MSI laptop, but unfortunately after i unscrewed the screw to open the service bay i found out that it's stuck!!! no matter how hard i pushed it simply didn't open, did any one had this problem before? how should i solve it? i am struggling with the warranty service here in Russia, shouldn't they simply replace my laptop as it's clearly a manufacture problem

  2. #2
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    Did you manage to unscrew the single screw? The screw should not be hard to remove, just use the correct size. I think it does not come out of the cover, but once fully unscrewed counter-clockwise, you can already carefully pull out the rubber tab and the plastic cover should lift a little. Then use your other hand and fingers to pry open the cover.

    Here's a video. https://www.youtube.com/watch?v=3x7px8mx5LU
    Last edited by Julskey; 02-15-2016 at 06:47 AM.

  3. #3
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Julskey View Post
    Did you manage to unscrew the single screw? The screw should not be hard to remove, just use the correct size. I think it does not come out of the cover, but once fully unscrewed counter-clockwise, you can already carefully pull out the rubber tab and the plastic cover should lift a little. Then use your other hand and fingers to pry open the cover.

    Here's a video. https://www.youtube.com/watch?v=3x7px8mx5LU
    Hello i did unscrew the single screw without any problem, but after i unscrewed it and when i try to pull the cover it just wont come out no matter in what direction i pull, i can see that cover is pulled out in the area around where the screw was but the rest of the cover seems to be soldered to the body it simply won't move

  4. #4
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    You need a little bit of force when opening the cover as they are latches to keep it in place. Just pull the rubber tab covering the screw, try to grab the cover with your fingers, put fingers one by one slowly under the edges of the cove. Once under, pull up the cover upward. You should also keep one hand on the laptop to keep it in place.

  5. #5
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    5

    Quote Originally Posted by Julskey View Post
    You need a little bit of force when opening the cover as they are latches to keep it in place. Just pull the rubber tab covering the screw, try to grab the cover with your fingers, put fingers one by one slowly under the edges of the cove. Once under, pull up the cover upward. You should also keep one hand on the laptop to keep it in place.
    Thanks a lot Julskey, i followed your advice step by step and it was like magic it opened straight away, i seriously thought that there was something wrong with my unit, but know everything is working great, i really appreciate it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •