Results 1 to 1 of 1
  1. #1
    New ROGer Array
    Join Date
    Jan 2016
    Reputation
    10
    Posts
    2

    Exclamation Touchpad not working on Linux (Kali Linux 2.0) [Can't be detected]

    Hey ROGers!, how are you all doin today ? I'm new here to the Asus Rog community. Well as you can tell from the title,

    I've just installed Kali Linux 2.0 on my HHD beside my SSD Windows 10. I had to reinstalled it multiple times due to GPU driver issues.
    and everytime i boot my linux it cannot detect my touchpad driver! It's not working. I'v tried so many solutions but non of them worked.
    I tried installing Gpointing with apt-get install gsynaptics and still the touchpad is not detected. even during the installation of linux i couldn't
    use the touchpad so i had to use the mouse.

    My notebook is : ASUS Rog G551VW [ GeForce 960M, i7-6700HQ, 1TB HDD( linux & my data ) 125 SSD (windows and program files), ]

    here is my output of lshw:
    http://pastebin.com/SCaKM7MB


    and here is my output of: xinput

    Code:
    root@kali:~# xinput
    ⎡ Virtual core pointer                    	id=2	[master pointer  (3)]
    ⎜   ↳ Virtual core XTEST pointer              	id=4	[slave  pointer  (2)]
    ⎜   ↳ ASUS Laser GAMING MOUSE                 	id=11	[slave  pointer  (2)]
    ⎣ Virtual core keyboard                   	id=3	[master keyboard (2)]
        ↳ Virtual core XTEST keyboard             	id=5	[slave  keyboard (3)]
        ↳ Power Button                            	id=6	[slave  keyboard (3)]
        ↳ Video Bus                               	id=7	[slave  keyboard (3)]
        ↳ Video Bus                               	id=8	[slave  keyboard (3)]
        ↳ Sleep Button                            	id=9	[slave  keyboard (3)]
        ↳ USB2.0 HD UVC WebCam                    	id=10	[slave  keyboard (3)]
        ↳ Asus WMI hotkeys                        	id=12	[slave  keyboard (3)]
        ↳ AT Translated Set 2 keyboard            	id=13	[slave  keyboard (3)]

    I went to Windows 10 -> Device manager -> pointing devices -> and i saw that the driver is : ASUS Touchpad driver
    maybe this is the problem, does it support linux or no ? or how should i install it to get it wokring.


    Thank you in advance!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •