Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    8

    Bluetooth not working on G751JY

    I have a brand new G751JY-DB72 and the bluetooth doesn't seem to work. To be more exact the driver is installed "Intel Bluetooth Driver v17.0.1405.0464" according to the Asus Installation Wizard utility but I don't see any indicator of a bluetooth device or any way to add one. What driver does this laptop uses? On Asus support page there are three different drivers listed which is very confusing:

    Qualcomm Atheros BlueTooth driver
    Intel BlueTooth driver
    Broadcom BlueTooth driver

    So, which chip does this laptop have? What driver should I install again?

    Thanks for help!

  2. #2
    Banned Array JustinThyme PC Specs
    JustinThyme PC Specs
    Laptop (Model)G752VY-DH72
    MotherboardRampage VI Extreme
    ProcessorI9 9940X
    Memory (part number)64GB DDR4 8x8 Corsair Dominator Platinum 3800 MHz @ C17
    Graphics Card #1ASUS Strix 2080Ti O11G @ 2.1GHz
    Graphics Card #2ASUS Strix 2080Ti O11G @ 2.1Ghz
    Graphics Card #3ROG Nvlink
    Graphics Card #4Have to feed animals
    Sound CardExternal Audioengine D1 24 bit 192kbps DAC
    MonitorASUS PG348Q @ 100Hz
    Storage #1Intel 905P 480GB U2 flavor
    Storage #2Samsung 850 EVO 1TB X2 in RAID 0, 960 PRO 1TB DIMM.2_1
    CPU CoolerHeatKiller IV PRO and VRM blocks ,Dual D5 PWM serial, 2X 480, 1X 360 RADS
    CasePhanteks Enthoo Elite 8X LL120 PWM, 3X LL140 PWM, 12 SP120 PWM 1x AF140 PWM
    Power SupplyCorsair AX 1500i
    Keyboard ASUS Claymore
    Mouse ASUS Spatha, Logitech MX Master
    Headset Sennheiser HD 700
    Mouse Pad ASUS ROG Sheath
    Headset/Speakers Audioengine A5+ with SVS SB-1000 Sub
    OS Win10 Pro 1809
    Network RouterNetGear NightHawk X10
    Accessory #1 NetGear Prosafe 10GBe Switch
    Accessory #2 Qnap TVS-682 NAS modded with I7 CPU

    Join Date
    Nov 2013
    Reputation
    144
    Posts
    3,855

    Quote Originally Posted by kutyafal View Post
    I have a brand new G751JY-DB72 and the bluetooth doesn't seem to work. To be more exact the driver is installed "Intel Bluetooth Driver v17.0.1405.0464" according to the Asus Installation Wizard utility but I don't see any indicator of a bluetooth device or any way to add one. What driver does this laptop uses? On Asus support page there are three different drivers listed which is very confusing:

    Qualcomm Atheros BlueTooth driver
    Intel BlueTooth driver
    Broadcom BlueTooth driver

    So, which chip does this laptop have? What driver should I install again?

    Thanks for help!
    https://downloadcenter.intel.com/pro...reless-AC-7260

    3rd down is your wireless and 4th is your BT. Usually get more up to date drivers looking at the wireless card manufacturing website.

  3. #3
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    8

    Thanks! Since I'm running Win 8.1 I assume I shouldn't use the 4th win 10 driver but rather the one further down for 8.1.

    So this laptop has the Intel BT module? If so why does the support page also lists BT drivers for Qualcomm and Broadcom ?!?

    Also, I did the F9 re-image/reset and that should put everything back to factory config yet the BT driver doesn't seem to work. Don't quite get how Asus configured this machine...

  4. #4
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    8

    OK, I've installed the latest Intel BT driver and still no change. I don't see a Bluetooth option when trying to add a new device. I'm installing all the Win 8.1 updates now to see if that makes a difference. I really would like to make this work so I can use my bluetooth headset. Can someone take a screenshot of what it looks like where you add/pair a new bluetooth device in Windows 8.1 ? Thanks!

  5. #5
    ROG Guru: Orange Belt Array Julskey's Avatar
    Join Date
    Feb 2013
    Reputation
    30
    Posts
    388

    Check Device Manager, if there are items with yellow trangle and exclamation point, it means that there are devices that are not working and windows cannot find the driver for them and it is probable that it could be your bluetooth device. You can install drivers one by one until the errors in the device manager will disappear. Then uninstall the wrong driver/application installed from programs and features if any are present there.

  6. #6
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    8

    In device manager under Network Adapters I only see two items:
    - Intel Dual Band Wireless AC 7260
    - Realtek PCIe GBE Family Controller

    No Bluetooth anywhere in the device tree and no yellow triangles either.

    Should there be a separate item for it somewhere?

  7. #7
    ROG Guru: Yellow Belt Array antoine52200 PC Specs
    antoine52200 PC Specs
    Laptop (Model)G751JT
    MotherboardASUS
    Processori7-4720HQ OC at 3.8Ghz
    Memory (part number)16Go 1600Mhz OC
    Graphics Card #1NVIDIA GTX 970M OC
    OS Win10 64bits
    antoine52200's Avatar
    Join Date
    Jul 2015
    Reputation
    10
    Posts
    241

    Go into services.msc, and check if you see bluetooth there, and make sure it is set as automatic, and you can also start the service manually

  8. #8
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    8

    Well, I checked the services and the hands free and support services were not running. However even after starting all BT services it doesn't work. Funny thing is the laptop even have the little Bt sticker next to the right USB port. Maybe this laptop only received the sticker. I don't know what else to do. I'll try to contact ASUS.

  9. #9
    ROG Guru: Yellow Belt Array antoine52200 PC Specs
    antoine52200 PC Specs
    Laptop (Model)G751JT
    MotherboardASUS
    Processori7-4720HQ OC at 3.8Ghz
    Memory (part number)16Go 1600Mhz OC
    Graphics Card #1NVIDIA GTX 970M OC
    OS Win10 64bits
    antoine52200's Avatar
    Join Date
    Jul 2015
    Reputation
    10
    Posts
    241

    Do you use wifi? Because, i had this issue, when i used ethernet, i disabled wifi and my bluetooth stopped working.. I had to turn it back on to use bluetooth..

  10. #10
    ROG Member Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    8

    Yes, I only use wifi. As I said, bluetooth device is not even in the Device Manager list anywhere.

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •