Results 1 to 9 of 9
  1. #1
    New ROGer Array
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    3

    Unhappy ASUS ROG G20 Problem (Reboot+Crash+Fans Soaring)

    Hello,

    I have a ASUS ROG G20. (ASUS ROG G20AJ-US023S Intel i5 3.2GHz 8GB 1TB HDD 8GB SSD NVIDIA GTX 750 2GB Desktop)
    Its brand new & I have properly maintained the computer.

    When I play any games etc the monitor freezes and at the top of the monitor's displays it disconnects the HDMI/AVI/Etc.
    After a second or so when the screen turns black then this weird noise plays (sounds like a weird crash noise example; "wzzerggggggggg") and after that the PC fans start to soar and get loud, afterwards it shuts down with the lights still on or either it stays on but nothing is working etc. until I hard shut it off by holding the power button.

    I have even clean installed windows 10 again also checking all drivers, updating all drivers, checking all software that could be a problem, and kept a eye on my temp. along with noting my fan speed.

    Computer Specs:
    **Operating System** - Windows 10 (64-Bit)
    **Processor** - 4th generation Intel® Core™ i5-4460 Processor 3.2GHz
    **Chipset** - Intel® H97
    **Graphic** - NVIDIA® GeForce GTX 750 2GB
    **Memory** - 8GB dual-channel 1600MHz DDR3, expandable to 16GB
    **Storage** - 1TB 7200RPM HDD / 8GB SSD hybrid drive
    **Optical Drive** - Slim tray Super Multi DVD burner
    **Wireless Data Network** - 802.11a/b/g/n/ac, Bluetooth V4.0
    **LAN** - 10/100/1000 Mbps
    **Audio** - SonicMaster High Definition 7.1 Channel Audio

    **Monitor** - ACER K272HL 27" 1920X1080 60Hz

    **Peripherals**
    Razer Black Widow Chroma Ultimate
    Razer Naga 2014
    Razer Ferox

    Does anyone have a idea whats going on or anything similar with a fix or a idea?
    I really don't think its a overheating problem but with the fan's it seems to be a indication.
    Been having this issue for a while now and it sometimes.
    Noticed when changing game settings in some games to high+ it happens more frequently.

    Thank you in advance!

  2. #2
    ROG Enthusiast Array
    Join Date
    Mar 2015
    Reputation
    10
    Posts
    28

    Not sure if this helps. But worth checking if your using the dedicated video card via hdmi.

  3. #3
    New ROGer Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    2

    Same issue here with i7, 12 gb ram and again with gtx 750 gpu. I can play Elder Scrolls Online,
    Fallout 4 for hours with near maximum settings. But when i try to play Blade and Soul or Borderlands 2
    it crashes same way with you. İ have seen some comments about the ethernet card is being the problem, but don`t know exactly.

  4. #4
    ROG Guru: Yellow Belt Array Welsh Whoopee's Avatar
    Join Date
    Jan 2016
    Reputation
    17
    Posts
    227

    any chance you can record with your phone and upload so I have a better idea and maybe help, as for the ethernet card problem, try wireless and also use the onboard hdmi instead
    YOUTUBE CHANNEL @ http://bit.ly/2LNo1dI

    ASUS ROG G20 PLAYLIST @ http://bit.ly/2R9njXC

  5. #5
    New ROGer Array
    Join Date
    Feb 2016
    Reputation
    10
    Posts
    2

    I found an interesting thing. My comment will be specific on one game but maybe we can solve the problem from this.
    Now i have 2 computer. One is my old laptop and the other is the new ASUS G20aj.
    I deleted gameguard file for blade n soul on both of them. And when i start the game, my laptop installs the gameguard
    again, but the new one doesn`t install only opens the folder and install one file. I think this is the problem that
    causes all these crashes. I don`t know why but on both of them i ve windows defender.
    On my new computer i had Mcafee and avira but it was way before. What would cause this problem?
    I dont connect my pc directly to the modem, i ve wireless one, i connect the internet with wi-fi.
    Maybe modem is the problem? I don`t know, any ideas?

  6. #6
    New ROGer Array
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    3

    Quote Originally Posted by Welsh Whoopee View Post
    any chance you can record with your phone and upload so I have a better idea and maybe help, as for the ethernet card problem, try wireless and also use the onboard hdmi instead

    Hello, uploaded it to dropbox.
    Here is the link to the video I recorded.

    http://bit.ly/1TpUlQZ

  7. #7
    New ROGer Array
    Join Date
    Jul 2014
    Reputation
    10
    Posts
    3

    Quote Originally Posted by kurbagaprens View Post
    Same issue here with i7, 12 gb ram and again with gtx 750 gpu. I can play Elder Scrolls Online,
    Fallout 4 for hours with near maximum settings. But when i try to play Blade and Soul or Borderlands 2
    it crashes same way with you. İ have seen some comments about the ethernet card is being the problem, but don`t know exactly.
    Exactly the same for me!
    For example I can play Assassin Creed Syndicate/Unity, etc (Max settings), Skyrim (fully moded + enb), BL2 and Fallout 4 without anything happening. But minute I try to play any other specific game it crashes.

    I tried the ethernet to wifi option, also went in to device manager and updated all driver settings and noticed the computer was booting up faster but still resulted in a crash.

    I'm thinking either its a BIOS setting problem when I clean installed Win 10 but I am suspecting that its a software issue from reading other forums.

    I think the problem is any latest game etc that uses DirectX 12 works fine. Anything that requires below 11 crashes, (hence 11, etc.)
    Still kinda clueless but trying to look for solution. :L
    Pretty sure this is a ASUS software issue going on

  8. #8
    ROG Member Array
    Join Date
    Jun 2015
    Reputation
    10
    Posts
    16

    GTX 750 (maybe others) issue

    Not ASUS, happens with MSI also, I think the game is asking too much of the card

    https://forums.bladeandsoul.com/topi...gtx-750-issue/

  9. #9
    ROG Guru: Yellow Belt Array Welsh Whoopee's Avatar
    Join Date
    Jan 2016
    Reputation
    17
    Posts
    227

    Quote Originally Posted by FallenDiscrete View Post
    Hello, uploaded it to dropbox.
    Here is the link to the video I recorded.

    http://bit.ly/1TpUlQZ
    cheers for that,y yeah mine near does that.

    mine can boot up quick and then restarts. sometimes mines crashes at the asus logo, but after a restart it can boot up ok.

    as for blade&soul not running with gtx750, well maybe the card needs to be turned alittle to stop it from throttling to much, I am gonna try it out on my asus computer and let you know the findings
    YOUTUBE CHANNEL @ http://bit.ly/2LNo1dI

    ASUS ROG G20 PLAYLIST @ http://bit.ly/2R9njXC

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •